Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




63 posts

Master Geek


Topic # 113866 30-Jan-2013 14:15
Send private message

Anyone know how to change the time zone within FreePBX so that it reports the correct time that calls were made/received in the call monitor? For some reason the time it shows is 13 hours behind NZ time, even though the time within my Raspberry Pi is set to NZ time.

Create new topic
26197 posts

Uber Geek
+1 received by user: 5796

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 753373 30-Jan-2013 16:57
Send private message

Normally it'll just gets it's timezone from PHP, so you presumably have that wrong in php.ini



172 posts

Master Geek
+1 received by user: 25


  Reply # 753379 30-Jan-2013 17:14
Send private message

http://www.freepbx.org/forum/installation/is-php-timezone-setting-required

If the application gives shell access to the underlying operating system running the date command with tell which time zone applies.

 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


63 posts

Master Geek


  Reply # 753596 31-Jan-2013 07:24
Send private message

Thanks, but can you tell me how you go about setting the time in this PHP thing you mention?


26197 posts

Uber Geek
+1 received by user: 5796

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 753610 31-Jan-2013 08:24
Send private message

php.ini




63 posts

Master Geek


  Reply # 753644 31-Jan-2013 09:14
Send private message

@sbiddle, while I appreciate your posting a response very much, it's completely useless to me since I have posted before that I am not a specialist in Linux or FreePBX or anything beyond what a layperson knows how to do on a computer.

Perhaps I'm posting to wrong forum, but if anyone can give me more or less step-by-step instructions on how to fix my time settings, I'd be grateful.

3343 posts

Uber Geek
+1 received by user: 1112

Subscriber

  Reply # 753726 31-Jan-2013 10:52
Send private message

Could it be the system clock isn't in sync with the hardware clock or vice versa?

Run 'hwclock --systohc'

Never had an issue with time. When you type 'date' on the command line is that the right time? If not you can manually set the time by going 'date mmddhhmmyyyy' which is month, day, hours, minutes, year.



63 posts

Master Geek


  Reply # 753744 31-Jan-2013 11:11
Send private message

Thank you so much, @chevrolux, that did the trick!



63 posts

Master Geek


  Reply # 753751 31-Jan-2013 11:19
Send private message

BTW, I wound up running the following to set the correct time zone, too:

ln -sf /usr/share/zoneinfo/Pacific/Auckland /etc/localtime

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Amazon launches the International Shopping Experience in the Amazon Shopping App
Posted 19-Apr-2018 08:38


Spark New Zealand and TVNZ to bring coverage of Rugby World Cup 2019
Posted 16-Apr-2018 06:55


How Google can seize Microsoft Office crown
Posted 14-Apr-2018 11:08


How back office transformation drives IRD efficiency
Posted 12-Apr-2018 21:15


iPod laws in a smartphone world: will we ever get copyright right?
Posted 12-Apr-2018 21:13


Lightbox service using big data and analytics to learn more about customers
Posted 9-Apr-2018 12:11


111 mobile caller location extended to iOS
Posted 6-Apr-2018 13:50


Huawei announces the HUAWEI P20 series
Posted 29-Mar-2018 11:41


Symantec Internet Security Threat Report shows increased endpoint technology risks
Posted 26-Mar-2018 18:29


Spark switches on long-range IoT network across New Zealand
Posted 26-Mar-2018 18:22


Stuff Pix enters streaming video market
Posted 21-Mar-2018 09:18


Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47


Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25


New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48


Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.