Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2063 posts

Uber Geek
+1 received by user: 214

Trusted
Subscriber

Topic # 144167 9-May-2014 13:07
Send private message

I'm on Vodafone's UFB using my own router connected directly to the ONT. I have the SIP settings copied from the Vodafone supplied router, got my username and password emailed to me from Vodafone, but I'm struggling to get the phone set up.

The SPA112 is connected to the router, I have entered the proxy, my username and password in the appropriate boxes but it fails to register - no tone at all on the phone, just completely dead.

Clearly I'm missing something somewhere, can anyone give me a hand please!




MacBook Pro 13" w/ Touch Bar (Early 2017) | iPad Pro 10.5 Wi-Fi 128GB (Space Grey) | iPhone 8 Plus 64GB (Product RED) | HomePod (Space Grey) | Apple TV 4K | Apple TV (4th Generation) | Apple Watch Series 3 42mm (Space Grey)

Create new topic
4123 posts

Uber Geek
+1 received by user: 842
Inactive user


  Reply # 1040820 9-May-2014 13:33
Send private message

Sbiddle did a write up on how to configure the SPA122 http://www.geekzone.co.nz/sbiddle/7208 which may help

26349 posts

Uber Geek
+1 received by user: 5921

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 1040838 9-May-2014 13:56
Send private message

There are potentially any number of reasons why it won't work, including the fact Vodafone won't allow any devices other than their own hardware to connect. Anybody know if this is the case?

SIP isn't quite a simple as having 3 settings.



 
 
 
 


Try Wrike: fast, easy, and efficient project collaboration software


2063 posts

Uber Geek
+1 received by user: 214

Trusted
Subscriber

  Reply # 1040855 9-May-2014 14:34
Send private message

Ok I thought it was but clearly I'm wrong.

I was using the Huawei router as an ATA but when people called the landline they could hear you, but on our end it was completely silent. Making calls from the phone worked fine. Vodafone said it was all working fine, I couldn't see anything on my router that might have been affecting incoming calls so got my hands on the Cisco SPA112 but now it's even more confusing, so I'm not sure how to get it working.





MacBook Pro 13" w/ Touch Bar (Early 2017) | iPad Pro 10.5 Wi-Fi 128GB (Space Grey) | iPhone 8 Plus 64GB (Product RED) | HomePod (Space Grey) | Apple TV 4K | Apple TV (4th Generation) | Apple Watch Series 3 42mm (Space Grey)

4123 posts

Uber Geek
+1 received by user: 842
Inactive user


  Reply # 1040858 9-May-2014 14:45
Send private message

Are the SIP ports (5060) open on your router?

392 posts

Ultimate Geek
+1 received by user: 205

Subscriber

  Reply # 1040863 9-May-2014 14:55
2 people support this post
Send private message

Port your number to an independent VOIP provider like 2talk. Screw device restrictions. Gain features.

Oh, and 2talk do automated provisioning of SPA112 devices. I know it works well, because I use it.







2063 posts

Uber Geek
+1 received by user: 214

Trusted
Subscriber

  Reply # 1040957 9-May-2014 17:50
Send private message

kiwitrc: Are the SIP ports (5060) open on your router?


They are.

I don't get it. Why can I call from the landline and it works perfectly, but when people call the landline why can they hear me but all I hear is dead silence???




MacBook Pro 13" w/ Touch Bar (Early 2017) | iPad Pro 10.5 Wi-Fi 128GB (Space Grey) | iPhone 8 Plus 64GB (Product RED) | HomePod (Space Grey) | Apple TV 4K | Apple TV (4th Generation) | Apple Watch Series 3 42mm (Space Grey)

3394 posts

Uber Geek
+1 received by user: 1140

Subscriber

  Reply # 1041096 9-May-2014 20:23
One person supports this post
Send private message

corksta:
kiwitrc: Are the SIP ports (5060) open on your router?


They are.

I don't get it. Why can I call from the landline and it works perfectly, but when people call the landline why can they hear me but all I hear is dead silence???


Because NAT is in the way.

One-way speech is almost always NAT/firewall issues - could also be codec.

Remove any port forwards you have in your router but make sure you have a firewall rule to allow 5060 in to the network.

Then on your SPA bring down the registration time to maybe 360 and set it to send SIP OPTIONS every 120-180. That should be enough to cure any NAT issues.

On your 2Talk settings go to 'Voice quality & networking' and disable G729, enable G711a & G722 and set it to "Prefer excellent quality calls".

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41


Exhibition to showcase digital artwork from across the globe
Posted 23-May-2018 16:44


Auckland tops list of most vulnerable cities in a zombie apocalypse
Posted 23-May-2018 12:52


ASB first bank in New Zealand to step out with Garmin Pay
Posted 23-May-2018 00:10


Umbrellar becomes Microsoft Cloud Solution Provider
Posted 22-May-2018 15:43


Three New Zealand projects shortlisted in IDC Asia Pacific Smart Cities Awards
Posted 22-May-2018 15:14


UpStarters - the New Zealand tech and innovation story
Posted 21-May-2018 09:55


Lightbox updates platform with new streaming options
Posted 17-May-2018 13:09


Norton Core router launches with high-performance, IoT security in New Zealand
Posted 16-May-2018 02:00


D-Link ANZ launches new 4G LTE Dual SIM M2M VPN Router
Posted 15-May-2018 19:30


New Panasonic LUMIX FT7 ideal for outdoor: waterproof, dustproof
Posted 15-May-2018 19:17


Ryanair Goes All-In on AWS
Posted 15-May-2018 19:14


Te Papa and EQC Minecraft Mod shakes up earthquake education
Posted 15-May-2018 19:12



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.