Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


MAH



9 posts

Wannabe Geek


#153778 7-Oct-2014 15:24
Send private message

Hi There,

I recently ported my number across to 2Talk and all works fine - except incoming callers experience a long delay (10 secs) between them dialing and them hearing ringing tone. I have a Cisco SP122 ATA. Some callers even hang up before hearing ringing tone because they think my line is faulty.  

Is there a way of reducing this delay.

Thanks....................MAH 

Create new topic
6 posts

Wannabe Geek


  #1149245 7-Oct-2014 16:12
Send private message

Hi,

Will this ring delay disappear if you put the device into the routers DMZ for an incoming call test ? It may be having an issue with RTP ?

Just a thought.

Cheers.

29119 posts

Uber Geek

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  #1149347 7-Oct-2014 18:02
Send private message

Unless you can explain to me in one sentence why placing a SIP device on a DMZ or setting a port forward to it is a good idea (and as a hint "it doesn't work without it" is not an answer) you should never, never, never, never, never, ever place a SIP device on a DMZ or set a port forward to it.

It's not a matter of if you device will be compromised, it's simply a matter of when it will be compromised.




 
 
 
 


6 posts

Wannabe Geek


  #1149417 7-Oct-2014 19:13
Send private message

I suggested it purely for testing purposes. Ruling out issues created by a router, you would never leave it in that state. Then you can go... OK I need to look at the ports on my router, or any other odd ball routeing issues, instead of getting tied up on device issues.

DMZ for testing only.

Cheers.


18 posts

Geek


  #1174916 13-Nov-2014 08:13
Send private message

Hi,

I've recently decided to take the plunge and started playing around with VoIP. I got an SPA112 yesterday and it was exhibiting the same delayed-ringer behaviour when using the configuration suggested by 2talk.

I reset the device and started with a configuration based on simply filling out the Quick Setup fields and found that the problem had gone away. I then proceeded to apply 2talk's settings section by section and ended up finding that the culprit is the use of TLS.

To remove the ringer delay change the following fields on the Line 1/2 pages:

 

  • SIP Transport: UDP
  • SIP Port: 5060
  • Proxy: sip.2talk.co.nz
  • Outbound Proxy: sip.2talk.co.nz
I have an (unconfirmed) suspicion that TLS is not working and falling back to UDP/TCP because of a certificate issue. In 2talk's faq/blog (http://blog.2talk.co.nz/2talkplus.html), they have a link to their certificate details to use with tls.2talk.co.nz, but at this stage I have not been able to find out how/if this should be used on a SPA112/SPA122.

MAH



9 posts

Wannabe Geek


  #1174983 13-Nov-2014 09:56
Send private message

On Page 2 (NAT Support Parameters) I changed......................

 

  • STUN Enable from: [yes] to [no]
  • STUN Test Enable: [yes] to [no]  
and this stopped the delay

495 posts

Ultimate Geek


  #1177045 16-Nov-2014 22:01
Send private message

Green: Hi,

I've recently decided to take the plunge and started playing around with VoIP. I got an SPA112 yesterday and it was exhibiting the same delayed-ringer behaviour when using the configuration suggested by 2talk.

I reset the device and started with a configuration based on simply filling out the Quick Setup fields and found that the problem had gone away. I then proceeded to apply 2talk's settings section by section and ended up finding that the culprit is the use of TLS.

To remove the ringer delay change the following fields on the Line 1/2 pages:

 

  • SIP Transport: UDP
  • SIP Port: 5060
  • Proxy: sip.2talk.co.nz
  • Outbound Proxy: sip.2talk.co.nz
I have an (unconfirmed) suspicion that TLS is not working and falling back to UDP/TCP because of a certificate issue. In 2talk's faq/blog (http://blog.2talk.co.nz/2talkplus.html), they have a link to their certificate details to use with tls.2talk.co.nz, but at this stage I have not been able to find out how/if this should be used on a SPA112/SPA122.


Yes I have had issues with TLS on a SPA122 that I set up last year. After a time it would disconnect from the server and not reconnect. Hence no-one could make or receive calls so I actually put in the the same settings that you have mentioned here and there has been no problem since.

Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.