Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




627 posts

Ultimate Geek
+1 received by user: 42


Topic # 32881 26-Apr-2009 12:29
Send private message

Hi,

Finally got my trixbox setup, the status screen say the IP trunk to VFX is registered and its detected my phone contected via a PAP2T. I've setup incoming and outgoing route, yet when I dail a local number i get an engaged dail tone, and if i try to ring our new VOIP phone number it says the phone number you dial is unavaliable please leave a voice message.

Any ideas? is there something really obvious I'm missing?

Thanks

Create new topic
27258 posts

Uber Geek
+1 received by user: 6688

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 209452 26-Apr-2009 12:34
Send private message

What is your outbound dialplan?

If you do a "sip show registry" are you connected to VFX OK?








627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209455 26-Apr-2009 12:41
Send private message

sbiddle: What is your outbound dialplan?

If you do a "sip show registry" are you connected to VFX OK?



Sorry I dont understand. Are you talking about dial patterns on the outgoing route or dail rules on the SIP trunk or something completely different?

How do you do a sip show registry?

Cheers

 
 
 
 




627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209458 26-Apr-2009 12:43
Send private message

I'm just using the default dail pattern '9|.' as per the guide:

http://www.geekzone.co.nz/tonyhughes/4086

27258 posts

Uber Geek
+1 received by user: 6688

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 209465 26-Apr-2009 13:21
Send private message

First off delete that default rule and replace it with something simple

xx.

And set VFX as the outbound trunk. This removes all need to dial 9 first which is not needed.




627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209468 26-Apr-2009 13:25
Send private message

sbiddle: First off delete that default rule and replace it with something simple



xx.



And set VFX as the outbound trunk. This removes all need to dial 9 first which is not needed.





Done, still gives the same engaged tone. Any other ideas? I can provide screenshots or settings if needed.

593 posts

Ultimate Geek
+1 received by user: 65


  Reply # 209501 26-Apr-2009 16:35
Send private message

Is it a true engaged tone or a disconnect tone?
Disconnect tone will not be the standard bipbipbipbip bipbipbipbip. It will just sound like a slightly quicker busy tone.
If it is disconnect tone it sounds like a bar.



627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209821 27-Apr-2009 16:55
Send private message

Something werid is going on. I added a Freecall.com SIP trunk to try and see if it was the SIP trunk or the outbound route causing the problem.



Its now dialing out with the Freecall.com set as the primary route and everything is fine, which suggest the VFX trunk isn't working, but I got a friend to call me on my VFX phone number and they managed to get through.



Any idea on what might be causing this? It looks to me as if I just can't send calls over the VFX trunk?

27258 posts

Uber Geek
+1 received by user: 6688

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 209833 27-Apr-2009 17:16
Send private message

How do you have your dial plan set up if you're using multiple trunks?




627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209874 27-Apr-2009 18:57
Send private message

Heres my outbound route:





If I change the order around it get a message saying all circuits are busy please try your call again later.



I have no dial rules described for the VFX trunk.



627 posts

Ultimate Geek
+1 received by user: 42


  Reply # 209886 27-Apr-2009 19:29
Send private message

Scratch this post, looks to be working fine now.
I had:

fromdomain=pan.wxcnz.net
host=ax.wxnz.net

Once i changed them to both be pan.wxcnz.net its seems to be working ok now. Time for some fine tuning!

Thanks for all the help. Greatly appreciated!!!

27258 posts

Uber Geek
+1 received by user: 6688

Moderator
Trusted
Biddle Corp
Lifetime subscriber

  Reply # 209893 27-Apr-2009 19:36
Send private message

PANiCnz: Heres my outbound route:




If I change the order around it get a message saying all circuits are busy please try your call again later.



You need to do a bit of reading understanding how trunk access and dial plans work.

That example routes all calls via Freecall. Calls will never go via VFX unless the freecall trunk is unailable and falls over to the VFX trunk.

Since you have no outbound route for VFX it's impossible to make calls.

If you're using multiple providers you need individual outbound routes for each one and either specify what numbers are accessible from each route using the dialplan or create numbered trunk access for each such as 1|. for Freecall and 2|. for VFX meaning you dial 1 to make an outgoing call via Freecall or 2 via VFX.

 

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.