Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

Topic # 230317 18-Feb-2018 16:17
Send private message

I've had my Raspberry Pi2 running Kodi connected to my PC to play movies and such running fine for a couple of years, maybe more. It's generally very good, only stuttering on very high bitrate 1080p movies.

 

The past few days or so Kodi has started regularly pausing during movies it used to play 100% perfectly with no pauses. During slow parts of the movie it  pauses less, it's worst during action scenes. It can pause for 3-5 seconds every 30 to 60 seconds. It's getting really annoying.

 

Kodi CPU usage is about 5% during that time. PC CPU / network / disk are all just over idle. The movie peaks around 8Mbps, the PC is connected to the Fritzbox at 1Gbps Ethernet. The R.Pi2 is connected to Ethernet but only has a 100Mbps adapter, but it has more than enough bandwidth for this. My W10 install is fairly old, I started with the beta version and it's been regularly updated ever since. Might be time for a fresh reinstall, if I ever have time.

 

I noticed the problem started around the same time as the last big Windows update, which was a few days ago.

 

Any ideas how to track the problem down? Anyone else seeing anything similar?





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


Create new topic
608 posts

Ultimate Geek
+1 received by user: 37


  Reply # 1960219 19-Feb-2018 10:58
Send private message

Just wondering if it’s anything to do with the wider shift away from SMB 1. I know with the later releases of LibreELEC they disable SMB 1 support.

Edit - Windows 10 Fall Creators Update (1709) removed SMB 1 also

2627 posts

Uber Geek
+1 received by user: 503


  Reply # 1960223 19-Feb-2018 11:07
Send private message

I have a Pi2 running OSMC(Kodi) and using wifi to a windows 7 share.

 

I have noticed that when I get this sort of problem it is usually my PC. Seems to happen if I have been downloading or had a lot of connections to the internet open. Rebooting the PC seems to fix it - so it seems to be the PC side of things as far as I can see.

 

In my case it doesnt happen too often though.





Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler



13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 1960256 19-Feb-2018 11:32
Send private message

Rebooting unfortunately didn't help. I rebooted a few times. I noticed a couple of upgrades this last weekend, including one big one then a small one after. Rebooted Kodi too. At one point I resorted to watching it on a tablet, from local storage.

 

Usually this kind of stuttering would be the R.Pi2 not able to keep up, but this video has always played perfectly - it's one my son watches very regularly so we know it well.

 

 





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


2627 posts

Uber Geek
+1 received by user: 503


  Reply # 1960284 19-Feb-2018 12:15
Send private message

So I am guessing that the Pi is certainly on wifi.

 

What about the other PC?





Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler



13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 1960294 19-Feb-2018 12:24
Send private message

I slightly tweaked my original post to clarify that both PC and R.Pi2 are connected to a Wired ethernet network. It's a gigabit network off a Fritzbox 7390 but the R.Pi2 only has a 100Mbps ethernet adapter. There's a cheap switch between the 7390 and the PC, but it's been there for 5 years with no issues.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


2627 posts

Uber Geek
+1 received by user: 503


  Reply # 1960369 19-Feb-2018 13:58
Send private message

There seems to be a bit of discussion of SMB v 1 being 'retired' from windows and I found quite a lot of discussioon on what the KODI people were going to do about it.

 

Windows article here https://support.microsoft.com/en-nz/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

 

 

 

But then if it works (a bit/badly) it must still be using SMB - perhaps MS have stuffed it somewhat?

 

Maybe its work investigating setting up your share in NFS and seeing if KODI can connect to that.





Nothing is impossible for the man who doesn't have to do it himself - A. H. Weiler



13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 1960414 19-Feb-2018 15:18
Send private message

I don't really know the difference between SMB and NFS. I just set up a share in Windows by right clicking and choosing Share. How would I set up an NFS share?





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


608 posts

Ultimate Geek
+1 received by user: 37


  Reply # 1960416 19-Feb-2018 15:20
Send private message

I’d start by seeing if SMB1 is disabled and if it is try reenabling it. This will confirm if the issue is with SMB. Once the issue is confirmed you can begin trying to isolate the specifics.



13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 1960457 19-Feb-2018 17:04
Send private message

SMB1 is enabled in Windows Features. In my LAN properties for the Realtek PCIe GBE family controller I have the following enabled:

 

  • Client for Microsoft Networks
  • File and print sharing for MS Networks
  • VirtualBox Driver
  • QOS
  • IP4 over TCP
    Microsoft LLDP Protocol Driver
  • Link Layer Topology Responder
  • Link Layer Topology Mapper I/O Driver


The following is disabled:

 

  • IP6
  • Microsoft network Multiplexor Protocol:

 

 

In advanced network settings I have

 

  • Private: Network discovery on, file and printer sharing on
  • Private: User accounts to connect, not homegroups (I just changed this - Homegroups have never worked for me)
  • Guest: everything on
  • All networks: Public sharing on (just switched it on again, Windows reset it during updates), Media streaming just turned on again, 40 bit encryption, password protected sharing off (just turned off again)


I find Windows resets these settings to the most restrictive after every major upgrade - pretty annoying.

 

So based on poking about I've changed a few minor settings. None of them have made any difference, as I think they're all "all or nothing" settings - if any was causing the problem it'd have prevented access at all. 

 

Watching the movie with my son we had pauses of 16, then 5, then 18 seconds. That's waaay too much for simple buffering.

 

There's nothing suspicious in the Kodi log. The only odd thing in the Windows 10 log is "The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID" - no idea if it's related or not.

 

I'm a bit stuck here. I might try plugging a USB stick with the movie into the R.Pi and see if I can play from that. If it skips there then it's not computer or network. If it doesn't... not sure.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer




13918 posts

Uber Geek
+1 received by user: 2471

Trusted
Subscriber

  Reply # 1960569 19-Feb-2018 20:12
Send private message

I think I've managed to mask the problems by turning on caching on Kodi for the local network. I haven't solved why it started happening, but it works for now and I'm probably not going to bother looking at it again unless it fails again.

 

I used code from this page that looks pretty much like this in my advancedsettings.xml file (which is in .kodi/userdata/ from memory)

 

 

 

<advancedsettings>
  <cache>
    <buffermode>1</buffermode>
    <memorysize>41943040</memorysize>
    <readfactor>15</readfactor>
  </cache>
</advancedsettings>

 

 

 

BufferMode turns on caching for local file systems - default is only for internet based. I doubled the buffer to 40MB (which for some reason takes 120MB of RAM). The read factor increases the buffer fill rate, ie max network bandwidth.

 

As a result, in a quick test I got no skipping, but time will tell.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.