Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

dpw



812 posts

Ultimate Geek
+1 received by user: 13

Trusted

Topic # 27638 2-Nov-2008 14:43
Send private message

Hi folks,

We have machines with these OS installed and have noticed something very annoying. When either machine (1 is the host, the latter is the guest VM) has just been rebooted I cannot connect to them via remote desktop. I can only connect remotely after someone has logged on locally at least once.

Has anyone else encountered this? If so, is there a workaround that will allow me to connect remotely after reboot? The machine is running headless in the garage so having to log on locally is a royal PITA.

Any hints/suggestions would be greatly appreciated!

Cheers,
Dany.




Android user, software developer, a semi-typical (not a gamer) geek, and a Bernese Mountain Dog nut!

http://savitarbernese.com | https://nz.linkedin.com/in/danywu

Create new topic
BDFL - Memuneh
61339 posts

Uber Geek
+1 received by user: 12084

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 175258 2-Nov-2008 14:53
Send private message

Not a solution for this problem exactly, but why not install Logmein Free? The benefit here is that it's accessible from almost anywhere from just a browser - and no need to do port forward on your routers, firewalls, etc.

I use Logmein IT Reach on my servers (paid version), Logmein Free on my client machines, and Logmein Hamachi on all my machines to create my VPN.




dpw



812 posts

Ultimate Geek
+1 received by user: 13

Trusted

  Reply # 175261 2-Nov-2008 15:05
Send private message

That's one possibility but seems pretty crazy to connect between machines less than 10 m away. I'm not entirely sure how LogMeIn works, whether it connects through a gateway somewhere, or directly between the two machines.




Android user, software developer, a semi-typical (not a gamer) geek, and a Bernese Mountain Dog nut!

http://savitarbernese.com | https://nz.linkedin.com/in/danywu

dpw



812 posts

Ultimate Geek
+1 received by user: 13

Trusted

  Reply # 175333 2-Nov-2008 21:47
Send private message

Just noticed something in this case - it seems someone has to be logged on locally before anyone can remote desktop into that machine. Have I missed a setting somewhere?




Android user, software developer, a semi-typical (not a gamer) geek, and a Bernese Mountain Dog nut!

http://savitarbernese.com | https://nz.linkedin.com/in/danywu

dpw



812 posts

Ultimate Geek
+1 received by user: 13

Trusted

  Reply # 175336 2-Nov-2008 22:06
Send private message

Right - it seems I have discovered that missing setting. When enabling Remote Desktop connections chose to allow only clients with Network Level Authentication. That seems to have fixed the problem. According to the docs this will disallow older Remote Desktop clients - I guess I won't have a problem since I don't have "older" clients....




Android user, software developer, a semi-typical (not a gamer) geek, and a Bernese Mountain Dog nut!

http://savitarbernese.com | https://nz.linkedin.com/in/danywu

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.