Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




5799 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

# 38789 4-Aug-2009 12:24
Send private message

Hi there


I've got a sticky one that I'm hoping I can get some help with.


My WHS has been working perfectly for ages, no problems until I decided to use to to test a VPN connection to my office.


I installed the WatchGuard Mobile VPN software to test an IPSEC tunnel that I'd set up.  I was remotely connected to my server from my office when I did this.


On installing the software I guess the installation reset the NIC as I lost my connection.  I was expecting this, but I couildn't get back on after the time it should have taken for the NIC to come back up.


I waited until I got home and logged into the WHS itself to take a look - the thing had locked up when installing the VPN software.  I rebooted and then uninstalled the software.  I also ran CCleaner to take out any registry keys that may have lingered.  I then removed any traces of the folder structure for the VPN software.


I rebooted again and went upstairs. tried RDPing my server and got connected successfully.


It wasn't until later that night when I turned on the Xbox and tried to access one of the folder shares on the WHS that I realised it wasn't showing up on the network.  I did all the usual tests on the Xbox and still couldn't get the shares to appear.  I also tested from my MacBook Pro which I'm always able to map shared folders on - but every time I tried to map the folder it said that the connection did not exist.


The WHS doesn't even show up in my list of shared items in Finder or Path Finder.  I loaded up an XP VM on my Mac and tried to map to the UNC - no joy either as it just couldn't see the WHS.  I cleared all my DNS cache from the Mac and VM and tried again - nope.  Can't connect using IP OR DNS name.


I then disabled the WHS firewall - nothing.
I uninstalled File and Print Sharing from the WHS, rebooted, and reinstalled the service - nothing.  After doing this I had to enable the shares again so I did so on one folder.  Tested mapping it - nothing


I left it alone for a while and played a little Secret of Monkey Island SE.  Came back an hour or two later and lo - the shared folder I enabled is now showing on my Xbox and I can access the files in it?!?!  I tried again from my Mac and XP VM but the same thing happened - cannot connect!!!!!!!!!


I tried to open the WHS console on the WHS to see what was going on but it keeps crashing - the Application event log comes up with a .NET error after about a minute of trying to load the console: ".NET Runtime 2.0 Error Reporting: EventType clr20r3 P1 homeserverconsole.exe P2 6.6.6.6. P3 49ed39c1 P4 whscommon...... etc etc system.io.ioexception P10 NIL"


The HomeServer event log shows no errors or warnings, nor does System.


I checked the routes on my WHS - all look standard and are pointing to the right places.  Hmm what else did I do?  Oh I created a new workgroup on the WHS and rebooted - still not showing.


So clearly the VPN software did something it shouldn't have and I've learned my lesson there :)  But I'm stumped now as to what the problem could be.  Either it's something very simple that I've overlooked, or it's going to require a repair of the OS...


Question1: any idea what I've missed or need to check for now?


Question2: If I have to repair the OS on my WHS will that effect my data drive(S) in any way?  The OS is on it's own separate drive but I have a good 5 or 6 other drives with all my data on them and I don't want to lose that data.  Can WHS repair itself and then rebuild the data array without any problems or data loss?


Thanks Geeks!
G.

EDIT: I just tried to access another computer FROM the WHS and I can't access it either - but yet the Xbox still seems to be working.  So so weird.


EDIT2: I just tried mapping one of the shares on the actual WHS box itself, and I can't even do that - ie on WHS I went to Map Network Drive and tried to give one of the shares on the box a drive letter - can't access it at all. 


EDIT3: turns out I have two separate problems, I just fixed the networking issue by resetting the TCP/IP settings using NETSH (netsh int ip reset c:\resetlog.txt).  I can map to the drives now on the local WHS and the network clients.  Sigh of relief ensues!  Now on to the WHS Console issue!


EDIT4: SORTED!  The network reset must have resolved any issue with the WHS console too.

Create new topic
420 posts

Ultimate Geek


  # 245854 12-Aug-2009 22:22
Send private message

Hi Gehenna

Interestingly as I got home today I also found WHS was not visible on the network. Your NETSH command solved the problem though (thanks for that). I have noticed in the past that when WHS looses the network connection (often through a router reboot), it no longer appears as a network resource on other networked computers.

I could access the machine directly this evening using \\server without any problems, but Windows Explorer just would not browse to the server unaided. I also tried restarting the WHS Computer Browser service with no impact. An RDC connection worked fine as did the Home Server Console.

Given that your IP reset solves the problem it does tend to suggest that the problem is related to an IP issue, either the loss of its IP address or a router interruption.

Cheers Mike

204 posts

Master Geek


  # 245871 12-Aug-2009 23:31
Send private message

Hi Gehenna,

still having issues with this one??




I would love to change the world, but they won't give me the source code

#BOFH

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Microsoft launches first Experience Center worldwide for Asia Pacific in Singapore
Posted 13-Nov-2019 13:08


Disney+ comes to LG Smart TVs
Posted 13-Nov-2019 12:55


Spark launches new wireless broadband "Unplan Metro"
Posted 11-Nov-2019 08:19


Malwarebytes overhauls flagship product with new UI, faster engine and lighter footprint
Posted 6-Nov-2019 11:48


CarbonClick launches into Digital Marketplaces
Posted 6-Nov-2019 11:42


Kordia offers Microsoft Azure Peering Service
Posted 6-Nov-2019 11:41


Spark 5G live on Auckland Harbour for Emirates Team New Zealand
Posted 4-Nov-2019 17:30


BNZ and Vodafone partner to boost NZ Tech for SME
Posted 31-Oct-2019 17:14


Nokia 7.2 available in New Zealand
Posted 31-Oct-2019 16:24


2talk launches Microsoft Teams Direct Routing product
Posted 29-Oct-2019 10:35


New Breast Cancer Foundation app puts power in Kiwi women's hands
Posted 25-Oct-2019 16:13


OPPO Reno2 Series lands, alongside hybrid noise-cancelling Wireless Headphones
Posted 24-Oct-2019 15:32


Waikato Data Scientists awarded $13 million from the Government
Posted 24-Oct-2019 15:27


D-Link launches Wave 2 Unified Access Points
Posted 24-Oct-2019 15:07


LG Electronics begins distributing the G8X THINQ
Posted 24-Oct-2019 10:58



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.