Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




6 posts

Wannabe Geek


# 207506 29-Dec-2016 20:31
Send private message

HI,

I'm a first time forum poster here, so am hoping the image will attach to the post. I am new to Linux - got into it when my laptop Win7 crashed 6months ago, started with and stayed with Kubuntu and have been learning about Terminal etc as I go. I knew a little bit of DOS back in the day, and have worked my way through from Win95 generations onwards as a home user with a bit of driver installation and re-installation and partition work as I went.
The initial problem:
I've been trying to restore Windows Vista on an Acer Veriton using a LiveUSB Kubuntu16.04 i386 DVD to get me access to the drives etc.
C:drive doesn't appear in Dolphin, but does appear as a /dev/sda2 when looking with >lsblk and >fdisk -l

Initially Windows booted up to the Repair point and I asked for repair attempt off the Vista DVD, which it attempted for hours, but it never rebooted properly again after this, and I've only been able to view the drives via the linux live disk now.

my guess so far is the the C:Drive has lost its partition table.   I'd hoping to be able to restore the partition/s or bootsector so that I can re-run the windows repair dvd again and recover back to Vista.   The History: 1.
I have run;
>ntfsfix /dev/sda2 (for C:drive) which said various volume and bootsector errors  and finished with 'you should run chkdsk >ntfsfix /dev/sda3 (for D:drive) which said   partition processed successfully.

2. I then ran Boot-Repair (repository at ppa:yannubuntu/boot-repair) output at http://paste2.org/g0CPyhjA

 

I don't know much of what the output means, but the pastebin output indicates to me that sda2 was an unknown partition type.

 


3.  
Now I have run >fsck -N /dev/sda2 and sda3, but the fsck doesn't seem to be working properly compared with what I see on many websites/forums. Yes I know the -N switch means it won't actually carry out any repair, but I was expecting better dialogue back that what I'm getting.
I unmounted the drives first.   I would like to get some response out of the fsck -N switch before I move on to proper fsck repair so that I know what it's problem is and what it is going to try to do.

fsck screenshot attached.   The Problem Now: fsck output not what I'm expecting. I'm only getting... [/sbin/fsck.ext2 (1) -- /dev/sda2] fsck.ext2 /dev/sda2    and i'm not sure what that even means, I assume it is just naming the package that it is attempting to use before it goes off and does it.  takes about 10-20 seconds before the cursour reappears. Am I doing it right...?   Hey if it says it's broken then at least I'll know where it's at, but it just doesn't seem to tell me anything. It looks like it has tried to treat it as an Ext2 partition, but I'm wanting it to treat it as a WindowsVista (NTFS?) partition(?).  Do I need to add another package elsewhere?    

 

Anyone know if I'm doing the fsck correctly? Any help or knowledge gain appreciated.

 

 

 

 

 

          


Create new topic
126 posts

Master Geek
Inactive user


  # 1696320 29-Dec-2016 20:47
Send private message

I won't even begin to tell you how to fix an NTFS in *buntu but, here's a website that might help;

 

 

 

http://www.ubuntututorials.com/chkdsk-fsck-ntfs-ubuntu/

 

 

 

Me... I'd try real hard to copy off everything I could before I mucked around with it.  I wish I could be more help but, you might be sailing on the last moments of the Titanic right now.  You can Google "fsck, ntfs" and see what a bunch of people are saying about it.




6 posts

Wannabe Geek


  # 1696358 29-Dec-2016 21:52
Send private message

Thanks Mr Weed.

 

What I did figure out though, was I needed to be using fsck -n rather than fsck -N.  The instructions I was following must've been for a different fsck version.

 

Will keep working on it....


 
 
 
 


126 posts

Master Geek
Inactive user


  # 1696360 29-Dec-2016 21:54
Send private message

fnarg7:

 

Thanks Mr Weed.

 

What I did figure out though, was I needed to be using fsck -n rather than fsck -N.  The instructions I was following must've been for a different fsck version.

 

Will keep working on it....

 

 

 

 

Aye, right.  Good luck with it.  That's the one thing I worry about most... losing all my research work due to a corrupted system.


86 posts

Master Geek

Subscriber

  # 1696399 29-Dec-2016 23:29
Send private message

Firstly, using fsck to repair an NTFS partition, doesn't sound a good approach.  If the data are important, making an image backup would be my first priority, either the whole disc or the partitions individually.  Any attempts at fixing might make things worse.

 

Then TestDisk   http://www.cgsecurity.org/wiki/TestDisk

 

maybe from systemrescuecd from https://www.system-rescue-cd.org/ (written to a USB stick).  It's helped me a lot a few times over the years.

 

More positively, check out the independent Kubuntu Forums, https://www.kubuntuforums.net/ - it's very newbie friendly as linux forums go, but always try and search before you post.


Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Arlo unveils its first video doorbell
Posted 21-Oct-2019 08:27


New Zealand students shortlisted for James Dyson Award
Posted 21-Oct-2019 08:18


Norton LifeLock Launches Norton 360
Posted 21-Oct-2019 08:11


Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18


Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36


MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28


Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15


D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31


Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.