Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




323 posts

Ultimate Geek
+1 received by user: 48


Topic # 245585 11-Feb-2019 23:32
Send private message quote this post

starting a new sever and im using php-fpm 7.1

 

keep getting warning like this

 

WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 0 idle, and 9 total children

 

i change my default  www.conf to below but still getting warnings

 

my setting are

 

pm = dynamic

 

pm.max_children = 17

 

pm.start_servers = 2

 

pm.min_spare_servers = 1

 

pm.max_spare_servers = 3

 

pm.process_idle_timeout = 10s;

 

pm.max_requests = 1000

 

 

 

server has 1 core cpu and 2gb ram running Ubuntu 18 with Apache

 

any tips ?


Create new topic
Mr Snotty
8302 posts

Uber Geek
+1 received by user: 4272

Moderator
Trusted
Lifetime subscriber

  Reply # 2176821 11-Feb-2019 23:58
Send private message quote this post

What is this server hosting? It can be hard to balance this depending on how much ram each process uses. Really, it is trial and error. For a site that achieves ~3mil hits per day (running PHP-FPM, Apache with a seperate database server) I have this:

 

pm = dynamic
pm.max_children = 50
pm.start_servers = 20
pm.min_spare_servers = 10
pm.max_spare_servers = 35
pm.max_requests = 1000

 

The server has 2x Virtual CPU cores and 4gb of ram with NVME backed storage (I also have 4gb allocated to SWAP) and the site it hosts runs quickly. This is what works for me, but it may not work for you.







323 posts

Ultimate Geek
+1 received by user: 48


  Reply # 2176824 12-Feb-2019 01:08
Send private message quote this post

vultr vps im using with 1 core

 

forgot to post i have a 2gb swap too and MySQL on another server

 

ill test with about half of what you got

 

pm = dynamic
pm.max_children = 25
pm.start_servers = 10
pm.min_spare_servers = 5
pm.max_spare_servers = 16
pm.max_requests = 1000

 

what do you use in mpm_event.conf ?? on Apache ?

 

mine is keep as default settings

 

 

 

 

 

 


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.