Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

71 posts

Master Geek

Topic # 57721 22-Feb-2010 21:49
Send private message

Hi all,

just installed Ubuntu Netbook remix on my acer aspire one, 
and come across a problem Ive never faced before. Im able to Connect to my router (and access it through the internal ip address) but as soon as i try access anything outside of my network there is nothing! 
This i found odd as first i thought it might have just been my Routers problem, but seeing as all my other computers were connected to it with no problems (wired and wireless) I quickly traced the problem back to the laptop. 

After this i decided to see if after a simple update would fix the problem. so i connected it up through the Ethernet port... once again it connects to the router... but no internet!

after looking around several sites and on several different forums, i noticed that im defiantly not the only one having this problem. My only problem is that in most other case the people having the same problems as me can access the internet through their ethernet cable (download software, etc) which leaves me in a bit of a hole.

one suggestion i have seen is that i should install the madwifi drivers, (my other computers have internet access, would this work if i download it onto this and transfer it accross?). although im not sure if this is the problem as the wireless is actually connecting to the router (being able to access it).

another suggestion ive had is to install the wicd network manager as apprantly the preinstalled one dosent work with some wireless devices. one problem with this is that the installation and downloading has to be done through the terminal, which is a problem because... once again i cant access the internet!!!

every now and again i can access the google homepage, but as soon as i try and search anything, or enter a url it simply dosent respond. this leads my to believe that it is connected to the internet, just at a very very very slow speed.

arrrrggghhh.....! it feels like im going in circles!
almost ready to install 9.04 Netbook remix and see if i have any luck with that!

I have tried everything in my knowledge, but with no success!
please help me put the 'Net' back in my 'Netbook'... other wise its just a book... and we know how boring they are!

Any suggestions would be much appreciated 

Thanks in advance

Create new topic
124 posts

Master Geek
+1 received by user: 1

  Reply # 301280 22-Feb-2010 23:12

If you can connect to your router, then can't see any gain from changing to madwifi drivers.

Don't know about your particular distro (assume this remix is based on 9.10?) but the latest openSuse (11.2) provided an update to "network manager" specifically to address a problem with DNS/routing info not being passed on dhcp connection "in some configurations". The latter part suggesting it was only affecting certain adapters...and as mine worked anyway I didn't bother investigating further !

Suggest manually configuring your ip, routing (gateway address should be all you need, i.e. your router) *and* providing your ISPs (or anyone elses you may prefer) DNS server(s)

Then see if you can connect and maybe see if there are any updates.

Should add that all the issues I've seen around netwoork manager over the past few months have been in the KDE DE, and I'm assuming the Ubu netbook remix uses Gnome.

One other thing to consider is that a few recent distros have had problems where IPv6 is enabled by default and just doesn't play on a v4 network - so if your distro has v6 enabled and you are not using a full v6 network (which you probably are not!), see if that can be disabled


57 posts

Master Geek
+1 received by user: 1

  Reply # 301393 23-Feb-2010 10:14
Send private message

if you know how to open a terminal and do:

netstat -rn

and print that here, that might help. You might not get a default route.


71 posts

Master Geek

  Reply # 301553 23-Feb-2010 16:07
Send private message

hi, sure

got this

Kernal IP routing table
Destionation          Gateway       Genmask        Flags      Metric    Ref   Use Iface      U              1000       0       0     wlan0                  U               2             0       0    wlan0                         UG            0             0       0    wlan0


dosent seem that the Destionation and Gateway are on the same line. could this be the problem?

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Stuff Pix enters streaming video market
Posted 21-Mar-2018 09:18

Windows no longer Microsoft’s main focus
Posted 13-Mar-2018 07:47

Why phone makers are obsessed with cameras
Posted 11-Mar-2018 12:25

New Zealand Adopts International Open Data Charter
Posted 3-Mar-2018 12:48

Shipments tumble as NZ phone upgrades slow
Posted 2-Mar-2018 11:48

Oppo R11s: high-end Android, budget price
Posted 27-Feb-2018 16:27

Samsung New Zealand introducing the Galaxy S9 and S9+
Posted 26-Feb-2018 07:00

Fujifilm X beats its best with new top of the range, high-performance camera
Posted 24-Feb-2018 14:05

One million kiwis affected by cybercrime
Posted 24-Feb-2018 13:58

New Zealanders want to engage with government online and via mobile apps
Posted 24-Feb-2018 13:56

Samsung launches Samsung Max
Posted 24-Feb-2018 13:52

CPTPP text and National Interest Analysis released for public scrutiny
Posted 21-Feb-2018 19:43

Foodstuffs to trial digitised shopping trolleys
Posted 21-Feb-2018 18:27

2018: The year of zero-login, smart cars & the biometrics of things
Posted 21-Feb-2018 18:25

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.