Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

338 posts

Ultimate Geek

# 84405 30-May-2011 15:44
Send private message

Got a new laptop, Dell E6410 with i5 + Nvidia Video card. But a whole weekend trying to install ANY Linux with
no luck!

Is me or Linux become too hard lately?

Used to install Ubuntu on my Desktop or Laptop for a few years and it was always a walk in the park.

But but but, with the crazy UEFI patition and Windows 7 GPT partiton, and it doesn't help that Nvidia NVS Video
card are well supported by Linux. None of my old Ubuntu/Debian/Gentoo/Knoppix  disks are able to
boot successful with UEFI boot loader. And I downloaded all the newest and greatest Ubuntu 11.04, Fedora 15, none could load with UEFI either.

With Ubuntu, it is understandable that it didn't support UEFI load yet, but Fedora 15, which suppose to support that, I tried their USB boot loader, and netinstaller ISO, which should be load with UEFI, no, only show me a ugly Gurb command line with no useful error message or anything message tell me what's going on.

Last night, finally give up on UEFI, trying to load Ubuntu BIOS, still either Grub are not installed if trying to
installed to MBR or just give me a blank screen with nothing show if installed into other partition.

Wow, seems that after 5 years using Linux daily, Linux is still too hard for me.

Create new topic
384 posts

Ultimate Geek

  # 475803 30-May-2011 16:11
Send private message

Easy enough to install if you're willing to follow the steps - (read the Ubuntu passage) and

Support a locally made Linux based Operating System, try Linux Lite.
Download Linux Lite

384 posts

Ultimate Geek

  # 475806 30-May-2011 16:27
Send private message

Theres even a Dell Ubuntu ISO for your laptop, which I would try first

Support a locally made Linux based Operating System, try Linux Lite.
Download Linux Lite


338 posts

Ultimate Geek

  # 475840 30-May-2011 17:57
Send private message

valtam: Easy enough to install if you're willing to follow the steps - (read the Ubuntu passage) and

Thank, don't know about the Ubuntu hardware wiki until this morning, I even came to the same pages above, will give it a go this night if got time.

338 posts

Ultimate Geek

  # 475845 30-May-2011 18:04
Send private message

valtam: Theres even a Dell Ubuntu ISO for your laptop, which I would try first

The ISO looks good, but  it is actually a recover disk, which means it will most likely destroy all my data or other OS.  There will be no data as it is a new laptop, but I want install a dual boot, otherwise I already done it yesterday.

As a fact, Ubuntu is E6410 is official supported by Dell, but only pre-installed by Dell, and I would assume it is
Ubunut only.

Anyway, if nothing else, I will try the ISO to see how they handle the UEFI stuff.

384 posts

Ultimate Geek

  # 475848 30-May-2011 18:09
Send private message

Support a locally made Linux based Operating System, try Linux Lite.
Download Linux Lite

338 posts

Ultimate Geek

  # 476288 31-May-2011 16:53
Send private message

Kind of busy last night, only got time trying to revive my Fedora 15 installation.

Tried few kernel boot options, none working, still got a blank scree with a blank cursor. At this
stage, I am quite sure that this is not a video driver or something to do with Kernel, it is a Grub issue, and
even without a Grub fail message!

My theory is that Grub failed to install because of the existence of UEFI partition. As I boot the Fedora/Ubuntu with BIOS (emulation) options, Grub assume there will be a MBR, but because I installed
Windows 7 with UEFI boot option, there is no MBR in my Hadrdrive! So with my current set up, I am stuck
either way, with UEFI, none of the Linux will able to boot and install, using BIOS simulation, they will boot
and install, but Grub will fail to install because there is no MBR in hard drive.

Looks though all the posts, all the people successfully install Linux in their E6410, none mentioned
how they handled their UEFI partition, why?

My other theory is a. None bother with boot with UEFI option, or install Windows 7 with UEFI option, or more likely b. my E6410 is manufactured this year, February I think, and unfortunately, or fortunately, it come with a
UEFI firmware but the old batch of E6410s come with BIOS. All the people either have their E6410 pre-installed
with Windows 7 with BIOS and MBR, or installed them with old BIOS and update to new UEFI, but will still
have their MBR but not UEFI partition unless they reformat their hard drive.

I am unfortunately a very rare case, as I bought my one from Dell refurbished.       

384 posts

Ultimate Geek

  # 476289 31-May-2011 16:59
Send private message

Bring your laptop to me, I'll definitely get Linux on it.

Support a locally made Linux based Operating System, try Linux Lite.
Download Linux Lite


338 posts

Ultimate Geek

  # 476555 1-Jun-2011 09:18
Send private message

Thank you Valtam for the help, I think I'll try to make it work myself. Not a Linux expert myself by any means, but one thing I learned after few years using it is that:'It is hard because you haven't tried it'.

In my case, I've tried one of the E6410Boot disk from Mac tri-boot tutorial, and it wouldn't boot under UEFI. So yeah, all the E6410 been successful installed Ubuntu is in BIOS as far as I know. There are few possible route of install Ubuntu under UEFI, but I haven't see any clear information on how to do that, one guy did tried on a Alpha version of 11.04 successfully, but couldn't recall the details, and a few people asked about how to do that in Ubuntu forum and seems none bothered to do that in the end, and Ubuntu and Grub development still in the stage of trying to gather enough information for testing UEFI installation.

So yeah, it is doable, but challenging for me as well , the only thing I hope is it wouldn't took too long as I have my Desktop Motherboard and CPU upgrade plan due this weekend.

338 posts

Ultimate Geek

  # 477707 4-Jun-2011 12:14
Send private message

Tried Opensuse, it uses ELILO, suppose has better support for UEFI, still stuck, booting from USB disk, it will throw me a GRUB command line immediately, I can type 'boot' 'linux' etc, but as 'ls' 'find' doesn't working, so it is almost useless for me; or it will show me a blank screen if boot from CD/DVD after I choose install/try/test disk options.

Last night, I tried following Ubuntu UEFIBooting but got stucked after compiled GRUB-EFI and boot from UEFI, basically I got the same thing: boot directly into GRUB command, but this time around I can use 'ls', so I thought 'Cool, at least I can start from here'. but still couldn't work out the correct grub.cfg, and after fruitless tried a few hours, I realized that probably where all the Linux installation failed, and I am hitting the same road block here, the best thing I can do now is go to sleep.

But this morning, after update DELL BIOS from Version A07 to A09(just out), and tried install from Live CD, now I can boot under Legacy. Seems boot
under UEFI still doesn't not working. But I really need move on now. At least I got dual boot working, Windows 7 under UEFI, Linux not yet, but seems either I can do it myself if I want spend more time or just waiting Linux community to catch up with new hardware and probably a new BIOS from DELL will fix things up.   

Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18

Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36

MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28

Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15

D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31

Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29

Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24

Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59

Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07

Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02

Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41

Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36

2degrees Reaches Milestone of 100,000 Broadband Customers
Posted 1-Oct-2019 09:17

Nokia 1 Plus available in New Zealand from 2nd October
Posted 30-Sep-2019 17:46

Ola integrates Apple Pay as payment method in New Zealand
Posted 25-Sep-2019 09:51

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.