Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


92 posts

Master Geek


Topic # 84560 2-Jun-2011 12:29
Send private message

Hi Guys

I have recently turned and old desktop into a home server by installing Ubuntu 10.04 and Samba.  

Forgive me for my noobness

I have ensured that the workgroups are all the same and everyone is on the same network.

The desktop has 2 external hard drives plugged into it.  

From my laptop which is Windows 7 i can access the the shared folders i have set up.

The issue is my flatmates.  They both have laptops running vista.  Ubuntu shows up in their network folder and they can see all the folders that are shared but neither can access to shared folders on the hard drives. i.e. they can both access the videos folder on the hard drive of the computer but when ever they try to access the external hard drive folders they recieve an error.

Any ideas on what to try?

Thanks in advance


Create new topic
7 posts

Wannabe Geek


  Reply # 495203 19-Jul-2011 11:58
Send private message

It sounds to me like you have a problem with your permissions settings.

Right click on the folder you want to share, go into the "Permissions" tab, and make sure that "Others" have folder and file access. Also push "Apply Permissions to Enclosed Files".

If you'd rather do this through terminal then type in "chmod -r 777 [your directory path here]". Note that doing this grants full read/write access to everyone browsing that folder - that might not be what you're after. http://en.wikipedia.org/wiki/Chmod will show you how to better configure chmod for your specific use case.

Good luck!

606 posts

Ultimate Geek
+1 received by user: 38


  Reply # 495225 19-Jul-2011 12:33
Send private message

Could it be a security policy issue in the client...
http://www.crc.id.au/2006/11/23/windows-vista-and-samba-shares/

Although I'm not sure that's the answer, but it might be useful to compare in the Vista and Win 7 clients.
I'm not sure, but later versions of samba might support NTLMv2.
 

8025 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 495248 19-Jul-2011 13:00
Send private message

Ideally check the smb.cnf and make sure NTLMv2 is enabled, otherwise if need be you can downgrade the security setting in Vista to allow NTLM (ie: v1) to be used.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

N4L helping TAKA Trust bridge the digital divide for Lower Hutt students
Posted 18-Jun-2018 13:08


Winners Announced for 2018 CIO Awards
Posted 18-Jun-2018 13:03


Logitech Rally sets new standard for USB-connected video conference cameras
Posted 18-Jun-2018 09:27


Russell Stanners steps down as Vodafone NZ CEO
Posted 12-Jun-2018 09:13


Intergen recognised as 2018 Microsoft Country Partner of the Year for New Zealand
Posted 12-Jun-2018 08:00


Finalists Announced For Microsoft NZ Partner Awards
Posted 6-Jun-2018 15:12


Vocus Group and Vodafone announce joint venture to accelerate fibre innovation
Posted 5-Jun-2018 10:52


Kogan.com to launch Kogan Mobile in New Zealand
Posted 4-Jun-2018 14:34


Enable doubles fibre broadband speeds for its most popular wholesale service in Christchurch
Posted 2-Jun-2018 20:07


All or Nothing: New Zealand All Blacks arrives on Amazon Prime Video
Posted 2-Jun-2018 16:21


Innovation Grant, High Tech Awards and new USA office for Kiwi tech company SwipedOn
Posted 1-Jun-2018 20:54


Commerce Commission warns Apple for misleading consumers about their rights
Posted 30-May-2018 13:15


IBM leads Call for Code to use cloud, data, AI, blockchain for natural disaster relief
Posted 25-May-2018 14:12


New FUJIFILM X-T100 aims to do better job than smartphones
Posted 24-May-2018 20:17


Stuff takes 100% ownership of Stuff Fibre
Posted 24-May-2018 19:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.