Samba (Windows file sharing in *nix enviroments) is somewhat... tempremental.

I constantly have problems like this with it.

Try:

1) Unshare - EVERYTHING
2) Turn off file sharing
3) Turn on file sharing (and enable SMB / Windows file sharing in options)
4) Share the folders you want