Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




635 posts

Ultimate Geek
+1 received by user: 32
Inactive user


Topic # 24042 13-Jul-2008 22:14
Send private message

Hi folks,
I have a odd problem with always_on.sh script. 

But first some background, my setup is this:

internet>--<302G>--<DD-WRT Router>--<PC>

The problem is that when my modem disconnects, and subsequently reconnects (which happens in the space of a few seconds) the script is not detecting the new IP and therefore not running renew DHCP.  

With my very basic skills, i have worked out that, for some reason after the modem disconnects and reconnects, I can still ping the old gateway address, yet I cant ping google (IP or name). 

I looked closer at what the DD-WRT is getting from my modem in half bridge:  

WAN Config 
IP Address : 118.92.137.122 
Subnet mask : 255.255.255.255 
Gateway : 118.92.137.122 
DNS1 : 203.109.129.67 
DNS2 : 203.109.129.68  

Notice how the Ip Address and the gateway are the same? I am not sure if they are the meant to be the same, but I think that is why the always on script (which tests if the connection is up by pinging the gateway) can still ping the gateway, even if the modem has since disconnected and got a new IP. Does anyone know if (a) I have screwed something up or (b) its behaving this way by design?  

The script: http://www.dd-wrt.com/wiki/index.php/Useful_Scripts#Automatic_Connection_Repair_.28always_on.sh.29  

LAN Setup 

MAC Address00:06:25:C4:81:EF  
IP Address192.168.1.1  
Subnet Mask255.255.255.0  
Gateway0.0.0.0  
Local DNS0.0.0.0  

WAN Connection Type : Auto Config - DHCP  
Router Name : DD-WRT 
Host Name : Geek 
Domain Name :  

Router IP Local Address : 192.168.1.1 
Subnet: 255.255.255.0 

Gateway: 0.0.0.0 
Local DNS: 0.0.0.0  
Network Address Server Settings (DHCP) DHCp Type : DHCP Server DHCP Server : Enable 
Start IP Address : 192.168.1.100 Static DNS1: 203.109.129.67 Static DNS2: 203.109.129.68  

If anyone who can help needs more info please just ask!!! :D Thanks in advance,  

-Al 
PS: And yes I could just make the script ping one of the DNS servers, but I would like to know why its not working the way its designed!? :D :D :D
PPS: I notice the gateway address is not defined in the 302G either

Create new topic


635 posts

Ultimate Geek
+1 received by user: 32
Inactive user


  Reply # 147608 13-Jul-2008 22:43
Send private message

Things get even more interesting if I use my Linksys AM300 Modem instead of the Dlink 302G.

When using the AM300 it displays a Gateway address that is different to my IP:

AM300:
PPP Login:Up
Internet IP Address:118.93.33.54
Internet Netmask:255.0.0.0
Internet Gateway:203.109.128.90

Then in my DD-WRT instead of the gateway and IP being the same I get:
IP Address 118.93.33.54 
Subnet Mask 255.255.255.0 
Gateway 118.93.33.254 
DNS 1 203.109.129.67 
DNS 2 203.109.129.68 

That creates a whole new question - why is the gateway listed by the AM300 different to what the DD-WRT router shows? Maybe something to do with having to be on the same subnet?

-Al



635 posts

Ultimate Geek
+1 received by user: 32
Inactive user


  Reply # 147612 13-Jul-2008 22:49
Send private message

Interestingly the script works with the AM300, so the problem lies squarly with the Dlink 302G and it not passing any form of gateway address to the DD-WRT router......

 
 
 
 


1970 posts

Uber Geek
+1 received by user: 128

Trusted

  Reply # 148720 17-Jul-2008 02:24
Send private message

It should not use "Auto Config - DHCP" for the WAN, must always be PPPoA. I would say clear it to factory default and start again, perhaps test any NAT port forwarding or DMZ settings you can find instead of half-bridge.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^



635 posts

Ultimate Geek
+1 received by user: 32
Inactive user


  Reply # 148729 17-Jul-2008 07:22
Send private message

No it shouldnt - the modem is in half bridge mode, it terminates the PPPoA connection and then passes the real world IP (via DHCP) to the Router.

840 posts

Ultimate Geek
+1 received by user: 46

Subscriber

  Reply # 151345 25-Jul-2008 16:11
Send private message

The free via xtra 302g in half bridge is poor at best I remember trialing several we ended up using a US Robotics USR9105 which worked out to be a very good router for half bridge mode.  Nowadays I would just get a Draytek Vigor 110 ADSL modem (yes its a real modem) read here and here

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel reimagines data centre storage with new 3D NAND SSDs
Posted 16-Feb-2018 15:21


Ground-breaking business programme begins in Hamilton
Posted 16-Feb-2018 10:18


Government to continue search for first Chief Technology Officer
Posted 12-Feb-2018 20:30


Time to take Appleā€™s iPad Pro seriously
Posted 12-Feb-2018 16:54


New Fujifilm X-A5 brings selfie features to mirrorless camera
Posted 9-Feb-2018 09:12


D-Link ANZ expands connected smart home with new HD Wi-Fi cameras
Posted 9-Feb-2018 09:01


Dragon Professional for Mac V6: Near perfect dictation
Posted 9-Feb-2018 08:26


OPPO announces R11s with claims to be the picture perfect smartphone
Posted 2-Feb-2018 13:28


Vocus Communications wins a place on the TaaS panel
Posted 26-Jan-2018 15:16


SwipedOn raises $1 million capital
Posted 26-Jan-2018 15:15


Slingshot offers unlimited gigabit fibre for under a ton
Posted 25-Jan-2018 13:51


Spark doubles down on wireless broadband
Posted 24-Jan-2018 15:44


New Zealand's IT industry in 2018 and beyond
Posted 22-Jan-2018 12:50


Introducing your new workplace headache: Gen Z
Posted 22-Jan-2018 12:45


Jucy set to introduce electric campervan fleet
Posted 22-Jan-2018 12:41



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.