Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

9 posts

Wannabe Geek

#55313 29-Dec-2009 19:13
Send private message

I was recently connected to a roadside cabinet < 500m from my house. This cabinet has not been upgraded for ADSL2+ yet however my modem reports a downstream sync of 7.61 Mb. Keeping this in mind I am only getting a max of 3.1 Mb when performing speed tests, I've tried, Xtra's speedtest as well as a multitude of Australian speedtests, the result is the same. Surely given the sync I should be experiencing better results. I have tried downloading large files from Microsoft and Apple and the downloads max out at 350 Kb/s. I have attached some stats from my router that may be useful:

DSL Type:
G.992.1 annex A

Bandwidth (Up/Down) [kbps/kbps]:
832 / 7.616

Data Transferred (Sent/Received) [kB/kB]:
0,00 / 0,00

Output Power (Up/Down) [dBm]:
11,5 / 11,5

Line Attenuation (Up/Down) [dB]:
6,0 / 8,0

SN Margin (Up/Down) [dB]:
14,0 / 15,0

Vendor ID (Local/Remote):

Loss of Framing (Local/Remote):
1 / 0

Loss of Signal (Local/Remote):
4 / 0

Loss of Power (Local/Remote):
0 / 0

Loss of Link (Remote):

Error Seconds (Local/Remote):
3 / 0

FEC Errors (Up/Down):
0 / 56

CRC Errors (Up/Down):
0 / 0

HEC Errors (Up/Down):
0 / 0

I have also tried using a different modem however the result is exactly the same. Spoke to Telecom and they asked me to do the whole 3 speedtests for 3 days jazz. My line attenuation looks really good, sync doesn't fluctuate from the numbers above.

Any idea what the problem might be? Also, any advice as to how I can somehow get Telecom to look into this and hopefully fix it?? Have tried isolation tests, replacing filters, different phone cables with no success.

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
104 posts

Master Geek

  #285907 29-Dec-2009 19:44
Send private message

Can you confirm you are on an ADSL2+ plan?
Also, what router do you have?

Irrespective, I wouldn't expect to get 2+ speeds if the exchange has not been upgraded. I believe the sync speeds are the clock rate, not the throughput capabilities (could be wrong).

For comparison, some stats from my router:
Downstream Rate: 7616 Kbps
Upstream Rate: 896 Kbps
I regularly get over 300KBps (2400Kbps/2.3Mbps) on my Linksys WAG160N.

9 posts

Wannabe Geek

  #285929 29-Dec-2009 21:17
Send private message

I have a Thompson router (the one's that Telecom provide), I am on the Adventure plan which is FS/FS and ADSL2+ capable. I don't expect ADSL2+ speeds since I am on an ADSL cabinet, I just feel that since I am getting the maximum ADSL sync from the cabinet I should be achieving higher speed test results, at least something closer to 7 Mb. Surely 3 Mb is well below what I should be achieving given that I can achieve a sync of over 7 Mb?


8035 posts

Uber Geek


  #285985 30-Dec-2009 01:31
Send private message

In peak time especially for international downloads I would not expect to get file transfers running at a sustained speed of 7Mb.

Outside of peak time local downloads from NZ servers yes you should be able to get near that speed.

Remember residential adsl is a best effort shared network service, you can't expect any guarantee of speed or performance. Somewhat like how you wouldn't be guaranteed to be able to travel at 100km on a motorway in rush hour.

Here's an example of some of the main factor's that could be affecting your speeds:

1: Your PC and operating system, tcp/ip settings (MTU, window size etc)
2: Quality of your ADSL modem/router
3: Quality of your phone/ADSL filtering
4: Quality of your house wiring
5: Quality of you phone line to the exchange/cabinet
6: Cabinet/Exchange port quality
7: Congestion on the backhaul network to your ISP
8: ISP's hand over links
9: ISP's internal network, caching, shaping, traffic management
10: ISP's bandwidth and route to the end server you are communicating with

94 posts

Master Geek

  #286053 30-Dec-2009 13:18
Send private message

epoxer, are your upstream speedtest results in line with your upstream sync rate? Just to rule out the possibility that Telecom screwed up and throttled your upstream (irrespective of sync rate) to 128 kbps, which would in turn limit your TCP download performance. Likewise if you've modified any OS TCP settings (like TcpAckFrequency in Windows), that could also impact download rates.

Also, were you connected to the local exchange prior to being cabinetised, or have you just moved in to a new residence? If the former, were you experiencing the same or better downstream rates prior to cabinetisation?

Realistically, of the factors that Ragnor listed, only 1, 6, 7, 8, 9 and 10 are relevant, given the information you've provided... and out of those, given my own experience with Telecom, only 1, 7 and 9 are likely candidates. I'm not a network engineer, but if your cabinet is ADSL (G.DMT) only, that suggests it's rather old, and as such the backhaul from the cabinet to the exchange may be the limiting factor.

9 posts

Wannabe Geek

  #286057 30-Dec-2009 13:29
Send private message

Will post a few speed test results when I get home, generally though upstream is sitting close to 0.65 Mb which seems pretty good. Have tried testing my connection on multiple computers running different operating systems and have tweaked the settings mentioned however the result is the same unfortunately. I was previously uncabinetised connected to the local exchange using Orcon, and speeds were crap (that was the main reason for moving to Telecom, to get onto the cabinet), Downstream was around 0.6Mb and upstream slightly higher than that (strangely). I know someone else on the same cabinet approx the same distance from it with the same sync speeds, however their speed test results are between 6-7 Mb which is more indicative of what you would expect given the sync.

104 posts

Master Geek

  #286064 30-Dec-2009 13:44
Send private message

epoxer: I know someone else on the same cabinet approx the same distance from it with the same sync speeds, however their speed test results are between 6-7 Mb which is more indicative of what you would expect given the sync.

Interesting, that blows most of the theories away.

If you could, the best test would be swap routers with this other person.
Your local wiring may be the fault, ie a bad solder point, bad connection at the letterbox, water in a wiring conduit etc.

Have you pulled all other phone devices out of their jacks while testing?

Do you have a monitored house alarm?  If so does it have the proper split/filtered connection?

7266 posts

Uber Geek


  #286101 30-Dec-2009 16:54
Send private message

Hi, you modem is also reporting that its in ADSL1 mode G.992.1 annex A, hence it will not exceed 7.6Mb/s because thats all ADSL1 does.

I suggest that you wait till the cabinet is fully migrated, this of course its still in the process of being cut over. Its quite common that Telecom only apply DSL1 profiles till the cabinet is fully migrated, fully preformance and ADSL2+ speeds may not happen till then.

Other than that I suggest that you continue to talk to Telecom and see why the port you are on is limited to G.DMT (ADSL1), I am of course assuming that your house wiring is up to scratch and not laboured by unfiltered POTS devices, alarms etc, ideally with a central filter installed. Concidering your close proximity to the cabinet if you are going to get a central filter installed insist on a VDSL2 rated one so that you can take advantage of that service once its on line.



9 posts

Wannabe Geek

  #286123 30-Dec-2009 18:05
Send private message

I've tried swapping out my modem for a Siemens one and it reports a max line speed (down) of 8.9 Mb, really baffled about why my speed tests seem capped at a max of 3.2 Mb. Tried this at all times of the day and the result is the same. We have a central splitter installed, have had numerous techs at our place over the years to check out the wiring and according to them everything is in order.. I'm thinking at this point all I can do is try to get Telecom to hopefully look into the issue further, from past experience however I don't think this is likely unfortunately. First time for everything though I guess, fingers crossed, will let you guys know if I make some headway.

7266 posts

Uber Geek


  #286129 30-Dec-2009 18:16
Send private message

Hi, sounds to me like its nothing wrong with your line per say, but its a issue of both port config which is Telecom/ISP to sort purhaps with cabinet migration, and ISP issue that you cannot get over 3.6Mb/s on a 7.6Mb/s line. This of course assumes there are no TCP managemet issues (ie incorrect MTU etc).


104 posts

Master Geek

  #286131 30-Dec-2009 18:22
Send private message

The 101ms ping seems good (I get 212ms) but not sure what server that really is.
Can you post the ping time to I know the hosters, response from a Telecom circuit should be approx 40ms.

Also, what about bigger pings? On windows, that is done by the -l option:
ping -l 1400 (57ms)
ping -l 1400 (219ms)

104 posts

Master Geek

  #286132 30-Dec-2009 18:26
Send private message

cyril7: This of course assumes there are no TCP managemet issues (ie incorrect MTU etc).


Just for fun, try setting your router wan mtu to 1492, see if it makes a difference.
That's normally used for PPPoE but I've used it for PPPoA to resolve issues before (issues with IPSEC dropouts and failed key renegotiations) and it should still give you the same speed results, and *may* inmprove things.

94 posts

Master Geek

  #286139 30-Dec-2009 18:42
Send private message

I would second what Cyril said regarding the port config being possibly awry, although my own experience with bad port configs/state has always involved the sync rate being sub-standard, not just the TCP/IP throughput. Your throughput is reminiscent of the old 3.5 Mbps caps, however. The challenge is talking to someone at Telecom who actually appreciates that, given the diagnostic steps you've taken, the port config should be sanity-checked as a matter of course.

9 posts

Wannabe Geek

  #286168 30-Dec-2009 22:00
Send private message

PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=57 time=49.500 ms
64 bytes from icmp_seq=1 ttl=57 time=51.578 ms
64 bytes from icmp_seq=2 ttl=57 time=48.890 ms
64 bytes from icmp_seq=3 ttl=57 time=49.702 ms
64 bytes from icmp_seq=4 ttl=57 time=50.197 ms
64 bytes from icmp_seq=5 ttl=57 time=48.966 ms

PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=50 time=205.595 ms
64 bytes from icmp_seq=1 ttl=50 time=207.305 ms
64 bytes from icmp_seq=2 ttl=50 time=217.166 ms
64 bytes from icmp_seq=3 ttl=50 time=204.858 ms
64 bytes from icmp_seq=4 ttl=50 time=204.646 ms
64 bytes from icmp_seq=5 ttl=50 time=205.103 ms

Pings seem in order, will try changing the MTU to see if it helps. Yea it's quite difficult actually getting through to someone at Telecom that can actually help, so far I've not progressed past the tier 1 guys. I've emailed adsl_helpdesk@xtra so hopefully will get a helpful response...

104 posts

Master Geek

  #286210 31-Dec-2009 07:59
Send private message

Did you get a chance to change the MTU?

9 posts

Wannabe Geek

  #288175 8-Jan-2010 15:29
Send private message

hey sorry for the late reply, have been away. Yea changed MTU but didn't make a difference. Talked to a friend at Chorus and turns out that the cabinet has an ASAM and a Conklin and I'm on the Conklin which has 2 2Mb links therefore I can't get anything better in terms of speed tests.

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

New Vodafone mobile data plans with unlimited data
Posted 26-Feb-2020 06:55

Vodafone launches innovation initiatives to help businesses use 5G
Posted 26-Feb-2020 05:00

Ultimate Ears HYPERBOOM brings massive sound and extreme bass
Posted 25-Feb-2020 09:00

Withings launches three new devices to help monitor heart health from home
Posted 13-Feb-2020 20:05

Auckland start-up Yourcar matches new car buyers with dealerships
Posted 13-Feb-2020 18:05

School gardens go high tech to teach kids the importance of technology
Posted 13-Feb-2020 11:10

Malwarebytes finds Mac threats outpace Windows for the first time
Posted 13-Feb-2020 08:01

Amazon launches Echo Show 8 in Australia and New Zealand
Posted 8-Feb-2020 20:36

Vodafone New Zealand starts two year partnership with LetsPlay.Live
Posted 28-Jan-2020 11:24

Ring launches indoor-only security camera
Posted 23-Jan-2020 17:26

New report findings will help schools implement the digital technologies curriculum content
Posted 23-Jan-2020 17:25

N4L to upgrade & support wireless internet inside schools
Posted 23-Jan-2020 17:22

Netflix releases 21 Studio Ghibli works
Posted 22-Jan-2020 11:42

Vodafone integrates eSIM into device and wearable roadmap
Posted 17-Jan-2020 09:45

Do you need this camera app? Group investigates privacy implications
Posted 16-Jan-2020 03:30

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.