This error has arisen on a almost new Samsung SSD 850 EVO.  The problem started when I first used Acronis to clone a drive. (not to or from this one, btw).

 

On the next boot DOS screen reported 'Non System Disk - Press a Key' even though the correct disk and boot sequence were setup in BIOS.  The next time I used Acronis this changed to 'MBR Error 2" and hung there for about 7 minutes before Windows (XP) started.

 

Over time the 7 minutes has reduced to almost zero but the error msg remains. Windows runs fine (as does a subsequent Acronis clone to a mechanical hard drive).

 

I tried a support call to Samsung but one would do better whistling in the wind, zero support from Samsung NZ as drive in ''imported". (So make sure you get a NZ made one, LOL).  Googled around and tried fixmbr (or is it mbrfix) from command line, and while it reported success, it didn't fix anything.

 

I think you can run fixmbr with other switches, but not sure what. Does anyone know, or ideas how to get out of this error - bearing in mind I could clone it again from an Acronis image, but would prefer to find and fix, if possible.

 

Thanks.