Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




2084 posts

Uber Geek

Subscriber

#271951 3-Jun-2020 10:08
Send private message

Just after Christmas, I got a new PC custom built by PB Tech. It has a Gigabyte X570 UD motherboard and a Cooler Master ML120L liquid cooling system, which has RGB LEDs in the pump and fan. I downloaded RGB Fusion 2.0 to control that and the G.Skill RGB RAM. Now, RGB Fusion has never worked properly after about the first day. It stopped recognising the RAM completely so I downloaded ASUS Aura Sync to see if that would work as a solution for both (no) and then the G.Skill software to control the RAM independently. The fan and the RAM have never been in sync with each other but that's okay - I just set both to cycle through the spectrum and was happy with that.

 

Yesterday I noticed that my fan and pump were stuck on static green, and went into RGB Fusion to see if I could fix it. RGB Fusion was now recognising both the RAM and the motherboard (to which the fan is connected) but the motherboard was greyed out and I couldn't interact with any of the controls. I wondered if Aura Sync was causing some kind of conflict so I uninstalled it. No change. Then I remembered that the fan came with a wired controller that PB Tech had neglected to install, so I shut down the computer and removed the glass side of the computer case to see if I could work out where it went. I've installed computer components before so I thought I might be capable of doing this. I identified the LED cables leading from the fan and the pump - they go into a splitter that is plugged into the LED_C1 header on the motherboard. I unplugged the one leading from the pump, inspected it, plugged it back in (ensuring the arrows matched up), and decided I didn't have the confidence to attempt adding the wired controller (or the necessary parts - I was missing a 4-pin connector and something to plug the controller into the PSU). So I closed up the case and resigned myself to living with whatever colour the fan decided it wanted to be.

 

However, when I restarted the computer, the lights in the fan and the pump were dead. The fan and pump are still operating just fine. A friend walked me through checking that everything was still properly seated. I re-plugged the splitter into the motherboard to ensure I hadn't knocked it loose when I was gently poking around. I reseated the LED cables on the splitter. I checked the power cables for the fan and pump were properly plugged in. I restarted several times and also uninstalled and reinstalled RGB Fusion. I found a lot of people online who have had issues with that software and there were a couple of fixes suggested, including moving the AtiTool folder out to the desktop and renaming a couple of the dll files. Neither of those worked - I still cannot get the software to communicate with the motherboard.

 

So now I am stuck with no RGB and I don't know if it's a hardware or a software issue. I can't find any way to try changing the RGB profile to see if that brings it back to life, or anything wrong with the way the components are plugged in. I am reluctant to lug the thing back to PB Tech because it's very heavy and I am very tiny, and if it's not a hardware fault covered by the warranty, I will probably be charged to fix it. Any suggestions on anything I could try would be very gratefully received.

 

And, yes, I realise I shouldn't have fiddled with it in the first place!





Geek girl. Freelance copywriter and editor at Unmistakable.co.nz.

 

Currently using: Custom-built AMD Ryzen 7 3700X Desktop, HP M6-1017TX Laptop, iPad Pro, iPhone 7, iPhone XR, AppleTV4.


Create new topic


2084 posts

Uber Geek

Subscriber

  #2497321 3-Jun-2020 12:38
Send private message quote this post

Update: Another poke around inside the case and re-seating the header connection for about the tenth time appears to have fixed it. Phew.





Geek girl. Freelance copywriter and editor at Unmistakable.co.nz.

 

Currently using: Custom-built AMD Ryzen 7 3700X Desktop, HP M6-1017TX Laptop, iPad Pro, iPhone 7, iPhone XR, AppleTV4.


Create new topic




News »

Pre-orders for Huawei MateBook 13 open now
Posted 14-Aug-2020 14:26


Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.