Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


3 posts

Wannabe Geek


Topic # 13011 18-Apr-2007 11:12
Send private message

iMate announced a software upgrade for JASJAM smarrtphones on the Telstra (Australia) GPRS/3G network. Prior to installing this software upgrade, my JASJAM worked fine - it did everything it was meant to, including Direct Push to my work Microsoft Exchange Server.   After the software upgrade, I lost all capacity to connect to the Exchange, over the phone network or via Active Synch to my PC.  I finally managed to make a connection to the Exchange Server using Active Sync after I manually installed a series of SSL certificates as root certificates on thhe phone and re-booting it.  I still cannot make a connection over the phone network and Direcet Push is not working.

The phone attempts to make the connection, the GPRS network connection is activated and a message indicates that the Exchange is "synchronising folders".  Eventually, it logs off, without making the connection.  A message on the screen indicates it is "Waiting for the Server" and the Status messages is 0x80072EFD (The server could not be reached).  This is the same message I was receiving when trying to connect via Active Sync directly to the PC and which was solved through installation of the security certificates.  It has not solved the problemm for Direct Push though.

HELP!  Anny suggestions.  The technical support line for iMate is to an overseas call centre and their operators do not seem to have ANY idea about what they are doing - one told me the JASJAM was nopt capable of connecting to an Exchange Server.

Thanks,
Greg

Create new topic
BDFL - Memuneh
61028 posts

Uber Geek
+1 received by user: 11857

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 67495 18-Apr-2007 11:18
Send private message

Welcome to Geekzone... Some suggestions:

1.Make sure you have the correct Root Certificate for your server, if it's not a public one (Self Signed Certificates)
2.Make sure the server name in use is the same one for which the certificate  was issued
3.Make sure your Smartphone can actually connect to the Internet, by accesing other servers
4.Try connecting to the Exchange Server with the SSL option turned off on your phone (if it works it can be a problem with your certificate configuration)
5.Enable logging on your Smartphne and see if you noticed any strange message in the log
6.Try accessing the /OWA from your PC and from your Smartphone (/OMA)
6.Ask the Exchange Administrator if the settings for your user are correct and allow user initiated synchronisation
7.Ask the Exchange Administrator if port 443 is not blocked in the firewall

These are just some start points and most likely the culprit is one of these...







3 posts

Wannabe Geek


  Reply # 67552 18-Apr-2007 15:04
Send private message

Thanks for all the suggestions:

1.Make sure you have the correct Root Certificate for your server, if it's not a public one (Self Signed Certificates)
2.Make sure the server name in use is the same one for which the certificate  was issued
3.Make sure your Smartphone can actually connect to the Internet, by accesing other servers
4.Try connecting to the Exchange Server with the SSL option turned off on your phone (if it works it can be a problem with your certificate configuration)
5.Enable logging on your Smartphne and see if you noticed any strange message in the log
6.Try accessing the /OWA from your PC and from your Smartphone (/OMA)
6.Ask the Exchange Administrator if the settings for your user are correct and allow user initiated synchronisation
7.Ask the Exchange Administrator if port 443 is not blocked in the firewall

(1) I have installed all the root certificates that seem appropriate, based on the following procedure:
  • Log onto web outlook via a secure https:// connection.
  • Clicking on the “lock” icon located next to the address bar and select “View Certificates”
  • Select the “details” TAB
  • Select “Copy to file…”
  • Follow the steps in the certificate export wizard selecting “Base-64 encoded X.509 (.CER)
  • Select a filename location
  • Copy to the phone then run the Certificate installer
One thing I noted though, was that the address for the Outlook Web Access was https:exchange.uq.edu/au/exchange, whereas the actual exchange server setting I use for Outlook and access via Activew Sync is uqexmb1.uq.edu.au.  I am trying to find out if there is an additional root certificate associated with the latter that I need to install.  The certificate that is installed is for access to *.uq.edu.au, so I assumed the * was a wild card allowing access to all uq servers.  If this is not the case then your point 2 might explain the situation, but I do not know how to solve this.   When I first got the phone, this was not a problem - I only lost Direct Push access after installing the iMate software upgrade.

(3) There is no problem accessing the internet and I can also download email from a pop server and IMAP account without any problems.
(4) I have SSL switched off and this does help.   If I have it switched on, I just get a different error message
(6) I have NO problem accessing OWA from the PC or OMA from the smartphone - I can see all my mail from OMA, although the interface is not very good so it is not a solution for actually reading the mail.

(7-8) I am waiting to hear back from our Exchange Administrator BUT given thge Direct Push worked on Monday, prior to the software upgrade, I have no reason to believe that these settings might have been changed.

Thanks again though.

Greg



3 posts

Wannabe Geek


Reply # 67570 18-Apr-2007 16:50
Send private message

Thanks very much for the help.  Problem solved.  There was yet one more certificate that I had not associated with the Exchange server but seemed to be needed in order to access the system.   Not sure why this had to be manually installed, but at least it is now all fixed.  Any other users of the JasJam on Telstra (Australia), be wary of installing the software upgrade unless you really need it.

Regards,
    Greg

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel introduces new NUC kits and NUC mini PCs
Posted 16-Aug-2018 11:03


The Warehouse leaps into the AI future with Google
Posted 15-Aug-2018 17:56


Targus set sights on enterprise and consumer growth in New Zealand
Posted 13-Aug-2018 13:47


Huawei to distribute nova 3i in New Zealand
Posted 9-Aug-2018 16:23


Home robot Vector to be available in New Zealand stores
Posted 9-Aug-2018 14:47


Panasonic announces new 2018 OLED TV line up
Posted 7-Aug-2018 16:38


Kordia completes first live 4K TV broadcast
Posted 1-Aug-2018 13:00


Schools get safer and smarter internet with Managed Network Upgrade
Posted 30-Jul-2018 20:01


DNC wants a safer .nz in the coming year
Posted 26-Jul-2018 16:08


Auldhouse becomes an AWS Authorised Training Delivery Partner in New Zealand
Posted 26-Jul-2018 15:55


Rakuten Kobo launches Kobo Clara HD entry level reader
Posted 26-Jul-2018 15:44


Kiwi team reaches semi-finals at the Microsoft Imagine Cup
Posted 26-Jul-2018 15:38


KidsCan App to Help Kiwi Children in Need
Posted 26-Jul-2018 15:32


FUJIFILM announces new high-performance lenses
Posted 24-Jul-2018 14:57


New FUJIFILM XF10 introduces square mode for Instagram sharing
Posted 24-Jul-2018 14:44



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.