Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


mitsii

62 posts

Master Geek


#28753 10-Dec-2008 13:11
Send private message

I have not been able to get the Google Maps application working on the two Storm's I have tried so far... I get the following message:

'Network unavailable: This application needs a data connection and some BlackBerry devices require reconfiguration to work properly. Please visit ww.google.co.uk/gmm for more info.’

The website they advised above (and it's forum) is useless and no one seems to have an answer for this.

I have checked all the application permissions and the internet settings, have refreshed GPS, re-registered myself on the 'wireless network' and un-installed & re-installed the application but to no avail...

I have spoken to RIM who insist it is a network issue, Vodafone say it is a software/application issue. So I am still not getting anywhere...

I was using Google Maps perfectly fine on my Curve the day before I got the Storm so I am thinking it is probably a software issue but I have also had others say that theirs works fine, no issues...

Vodafone Compass was not initially working but seems to be now and BlackBerry Maps seems to be able to locate me with the GPS but cannot pull up the actual map itself so it just shows me as being a dot in the middle of a whole lot of lines.

Does anyone have any suggestions on how I can get this working?


Create new topic
mitsii

62 posts

Master Geek


  #183318 10-Dec-2008 13:15
Send private message

Sorry Vodafone Compass is actually not working. It says 'Vodafone Compass has timed out attempting to connect to the mapping servers. Check that Compass has permission (which it does) to access the carrier network.'

slartibartfast
61 posts

Master Geek


  #183326 10-Dec-2008 13:54
Send private message

I have the same problem here...and have followed the same steps you have - forums etc.

No joy.

I noticed that under Advanced Options -> "Service Books" there is a Service Book for Google Maps. I'm no expert on Service Books, but it looks like it is wanting to use the blackberry.net APN.

I have deleted and re-sent service books from the BES, and I have tried different APN settings in the Advanced Options -> TCP but no luck. Opera Mini works fine, so it's not a wide spread Application connectivity problem. I haven't tried Compass yet.

Overseas, others are not having this issue - so I can only assume it is a Vodafone NZ specific problem.

I'm hoping a new version of the application comes out that is optimised for the Storm which would at least eliminate application compatibility as an issue.




 
 
 
 


mitsii

62 posts

Master Geek


  #183476 11-Dec-2008 10:46
Send private message

Ahh I didn't notice that under the Service Books. I haven't had a chance to have my service books re-sent but I wont bother if it hasn't worked for you.

My BlackBerry has also now stopped PXTing but the settings look okay so will be ringing VF now :)

slartibartfast
61 posts

Master Geek


  #183527 11-Dec-2008 14:35
Send private message

Good news - I now have Google Maps working perfectly on my Storm, including GPS integration.

The bad news - I'm not sure what I did differently to make this work.

The only steps I took from when it last wasn't working was as follows:

1. Uninstalled Google Maps using the Desktop Manager's "Application Loader" function.
2. Rebooted the phone a few times (not because of this, but because I was doing other things - not sure if it is important to the process)
3. From the applications menu, I clicked on the Google Maps icon that comes by default - this opened the Blackberry Browser and took me to download the latest Google Maps application.
4. Downloaded / installed the app (set the default permissions etc.)
5. Rebooted the device as instructed.
6. Ran the application and it worked first time, pinpointing me to within 4 metres.

The app itself has touch screen support built in - there were zoom in/out icons and a current location icon. So perhaps they've released a Storm specific version.

Anyhow, have a go.

mitsii

62 posts

Master Geek


  #183550 11-Dec-2008 15:27
Send private message

Since I last posted, I have also managed to get it working and also don't know what I did differently but this is what I did if anyone finds the above doesn't work for some reason:

 - re-register on wireless network under Options - Advanced Options - TCP (then press menu, 'Register Now' for each)
 - delete Google Maps service books under Options - Advanced Options - Service Books
 - delete Google Maps application from phone under Options - Advanced Options - Applications
 - after the BlackBerry restarted itself I downloaded the application again and it worked the first time round

The only things I did different was to delete the service books as well as the application and to tick the 'Set Application Permissions' tick box BEFORE I clicked the 'downloaded' button (which I don't usually bother doing).

It works perfectly :)

And, FYI, it was the same version I downloaded that was not working previously - v2.3.2

Bif

Bif
1 post

Wannabe Geek


  #185014 18-Dec-2008 17:28
Send private message

Mitsii - This is driving me to distraction: can youplease let me know what your APN settings are - and anything else you might have changed, tweaked, or fixed. I have followed both the suggested methods and still get the same "Network unavailable..." error. Ta

mitsii

62 posts

Master Geek


  #185099 19-Dec-2008 11:00
Send private message

Ummmmm...

I tend to fiddle with my phone a lot especially when something isn't working but I dont change settings unless I know what they are...

Under TCP/IP in Advanced Settings, APN Settings Enabled is ticked and APN Authentication Enabled is NOT ticked but there are no APN settings in there.

Under Host Routing Table in Advanced Settings my APN's are both blackberry.net, does that help?

I can't find any APN settings under the Service Books or Application list for Google Maps.

To be honest, I really can't think of why it just started working. I would re-send the service books to your phone, delete the Google Maps app and Service Books, re-start the BlackBerry and then re-install Google Maps using the link/icon under Applications in the main menu.

The only thing I did differently was to tick 'set application permissions' before I clicked download...

I did speak to Vodafone Solutions first about the issue but they didn't actually say they changed anything on the network end or on my account.

 
 
 
 


mitsii

62 posts

Master Geek


  #185103 19-Dec-2008 11:09
Send private message

I don't think that the issue is related directly to the application or its installation. Reason being that I had the same issue with Vodafone Compass where the application could not get a connection to the network and they both started working at the same time but I did not un/re-install Compass.

I also do not think that it is a network related issue as I was using Google Maps perfectly fine on my Curve the day before I got my Storm.

Are your Browser settings set to BlackBerry Browser, BlackBerry Browser and Vodafone Live! (in that order) under advanced settings? Sometimes you need to change these although I didn't have to and I don't know if it would affect the Applications...

Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.