Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


AKK



9 posts

Wannabe Geek


Topic # 3632 11-Mar-2005 00:28
Send private message

I have been unable to set up my pc (Fujitsu laptop) and Ipaq hx4700 to recognise each other correctly via bluetooth. I have synchronised using the USB cable without any problem. I am using a Desma Bluetooth (USB) adapter. If I set up a file transfer connection between these devices, this works perfectly (using bluetooth). I suspect that the problem may be to do with the com port numbers being used, but I am not convinced.

On the Local Services tab (Bluetooth Configuration), Bluetooth Serial Port has COM5 assigned. Under the Client Applications tab (also under Bluetooth Configuration), Bluetooth Serial Port has COM6 assigned. Under ActiveSync, File, Connection Settings, Allow serial cable is ticked, and COM5 is assigned. If I click on the Get Connected option (ActiveSync, File menu) then it scrolls through the available ports trying to find the device. While this is happening, with the Bluetooth Manager open on the Ipaq I have monitored any connection activity. Nothing happens when COM5 is tested, but when it checks COM6, Incoming Connection activity is shown (but no Outgoing Connection). Clicking on the Incoming Connection, and then on Status, no Bytes are shown as being transfered. This continues until COM7 is selected for testing, and COM6 dropped. I have tried changing COM5 to COM6, (and allocating either COM5 or COM7 to Bluetooth Serial Port on the Client Applications tab), but this results in no connection activity at all. In all circumstances, a "Your device was not detected" message results.

Can anyone help please?

Create new topic
BDFL - Memuneh
58506 posts

Uber Geek
+1 received by user: 9949

Administrator
Trusted
Geekzone
Subscriber

Reply # 13454 11-Mar-2005 00:33
Send private message

You should use COM5 (the local service) on ActiveSync.

You have to check that no firewall software is blocking the Bluetooth or ActiveSync program. If using Zone Alarm, make sure it's set to Medium security. If using Windows XP SP2 or Norton, make sure you have rules to allow these programs to talk...




AKK



9 posts

Wannabe Geek


Reply # 13455 11-Mar-2005 00:57
Send private message

I am using COM5 as you suggest, and I still have the same problem. I'm also running on Windows 2000, and there is no firewall software.

Can you suggest anything else please?

 
 
 
 


BDFL - Memuneh
58506 posts

Uber Geek
+1 received by user: 9949

Administrator
Trusted
Geekzone
Subscriber

AKK



9 posts

Wannabe Geek


Reply # 13457 11-Mar-2005 01:10
Send private message

No, but I will now. Watch this space...

Thanks

AKK



9 posts

Wannabe Geek


Reply # 13458 11-Mar-2005 01:34
Send private message

There were some minor differences between the details specified in the guide, and those I experienced, presumably due to the different hardware and different software versions. Also, as I had already paired my Ipaq with the laptop, I didn't get the PIN prompt.
However, as far as I can tell, everything happened as it should have done, except that when I double-clicked on the shortcut icon on the Ipaq, Activesync didn't start up. A message did appear near the task bar to confirm that the Ipaq had connected successfully, but Activesync did not appear to respond.

AKK



9 posts

Wannabe Geek


Reply # 13465 11-Mar-2005 05:28
Send private message

Although COM5 is specified both within ActiveSync (Connection Settings), and Bluetooth (Advanced Configuration, Local Services, Bluetooth Serial Port), if while bluetooth is running on the pc I right click on the bluetooth icon on the task bar, and then click on Explore My Bluetooth Places, right click on the entry for the bluetooth serial port, this shows COM7.

Should the pairing use different com ports for sending/receiving? Does it matter what the second port is?

When I double click on this serial port icon, it does connect to my Ipaq, and I can see communications activity on the Blouetooth manager screen, but it appears to be one-sided (incoming to the Ipaq only).

Similarly, when I double click (tap) on the ActiveSync icon on the Ipaq's Bluetooth Manager screen, and then check the connection status on the Active Connections screen this shows outgoing activity only, even though the pc does flash up a message to say that the Bluetooth connection has been successful.

Help!!!!

BDFL - Memuneh
58506 posts

Uber Geek
+1 received by user: 9949

Administrator
Trusted
Geekzone
Subscriber

Reply # 13467 11-Mar-2005 08:08
Send private message

Is the Bluetooth a USB adapter? Is it connected directly to a port on your computer, or to a USB HUB? These adapters sometimes use more power than a HUB can supply. Try moving it to another port.

Also, uncheck the power management checkbox in the Device Manager on your computer (access it from Control Panel | System) or press Windows key - Break.




AKK



9 posts

Wannabe Geek


Reply # 13498 11-Mar-2005 23:13
Send private message

Yes, it is a USB bluetooth adapter. I only have one USB port on my laptop, so I can't move it.

Reading from the specifications; the Adapter is claimed to be compatible with any USB device running Windows, allows for point or multipoint connections, is Bluetooth Class 2 TX power, supports up to 7 active links, operates on any of the 79 1MHz BW channels, and supports ACL links with data transfer rates up to 721 KB/s.

I don't know if this is any indication, but the signal strength shown on the Ipaq appears to be fine - it spends most of the time hovering around "just right" level, with occasional peaks and troughs at either end of the range.

When I set up a file transfer pairing, this seemed to work perfectly, suggesting (to me at least) that this problem is something specific to ActiveSync, or to the type of communications involved.

I will try the power management changes you suggest all the same. Thanks.

AKK



9 posts

Wannabe Geek


Reply # 13502 12-Mar-2005 00:37
Send private message

It must be me - I can't find a power management checkbox anywhere on Device Manager! I'm running Windows 2000 - where should this checkbox be please?

BDFL - Memuneh
58506 posts

Uber Geek
+1 received by user: 9949

Administrator
Trusted
Geekzone
Subscriber

Reply # 13503 12-Mar-2005 00:41
Send private message

Press Windows key - Break. Change to Hardware tab and click Device Manager. Scroll down to Universal Serial Bus Controllers. Each USB Root Hub will have a tab Power Management...




AKK



9 posts

Wannabe Geek


Reply # 13504 12-Mar-2005 01:16
Send private message

The USB Root Hub Properties show three tabs; General, Power and Driver. There is no Power Management checkbox on either of these tabs. The Power tab lists the hub as being self powered, with 500mA per port.

The Bluetooth Device is listed on this hub, with power required, 0 mA (doesn't change with the device active or inactive).

If the adapter were not functioning correctly, wouldn't this prevent forming other types of connections as well (I have managed to transfer data using a File Transfer connection successfully)?

BDFL - Memuneh
58506 posts

Uber Geek
+1 received by user: 9949

Administrator
Trusted
Geekzone
Subscriber

Reply # 13506 12-Mar-2005 01:22
Send private message

Hmmm. Well, that's pretty much all I can think. These things we talked before were all factors in previous problems with Bluetooth USB adapter: power management, firewalls, incorrect COM port selection.

The last thing we can check is the motherboard. I remember seeing one case in our forums where the user had a computer based on an old VIA motherboard. The first models with VIA chipsets had problems with USB. He added a USB PCI card and the problems went away.

Sorry, this is all I can think of now...




AKK



9 posts

Wannabe Geek


Reply # 13507 12-Mar-2005 01:48
Send private message

Thanks for all your help!

I'll see if I can try again with a different machine, and see if it makes any difference. I still have a gut feeling that it is a COM port related problem somewhere along the line...

If anything else occurs to you then I'll be only too pleased to hear.

Thanks again.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Public Wi-Fi plus cloud file sharing
Posted 18-Aug-2017 11:20


D-Link NZ launches professional Wireless AC Wave 2 Access Point for businesses
Posted 17-Aug-2017 19:25


Garmin introduces the Rino 700 five-watt two-way handheld radio
Posted 17-Aug-2017 19:04


Garmin announces the Foretrex 601 and Foretrex 701 Ballistic Edition for outdoor and tactical use
Posted 17-Aug-2017 19:02


Brightstar announces new distribution partnership with Samsung Knox platform in Australia
Posted 17-Aug-2017 17:07


Free gig-enabled WiFi network extends across Dunedin
Posted 17-Aug-2017 17:04


Samsung expands with connect Gear S3 Frontier
Posted 17-Aug-2017 15:55


Fact-checking Southern Cross Next cable is fastest to USA
Posted 17-Aug-2017 13:57


Thurrott says Microsoft Surface is dead last for reliability
Posted 16-Aug-2017 15:19


LibreOffice 5.4 works better with Microsoft Office files
Posted 16-Aug-2017 13:32


Certus launches Cognition
Posted 14-Aug-2017 09:31


Spark adds Cambridge, Turangi to 4.5G network
Posted 10-Aug-2017 17:55


REANNZ network to receive ongoing Government funding through to 2024
Posted 10-Aug-2017 16:05


Chorus backhaul starts with 2degrees
Posted 10-Aug-2017 15:49


New Zealanders cool on data analytics catching benefit fraud
Posted 10-Aug-2017 09:56



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.