Hi there,

I'm trying to get a 6120c (presumably running S60 3rd FP1) to sync nicely with our Exchange server.
We're running Exchange 2007 SP2 and authentication to the IIS component is via client certificate with directory mapping.

After some tweaking of the device policies I got it to sync but there's one major issue - every time you do anything Exchange related it prompts you for the phone's Key Store pin/password.
This is a complete deal-breaker because it requires a minimum of 6 characters and you get prompted for it over and over when you're doing something as simple as sending an email.

I know on FP2 devices you can move the certificate to the 'phone store' or disable the PIN requests which would solve this immediately but AFAIK FP2 isn't available as an upgrade for this phone and these options aren't available in FP1. Frustratingly the "Module PIN request" menu option is present, you just can't change it (or can you? hack/equivalent of a registry change???)

Any suggestions? Removing client certificate authentication is not an option... besides that it works beautifully on our various WinMo phones.

I'm loathe to install PC Suite on every 6120 user's PC. If it would do desktop activesync via USB or bluetooth I'd be happy with that but even that doesn't seem to be an option.

Cheers.