I have an HP iPaq rx3115 running Windows Mobile 2003 Second Edition v 4.21.1088 (build 14132) and have recently started having problems with ActiveSync which has been working just fine on the same PC for about 1.5 years. This happened after I installed the MobilePlay (http://mobileplay.com) application which I've recently removed (I don't recommend installing MobilePlay). I've been running ActiveSync 3.7 and recent upgraded to 3.8 to try to resolve my problems. I've also turned off my XP firewall and don't have any other firewall program installed.

When I dock my iPaq ActiveSync starts up, the little green ball spins and it says looking for changes, however the bottom half of the window which usually shows the items being updated is grayed out. When it's done looking for changes (or whatever it's doing at that time) the message in ActiveSync changes to Not Connected. I know that the PC is seeing the iPaq because ActiveSync starts up on both the PC and the iPaq however no data is exchanged.

Here are some things that I've tried:

soft reset
change USB port (PC recognizes new device but still have the same problem)
network sync
Bluetooth sync
Sync on a Mac with Missing Sync
Tried File/Get Connected but it tells me that the device is not detected however the USB is available.

Nothing seems to work and I've tried several different things that lead me to believe that the MobilePlay install has done something to affect ActiveSync on my iPaq. I'm at the point now where I'm about ready to wipe the thing out and start from scratch but I can't connect the thing to a PC to do that. Any help or ideas would be greatly appreciated.