Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


caeser

6 posts

Wannabe Geek


#28396 28-Nov-2008 10:48
Send private message

Hey everybody, first time poster.

I am having a problem getting my Xbox 360 online. In order to save $100 for a Network Adapter, I am trying what I found posted on the internet (which works for the multiple number of people I've seen suggest this), suggesting to take a Crossover cable, and with the Xbox OFF, connect the Xbox and my wireless enabled laptop with the cable. Then I go into Control panel, then Network Connections (WinXP), and select both my LAN connection and my Wireless connection, right click and select "Bridge Connections". Once the connections are bridged, I then turn on my Xbox 360. But when I try to connect to Xbox Live for the first time, it fails. It is detecting the connection, but it will not secure an IP address for some reason, which I don't understand as the laptop should already have an IP address.

I am using a wireless D-link DI-524 with Firmware version 1.12, SSID enabled, WEP 128 bit security enabled. Does anyone happen to know what the problem is? Suggestions? Thanks in advance.

Create new topic
gehenna
8088 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  #180861 28-Nov-2008 11:01
Send private message

Too complicated!

Just make sure you have an active WiFi connection on your laptop, then connect the Xbox to the laptop using a standard etnernet cable.  Load up the Internet Connection Sharing wizard and follow the prompts to share the internet over your ethernet port.

Done and dusted.

 
 
 

Free kids accounts - trade shares and funds (NZ, US) with Sharesies (affiliate link).
caeser

6 posts

Wannabe Geek


  #180867 28-Nov-2008 11:23
Send private message

Sounds simple! I like it. Maybe you can tell me where I can find this "Internet Connection Sharing Wizard"? I am not seeing it. All my connections are listed, but I cannot find a sharing wizard. Sorry for my ignorance,.. I'm a noob. Thanks for the help.

gehenna
8088 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  #180868 28-Nov-2008 11:25
Send private message

windows xp: http://support.microsoft.com/kb/306126
windows vista: http://windowshelp.microsoft.com/Windows/en-us/help/bfd3bd31-82f0-4b9c-9cde-fb92bc2b14771033.mspx



caeser

6 posts

Wannabe Geek


#180895 28-Nov-2008 13:03
Send private message

Thank for that. It was helpful,.. to a point anyway. I am doing what the article says, but after selecting "Share connection", when I click "OK", it works for a few seconds, and then brings up a box that says - An error occured,.. blah blah blah,.. windows sucks,.. blah blah blah,.. and says something about an IP address being assigned elsewhere??? What the,..??

gehenna
8088 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  #180897 28-Nov-2008 13:12
Send private message

how about writing out the actual message instead of "blah blah blah".... we're not mind readers you know...

If it's an IP conflict then that should be pretty easy to sort out.  Is your Xbox auto-assigning it's IP or is it manually assigned?  If manually then give it an IP that's not in use.  Use the network connection test on the Xbox to see where it is failing.

caeser

6 posts

Wannabe Geek


  #180932 28-Nov-2008 14:53
Send private message

Ok, word for word:
When right clicking my wireless connection and selecting to enable sharing:
"An error occured while Internet Connection Sharing was being enabled. Internet Connection Sharing cannot be enabled. A LAN connection is already configured with the IP address that is required for automatic IP addressing."

When right clicking on my LAN connection and selecting to share:
"An error occurred while Internet Connection Sharing was being enabled. Internet Connection Sharing cannot be enabled due to an IP address conflict on the network. Internet Connection Sharing requires the host to be configured to use 192.168.0.1. Please ensure that no other client on the network is configured to use 192.168.0.1."

I don't know if it's important (as I mentioned before I'm a noob) but I have my desktop hard-wired to the router (in the basement), my wife's laptop on the network (wirelessly from living room), a WII (wirelessly from living room), and my laptop (which I am trying to use as my connection bridge - from the living room).

Quidam
291 posts

Ultimate Geek


  #180937 28-Nov-2008 15:28
Send private message

Hello.

Unfortunately I just lost a huge/epic posting that explained everything you needed to know.

The error you are getting is normal.

Do not use ICS.  ICS and Netowrk bridges are incompatible.

A network brige is the best option, and you have already set it up, which is why you cannot enable ICS.

Your problem is almost certainly not the laptop.

You need to do 2 things:
1) Log into your routers web interface and note down the default gateway IP address; and DNS server addresses
2) Log into your 360 and update your network settings so that
 (a) IP address allocation is automatic
 (b) Default Gateway address and DNS server IP addresses are the same as what you copied from your router

The deafualt gateway is critical.  Without it your 360 cannot properly talk to your router.

I'll write more abotu the why's/hows of this later, but right now i'm mourning my lost post.




"There is no way to Peace -Peace is the Way" (A. J. Muste)

 




gehenna
8088 posts

Uber Geek

Moderator
Trusted
Lifetime subscriber

  #180942 28-Nov-2008 15:44
Send private message

Quidam: Hello.

Do not use ICS.  ICS and Netowrk bridges are incompatible.


just disable the network bridge.  ics works fine, had it working on my 360 from my htpc for ages before I wired some ethernet through to the lounge.

Quidam
291 posts

Ultimate Geek


  #180955 28-Nov-2008 17:29
Send private message

Either way might work, but do you actually understand what they are doing?

Using a network brdige means you have 1 lgocial network, made up of 2 or more phsysical network connections:

The router is the DHCP server, and the laptop and 360 are both clients.

Without a bridge, you have two logical networks.  One between the router and the laptop, and another between the laptop and the 360.

In this case the laptop must be both a DHCP client (to the router) and a DHCP server (or peer) to the 360.

It seems smarter to simply let the 360 talk to the router directly via the network bridge.

To the OP.

If you are still having problems (regardless of the approach you take) let me know, I'm sure we can get it sorted out with a bit of patience.





"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


wazzageek
1090 posts

Uber Geek

ID Verified
Trusted
Lifetime subscriber

  #180989 28-Nov-2008 22:36
Send private message

Do you have any firewalls installed and running?  if the connection is bridged, and the xbox can see a connection is live - then the xbox needs to be able to communicate back to your router - sounds suspiciously like you're not getting that communication through.

Xbox Live doesn't like high latency connections (a big surprise there ...) - which you could get if you have your laptop running a lot of things while trying to connect through.  YMMV.

 


caeser

6 posts

Wannabe Geek


  #181020 29-Nov-2008 03:03
Send private message

Thanks for joining in guys, I really appreciate it and am envious of your knowledge in these things. I am going to try the suggestions today and will let you know how it goes.

caeser

6 posts

Wannabe Geek


  #181025 29-Nov-2008 06:32
Send private message

Ok Quidam, my next problem is that my XBox 360 menu doesn't give me an option to leave the IP on auto while manually selecting the gateway address. When I go into the menu and select System > Network Settings > Edit Settings it takes ne to a dual menu with "Basic Settings" and "Additional Settings". Under Basic Settings I have 2 selectable areas. The top one says IP Settings, IP Address, Subnet Mask and Gateway, but they are all selectable as one. Right now, beside "IP Settings" it says Automatic, but if I select the IP menu, I can change it from Automatic to manual. But if I switch it to manual, then I have to change ALL the subheadings (IP Address, Subnet Mask and Gateway)> It appears it will not let me assign the IP address automatically, while assigning a gateway manually. Or am I in the wrong menu or area?

Wazzageek, I have disabled the firewall on the laptop. But, I had it enabled for the first few attempts, until I thought of the same thing. Thanks.

Gehenna and Quidam, yes, you either have to have the bridge on or off to even have access to any option to share. With the bridge activated, there isn't an option to share the connections. But after removing the bridge, then you can access the sharing options. But I am getting the above-listed error even with the bridge removed.

Quidam
291 posts

Ultimate Geek


  #181103 29-Nov-2008 13:40
Send private message

You are right.  It has been a while since I originally set my own system up.  Enter the settings manually, as follows.

1) Log into your routers web-interface and acquire the following details:
(a) The IP address of your router.  (eg D-Link use 192.168.0.1 as their default).  This number will be the 'gateway' on your 360.
(b) The DNS server IP values (Domain Name Server lookups)
(c) The subnet mask, which will almost certainly be 255.255.255.0

The last thing you need is a valid and unique IP address to assign to your xbox360.

This is where you need to learn a little bit about networking -but don't worry, it's not too complex.


Your router is what allows multiple devices to connect to the internet.  It also allows these devices to talk to each other.  In order to do that it uses a service known as a DHCP server (Dynamic Host Control Protocol).
Your laptop and 360 are DHCP clients.

The server allocates valid/unique IP addresses to the clients.  This concept is known as "leasing".
The server has a range of valid IP addresses it can allocate.

In order to find out what th range is, you need to log into your routers web-interface (from your laptop) and check your "network settings"

You should see options for the following:

Enable DHCP Server (which should be set to Yes, and if it is not, this could definately be your problem)
DHCP IP address range, which should have a "from" and "to" value.  We need to pick a value from this range that we can assign to your xbox 360.  But there is a slight issue.  Since we are going to manually assign a value, we need to make sure that value is not going to be used by any other device.

So here is what I suggest, adjust the "from" value up by 1.  So if the original value was 192.168.0.100.  Change it to 192.168.0.101.  We will then use 192.168.0.100 as the IP address for your xbox.  Because of the change we made to the range, we know the DHCP server will never attempt to assign that IP address to any other device.  You could also "permanantly assign" that IP address to the xbox, but this is an easier way to do the same thing.

We are almost ready to go, but one last thing to check is that the IP address you are about to use for your xbox is not already being used by your laptop (very unlikely).  If it is, you will need to reboot your laptop so it gets a different number.

To check the value, you need to run a command prompt from your laptop.  Just go to the start menu and select the run option.  Then type CMD.  You should now get a DOS window.  Type IPCONFIG and this should give you the IP address of your laptop.  It will be something like 192.168.0.xxx where xxx is in the DHCP IP address range.

Once you have confirmed it is not the same as the number you are going to use for your xbox, you are ready to go!

Just go to your xbox network settings and enter everything in.  Then run an xbox live test, and you should be good to go.

Let us know how you get on.  If you still have problems, it could well be a firewall issue




"There is no way to Peace -Peace is the Way" (A. J. Muste)

 


Create new topic





News and reviews »

Synology Introduces BeeStation
Posted 23-Feb-2024 14:14


New One UI 6.1 Update Brings Galaxy AI to More Galaxy Devices
Posted 23-Feb-2024 10:50


Amazon Echo Hub Available in New Zealand
Posted 23-Feb-2024 10:40


InternetNZ Releases Internet Insights 2023
Posted 20-Feb-2024 10:31


Seagate Adds 24TB IronWolf Pro Hard Drives for Multi-user Commercial and Enterprise RAID Storage Solutions
Posted 19-Feb-2024 16:54


Seagate Skyhawk AI 24TB Elevates Edge Security Capacity and Performance
Posted 9-Feb-2024 17:18


GoPro Releases Quik Desktop App for macOS and Introduces Premium+ Subscription Tier
Posted 9-Feb-2024 17:14


Ring Introduces New Ring Battery Video Doorbell Pro
Posted 9-Feb-2024 16:51


Galaxy AI Transforms the new Galaxy S24 Series
Posted 18-Jan-2024 07:00


D-Link launches AI-Powered Aquila Pro M30 Wi-Fi 6 Mesh Systems
Posted 17-Jan-2024 20:02


Newest LG 4K Lifestyle Projector Doubles as Art Objet
Posted 9-Jan-2024 15:50


More LG Smart TV Owners Set To Enjoy the Latest webOS Upgrade
Posted 9-Jan-2024 15:45


Panasonic Announces the Z95A and Z93A With Fire TV Built In
Posted 9-Jan-2024 15:30


Amazon Echo Pop Review
Posted 8-Jan-2024 14:22


Samsung Tab S9 FE Review
Posted 17-Dec-2023 08:26









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.







Backblaze unlimited backup