Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

25 posts


Topic # 107958 23-Aug-2012 04:24
Send private message

I recently bought one of these off PB tech as I need to get wifi on my desktop PC in the upstairs room I am now living in and running an ethernet cable from the router is not an option

I am experiencing a lot of issues connecting right from when I bought it a week ago, it sees the router OK and the signal level is good, 4/5 or better, but it will not connect.

Pulling the device out and putting it in another USB port has fixed it up to now, but now it will not connect on any port. It has connected OK prior to today (usually after I've stuck it another USB port) and once connected it goes fine with OK speed and stability.... until I restart the PC, at which point I have not be able to reconnect until I have stuck it another USB port.

Now I have tried it in all available USB ports, no joy. Device shows up OK in device manager, it sees the router SSID fine and signal level good, know network key is good as have been using it OK up to now, but it will not connect. OS is Windows XP SP3, have tried both the ASUS WLAN Manager and the Windows Wireless manager that comes with XP, usually find I am more likely to get a connection with the latter up to now.

Suspect this is a hardware issue, will take it back and swap it Friday, any one else had one of these? Anyone got suggestions/ recommendations for a better one? Am also contemplating spending a bit more and getting a LAN over mains power setup, these are $93 at PB tech - anyone got one, are they OK?

I need stability and reliability more than speed, dont mind if its a bit slow, just object to it stopping altogether!

Create new topic
1143 posts

Uber Geek
+1 received by user: 69

  Reply # 675814 23-Aug-2012 09:26
Send private message

I had an Asus Wifi USB adaptor, not sure of the exact model but WL-167G seem familiar.

I had all sorts of problems with it, just like you. After struggling for a week I replaced it with a D-Link model. While the D-Link did indeed work I was getting very slow data transfers that I knew weren't right (I had my netbook with it's built-in Wifi sitting right next to my desktop PC with the D-Link adaptor and was comparing speeds and the D-Link was crawling compared to my netbook, and both on 802.11g).

So I returned the D-Link and replaced it with a Netgear (can't remember the exact model). Immediately everything worked really well and I was getting the speeds that I thought I should be. This was my first Netgear purchase I so far I'm impressed and might look into them when it's time to upgrade my router.

25 posts


  Reply # 676180 24-Aug-2012 01:41
Send private message

Thanks for that Murray M, will see if I can get a Netgear USB wifi stick off PB Tech when I take the ASUS one in tommorrow

I Googled last night for solutions, and found two;
1) Enter the Network Key with the Caps Lock on
Tried this, no joy
2) Udpate the drivers
Tried this, and ... success, got back online after loaded new drivers
Unfortunately this didnt last. After turning the PC back on this afternoon, the stick was now completely dead - not seen in Device Manager, not showing in Windows Wireless config, no light on the stick itself

It goes back in the morning after I finish my shift



25 posts


  Reply # 678247 28-Aug-2012 16:23
Send private message

PB Tech didnt have any Netgear ones available, ended up getting a Tenda one which seems to be doing the job OK, although indicated signal strength is far lower
Have partly remedied that by putting it on the end of a 10 metre USB extension lead I had handy and running it out the bedroom door and hanging it over the Aspidistra in the hallway where it seems to get 3-4 bars signal rather than 1-2 everywhere else. This give me a reasonably solid connection, up to 54Mbs which will do me

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53

Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51

Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39

If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54

Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07

OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56

Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48

Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37

Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45

Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40

Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27

NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16

Windows 10 Fall Creators Update coming Oct. 17
Posted 4-Sep-2017 14:10

Garmin introduce Garmin vivoactive 3
Posted 1-Sep-2017 18:38

Kiwibank wastes $90 million on software – Reseller News
Posted 1-Sep-2017 13:45

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.