I managed to update my router to Gargoyle firmware, so that I can use the USB Storage as a DLNA Server.


1. PC with Windows 7 Home Premium Edition
2. Router TP-Link WR1043ND Rev 1.8
3. Samsung Smart TV (ES Series)
4. External storage device using NTFS file system (USB Flash Drive 8GB for tests)

Using the firmware provided by TP-Link, I was unable to share the USB storage to be seen by the TV as DLNA server. I searched for solutions on the internet and I found http://www.geekzone.co.nz/forums.asp?forumid=66&topicid=102765.

Using the information provided there I installed on the Router the firmware gargoyle_1.4.7-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin. Detailed information here: http://www.gargoyle-router.com/wiki/doku.php?id=tp-link_tl-wr1043nd.

For the DLNA server I used the tutorial provided here: http://wiki.openwrt.org/doc/uci/minidlna.

So the steps are:
1. Install the firmware onto device.
2. Configure the router to have internet access, wireless enabled and the connection from TV to router working.
3. Download "Putty" application to access the router using SSH.
4. Attach the USB storage
5. From WebGUI of the router, access the USB Storage section and add a shared folder existing onto external device. There is the possibility to add the whole drive or just a selected folder. 
5. Install using Putty,  the miniDlna package, configure the minidlna.conf file and start the daemon. Useful commands
- "ls -l": see contents of the current folder onto the router
- "top": a list of executing process
- "df": available disk space onto the drive
In the configuration file it can be set to give access to the whole share folder in step 5, or just one of the sub-folders of it. Basically here are 2 filters to restrict access to external drive, first when a folder is shared using Gargoyle WebGUI and second in the config file of miniDlna.
6. Use the TV all share option to access the device. From PC I can access the drive, by accessing the router as a resource in the network under the default name "Gargoyle".

Tips and problems:
1. First I tried to install the latest version (1.5.6) and it seemed to me that wasn't working as expected:
- problems sign in onto the drive using WebGUI or Putty (invalid password)
- the shared folder via WebGUI wasn't persistent. After a while it wasn't present anymore in the WebGUI USB Storage section. I didn't tried using Putty to search if it is a problem of the WebGUI or how is mounted.
- the miniDlna package wasn't installed. Error: "Not enough space"
2. Using firmware version 1.4.7 I still have problems accessing the router. I get the error "Invalid password".
3. The speed using "windows explorer" is Read 7-8 MB/s, write 2 MB/s. Need tot test using a external HDD
4. Didn't test using user/password combination to access the shared folder.

Hope it helps,