Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

4 posts

Wannabe Geek

#111924 19-Nov-2012 21:36
Send private message

Hey all,

I've been having a problem with my internet connection / router settings / local network settings of some kind.
I've noticed that internet speeds are down a lot to the point I can feel I am almost on dial-up speed sometimes.

It probably is not my line as I have achieved better speeds in the past - no changes to the line (at least inside the house).

I've tried resetting etc... to no avail. Also, it's not a peak time issue as I've tried various times of the day and experience the same slow speed.

Provider: Vodafone NZ (Cabinetised, in Red Zone, Auckland, 4+ years)

Network Layout:
Internet -> Linksys WAG200G -> Linksys E4200 -> Home Server & Wireless clients

WAG200G Settings:
Firmware: 1.01.09
Encapsulation: RFC 2364 PPPoA
Multiplexing: VC
Qos Type: UBR
Virtual Circuit: 0 VPI 100 VCI
DSL Modulation: MultiMode
Keep Alive: Redial Period 20s
MTU Size: 900

Stats from WAG200G:
DSL Modulation Mode: ADSL2+
DSL Path Mode: Interleaved
Downstream Rate: 19162 kbps
Upstream Rate: 932kbps
Downstream Margin: 12db
Upstream Margin: 12db
Downstream/upstream line attenuation: 0db
Downstream transmit power: 12db
Upstream transmit power: 13db

Pings to router from home server:
WAG200G - 1ms
E4200 - <1ms

E4200 Settings:
Firmware: 1.0.05
Internet Connection Type: Automatic Configuration - DHCP
MTU: 900

Server Setup:
Windows Server 2012 Datacenter (Dreamspark)
I just installed it a bit ago because my old installation of Server 2008 doesn't boot up anymore due to a hard drive issue. (Set one up to experiment how domains and such work)
I got a DHCP setup on my home server, which gives out the IP addresses to the wireless clients within the network. However, I have confirmed it not to be the issue, as I plugged both my home server and laptop to the WAG200G directly, and no speed improvement can be observed.
Roles Installed: DHCP, DNS (forwards them to ISP's DNS), Active Directory (not configured)

Speedtest Results:
Before: ~10Mbps download, 2Mbps (Not 100% sure) upload. C Grade
After: Ping 30ms, 2.92Mbps download, 0.13Mbps upload. F+ grade. (On wireless N 5GHz laptop)
Ping 25ms, 2.96Mbps download, 0.15Mbps upload. F+ grade (Via ethernet on home server)
Direct Connection (WAG200G -> Laptop via ethernet): Ping 26ms, 2.88Mbps download, 0.14Mbps upload. F+ grade.

^ proves that it shouldn't be the new server configuration that is causing this. The WAG200G however may be the cause, as I might've tinkered with some settings.

Thanks in advance :)

P.S. Any suggestions for a high cap, yet good speed plan? Something better than $90 for 80GB (extras not included/needed)? Family takes up a bit too much every month. And apparently, the plan I am on the moment is pretty bad in terms of price/cap.

Create new topic
19282 posts

Uber Geek
Inactive user

  #719778 19-Nov-2012 21:41
Send private message

Done an isolation test?
Have you tested with another modem?
Do you have the Vodafone HG556a modem about to test with?
Approx where in Auckland are you?

Vodafone launched new fixed line plans last week they are over on the Vodafone NZ web site


4 posts

Wannabe Geek

  #719806 19-Nov-2012 22:26
Send private message

Hey John

Nope. Haven't done an isolation test yet. Will do so in the morning.

I've just tested with a Huawei MT882 that came with our vodafone package.
Results look promising with 6Mbps download, 35 ping and forgot about upload but it was better.

I compared settings and it looks pretty much the same, except MTU which I now set as Auto. However, speedtests aren't getting better from that change. (3Mbps DL, 0.14Mbps UP, 28 ping)

Approx location: Half Moon Bay.

So free upgrade to 100GB/month (for the same price?)


19282 posts

Uber Geek
Inactive user

  #719811 19-Nov-2012 22:35
Send private message

You really need to do a full isolation test and some basic fault checking on your side, Call the Vodafone support team and see if you can get a free Vodafone HG556a sent out (might need new 12 month contract term) but these modems are rock solid

Login to the Vodafone website ' My Account ' and check the data package on your account

4 posts

Wannabe Geek

  #720426 20-Nov-2012 22:34
Send private message

Done an isolation test today, virtually nothing changes when testing speed.

However, it is definitely the WAG200G router, which I just reset and re-configured it. Now happily with 15Mbps (which is better than normal).

Thanks, johnr for asking about the modem. Forgot about it when I was diagnosing what was the problem. :P

19282 posts

Uber Geek
Inactive user

  #720432 20-Nov-2012 22:40
Send private message

Are you now using a HG556A or the MT882?

33 posts


  #720446 20-Nov-2012 23:09
Send private message

Cabinetised? Yet in Red Network? Which network are you on? From the SNR, it seems to be the wholesale network...hmm.

Also, if you're using a MT882, make sure you have the latest firmware.

4 posts

Wannabe Geek

  #721792 23-Nov-2012 11:43
Send private message

I only got the MT882 and the Linksys WAG200G, I think the wireless modem was optional when we signed up for the plan a couple of years ago? Would it actually be much better?

The Linksys is faster than the MT882. (Both firmwares are up to date)

And yes, got moved to the wholesale network (formerly was on the Red Network before speeds dropped dramatically when the cabinet outside our house was set up).


478 posts

Ultimate Geek
Inactive user

  #724959 30-Nov-2012 00:23
Send private message

When I'm troubleshooting slow internet I first ring the ISP and get a line test done which will give a speed result and find out if there are any errors on the line and find out what speed should be expected.
Then I plug only a testing laptop into the modem which should be plugged into the primary jack point.
Then run the speed test. You can have them do an extended test over 24hrs.
Your line attenuation should not be zero.
You could have your ISP turn off interleaving.
You can lose up to around 1.5mbpbs between the router and the pc that you are running the speed test from. Anymore than that and you have an issue.
Also if your ISP says you should be able to get around 10mbps but your pc only gets 5 or 6 then you have an issue. When the internet seems slow, run a speed test then compare with the modem.
I can tell you that before ISP's even look at their side of things (apart from a speed test from their end) they will want you to eliminate all possible issues on your side.
Also try replacing the filters, faulty phones on other jack points can cause issues as well as faulty jack points themselves.
Over time as more customers get connected to the internet on the same exchange this can cause issues with speed as well.
Get a hard splitter installed.  

7327 posts

Uber Geek


  #724986 30-Nov-2012 07:19
Send private message

Umm, other than the strange 0dB line attenuation it would seem to me unless there is high error rates the DSL connection is not the problem. What attenuation does the MT882 report, and whats the ATM error rates reported by either modem. If both those check out ok then look elsewhere.

What speedtest server are you checking to.


Create new topic

Twitter and LinkedIn »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

News »

Intel introduces 10th Gen Intel Core H-series for mobile devices
Posted 2-Apr-2020 21:09

COVID-19: new charitable initiative to fund remote monitoring for at-risk patients
Posted 2-Apr-2020 11:07

Huawei introduces the P40 Series of Android-based smartphones
Posted 31-Mar-2020 17:03

Samsung Galaxy Z Flip now available for pre-order in New Zealand
Posted 31-Mar-2020 16:39

New online learning platform for kids stuck at home during COVID-19 lockdown
Posted 26-Mar-2020 21:35

New 5G Nokia smartphone unveiled as portfolio expands
Posted 26-Mar-2020 17:11

D-Link ANZ launches wireless AC1200 4G LTE router
Posted 26-Mar-2020 16:32

Ring introduces two new video doorbells and new pre-roll technology
Posted 17-Mar-2020 16:59

OPPO uncovers flagship Find X2 Pro smartphone
Posted 17-Mar-2020 16:54

D-Link COVR-2202 mesh Wi-Fi system now protected by McAfee
Posted 17-Mar-2020 16:00

Spark Sport opens its platform up to all New Zealanders at no charge
Posted 17-Mar-2020 10:04

Spark launches 5G Starter Fund
Posted 8-Mar-2020 19:19

TRENDnet launches high-performance WiFi Mesh Router System
Posted 5-Mar-2020 08:48

Sony boosts full-frame lens line-up with introduction of FE 20mm F1.8 G large-aperture ultra-wide-angle prime Lens
Posted 5-Mar-2020 08:44

Vector and Spark teamed up on smart metering initiative
Posted 5-Mar-2020 08:42

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.