Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




25 posts

Geek
+1 received by user: 4


Topic # 120981 20-Jun-2013 10:25
Send private message

Hi guys,

I recently switched to a Draytek Vigor 2710e modem so that I can set it up as a dumb modem to my Linksys EA4500. Unfortunately, while my Linksys is able to connect to the internet (and get a WAN IP and such) but I have no real connectivity.

I’ve been trying to follow steps that others have used for their Vigor 120, and while the modem is different, they should still work similarly as both have the PPPoE/PPPoA relay function. The screenshots for the web interface look similar, at any rate!

My understanding is that all I have to do is set the Draytek modem to enable PPPoE passthrough, ensure that the ISP name is left blank, which it is. The Draytek has the following settings:

VPI: 0
VCI: 100
Encapsulating Type: VC Mux
Protocol: PPPoA

Everything else has been left as default as I believe that if you have the PPPoE passthrough function checked, then it ignores all those other settings.

Next, I have my Draytek connected to a phone line, and LAN port #1 is connected to the Ethernet port (what I assume is the ‘input’ – as opposed to the LAN ports) of my Linksys. The DHCP server is still currently enabled on the Draytek.

Now, as for my Linksys configuration – I have it set to PPPoE mode, and have a default email/password in the authentication. All I can actually configure at this point is the login settings, ‘keep alive’ and the MTU settings. (I actually have no idea what the latter two does in terms of connectivity, besides assuming keep alive maintains the connection permanently.)

When I go to the status page of my Linksys, I am greeted by a WAN IP in the IPv4 section, and I can see that I have two DNS servers that it seems to have picked up automatically.

However I am unable to actually connect to an external site, whether through a wired connection or wireless! Confusingly, I could ping google.com and get a reply, but telecom.co.nz. I couldn’t connect to either sites with a browser. I assumed it was just a DNS server setting, as I could also ping Google’s DNS servers. However when I set my connection properties on the computer to connect to 8.8.8.8/8.8.4.4, I still faced the same issues I described above.

Where could I be going wrong in this setup? When I connect a computer to the Draytek directly I can see that in the connection status page, I can see the upstream/downstream speeds, which must mean that as far as the Draytek is concerned I’m connected to the internet as well.

I just have a few concerns with the following points:
  1. Should the Draytek have DHCP enabled?
  2. I am unable to manually set the DNS settings on the Draytek, but it looks like the DNS settings that the Draytek gets (I assume automatically) is not matching what the Linksys picks up. Furthermore none of the DNS settings also match what Telecom has.
  3. Even if I manually configure DNS on my computer, I still can’t get a connection.
What could be going wrong? :(

Just to cover all my bases – I am able to connect to the internet with the Draytek if I set it up normally.

Any help would be much appreciated! I was up until the wee hours of the morning in my determination to try set this up… until I was defeated by my sleepiness.

Thanks if you’ve read this far! :D

Create new topic
341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 840234 20-Jun-2013 12:41
Send private message

Hi Mallas,

Just an FYI, telecom.co.nz (and all other Telecom/Xtra hostnames) won't reply to pings, they've blocked it on their firewall.

Could you post a screenshot of your WAN IPv4 status page on the Linksys? It sounds like everything is set up correctly.



25 posts

Geek
+1 received by user: 4


  Reply # 840465 20-Jun-2013 17:35
Send private message

Aha! I had no idea about that Telecom thing, thanks for letting me know. Stupidly enough I didn't really try other IPs besides Google and Telecom.

Here's the IPv4 settings page in the router status, and that's the weird DNS thing I mentioned - it doesn't look like the typical Telecom DNS servers.


I tried changing it to see if that was what is causing my headaches, but I can't really figure out where I can change the DNS settings that's filtering down to the router. (I assume it's filtering down anyway - I can't actually set DNS settings in the page where you set up the PPPoE authentication)

Thanks!

 
 
 
 




25 posts

Geek
+1 received by user: 4


  Reply # 842129 23-Jun-2013 23:48
Send private message

Quick update... I tried again recently and saw that Steam and Skype were able to connect, and I was actually able to chat with people. However I still couldn't surf the web and most other apps had no connectivity as well.

Only thing I can think of is that this is a DNS setting problem... but I have already set my computer's DNS settings to Google's, but it still has the same effect. Is it possible that the modem or router is overwriting DNS settings?

I'm not sure what else to try anymore Cry

Edit: Just to add, I noticed that the Draytek was actually picking up the same DNS settings when it acts as a modem/router, instead of just a dumb bridge, so I guess this must be something to do with the Linksys. Argh!

341 posts

Ultimate Geek
+1 received by user: 26

Trusted

  Reply # 842180 24-Jun-2013 09:09
Send private message

It sounds like the Linksys could be failing at MTU Discovery and trying to send too-large packets down the PPPoE line. Could you try hard-setting the MTU (on the Linksys) to 1400 just to see what happens?

406 posts

Ultimate Geek
+1 received by user: 91

Subscriber

  Reply # 842189 24-Jun-2013 09:28
Send private message

Mallas: - it doesn't look like the typical Telecom DNS servers.


I am connected via Telecom using a DrayTek Vigor 120 and I have the same DNS servers.



25 posts

Geek
+1 received by user: 4


  Reply # 842388 24-Jun-2013 14:17
Send private message

theEd: It sounds like the Linksys could be failing at MTU Discovery and trying to send too-large packets down the PPPoE line. Could you try hard-setting the MTU (on the Linksys) to 1400 just to see what happens?


Ahh, this looked so promising! I decided to check what my MTU was, and found that it was actually 1472 as opposed to 1492 which I always assumed it was. Unfortunately, however, neither 1472 or 1400 worked when I set it manually.

One thing to note is that I'm actually able to ping the URLs of websites as well, not just IP. So I suppose it's not a DNS thing anymore!

MackinNZ: I am connected via Telecom using a DrayTek Vigor 120 and I have the same DNS servers.


Thanks, I just realized what I looked up was actually pretty old stuff from Telecom. If I use the Draytek as a modem/router I get connectivity as I would normally, with the same DNS settings too.



Anyway, onward! I might try making the MTU smaller and smaller to see if things will start working, seeing as I can get a reply from Google with 32 bytes of data.

Edit: Interestingly enough if when I have the Draytek acting as the modem/router, my MTU is 1472 as above, but when I set the Draytek as a pure bridge it drops down to 1424. Setting everything down to MTU 1400 does not seem to affect connectivity.

I have also tried to set the MTU setting on my wifi adapter, but still no real result.

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.