I'm at the end of my rope with this...

I recently bought a TP-Link 750N dual band router (model number WDR-4320 - the 4300 is the western version. Imagine my surprise when the interface was entirely in Chinese with no option update to english firmware/no dd-wrt support).

Having spent two days trying to get this set up, I got it working before it all turned to s**t. I guess I should run through how I got it set up in the first place.

Initially, I wanted to set up the Thomson modem/router (TG 585v7... yes. I know. Thomson. I was practically asking for trouble) to act as a bridge and get access via PPPoE. The Thomson, apparently, doesn't have a bridge mode. I tried an old Belkin modem/router in bridge mode and set the TP-Link to PPPoE but this didn't work - either I need a special set up with Telecom to use PPPoE or the MTU settings on the Thomson didn't match what Telecom supplied (1500 - I have no idea what MTU does, only in PPPoE mode I could only set it as high as 1480. 1500 was available in dynamic IP and static IP WAN modes). All the rest, VCI/VPI, encapsultation mode, etc, were good.

Then I read that you can use the "Assign a public IP" option on the Thomson in a similar way. Public IP was generated, TP-Link was set to Dynamic IP. Only changes that I made to the TP-Link were restricting the DHCP pool so that it did not clash with the Thomson's, changing the routers IP/gateway, and plugging in some DNS settings.

Anyway, after a day and a half of google translate I got this working. Everything was fine, browsing via ethernet/wifi = all good. Then I unplugged the TP-Link to move it elsewhere. At this point the Thomson no longer recognises the TP-Link in the list of devices: the ethernet port shows up as Unknown (whereas other ethernet connected-devices give the correct port number). Opening up the properties within the Thomson interface shows the status of the TP-Link as inactive, however it still assigns it an IP, one not in the same subnet as all the others (so I'm guessing the "public" part is working fine). The TP-Link now won't get an IP from within its interface.

As an aside, this "inactive device" issue happened once or twice during the setup but the problem resolved spontaneously/I may have done something but I have no idea what. At the point that it was working, and assigning an IP, I unplugged it a few times and it would reconnect without problem. Something in Thomson must have snapped, likely it's weak will broke from the horrors that it has experienced.

Basically, the question becomes how do I get the Thomson to recognize the TP-Link as a legitimate, active device? I've tried hard-resetting both and starting from scratch. Tried other ethernet ports and cables. I'm at the point where it would probably be easier to buy a dedicated modem were I sure that PPPoE mode would work/it's not the TP-Link that's the problem.