Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




56 posts

Master Geek


Topic # 129006 31-Aug-2013 15:14
Send private message

I am trying to set up my Belkin ADSL modem and Linksys wireless-N router (model  WRT120N) in a new location. They worked perfectly together in my old apartment.
The modem installed and configured OK, and I get a good internet connection using the LAN cable direct to my PC.
I reset the router to its factory default, and then reconfigured it using the wizard on the CD that came with it. Everything runs smoothly, and it tells me it has installed and configured correctly, and is ready to use.
Everything seems to be OK - except I can't connect my smartphone (Samsung S3) to the WiFi signal! (It could be a phone problem not a modem/router problem, but it's the only wireless device I have on hand to test the signal. And it works OK using the old Thomson modem/router I'm trying to replace).
I've tried switching everything (phone, computer, modem, and router) off then on again after a couple of minutes.
I've tried re-configuring the router (twice). I tried different wireless security options thinking that might make a difference: when using WPA/WPA2 the phone "authenticates" for a small eternity after entering the password - normally it would connect to a new signal almost immediately. When using WEP the phone shows "disabled" immediately after entering the password.
I don't know what to do next, other than going back to the old system that I thought I was improving on!
I don't pretend to know much about this, so please keep any advice as non-technical as possible.

Create new topic
19282 posts

Uber Geek
+1 received by user: 2600
Inactive user


  Reply # 887408 31-Aug-2013 15:15
Send private message

Remove all access point names it has stored off the WIFI on the handset

BDFL - Memuneh
61762 posts

Uber Geek
+1 received by user: 12424

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 887416 31-Aug-2013 15:44
Send private message

What band is the router configured to use? Is the router configured to use one type of WiFi only (b/g/n)? Is the router using 20 MHz, 40MHz or Auto?

There are lots of things that can break it...





 
 
 
 


624 posts

Ultimate Geek
+1 received by user: 124


  Reply # 887431 31-Aug-2013 16:28
Send private message

johnr: Remove all access point names it has stored off the WIFI on the handset


Yep, like my iPod, otherwise it tries to connect with the old password stored sometimes - especially on a 'default' ssid setup.

624 posts

Ultimate Geek
+1 received by user: 124


  Reply # 887432 31-Aug-2013 16:31
Send private message

Make sure you're only using one DHCP server too. If you have the Linksys LAN port connected to the Belkin (assuming not double NAT'ing through it's WAN port) then it could be a DHCP issue. I've experienced this before and it made it look like it was failing on the password (but no password error), except it was failing on being assigned an IP and just coming up with a could not connect generic warning.



56 posts

Master Geek


  Reply # 887479 31-Aug-2013 17:57
Send private message

Thanks for the responses, but they all appear to be written in Martian. I'd really appreciate reposting in simpler language! This may be the Geekzone Forum, but I'm only a Geeklet.
:-)

2018 posts

Uber Geek
+1 received by user: 1129


  Reply # 887483 31-Aug-2013 18:09
Send private message

What they said was

Tell the phone to forget the wifi network. It should then search for it and connect again like it's never seen it before. This will fix it if the phone was trying to use old information to log on.

Then, if that doesn't work.
Make sure only one of the devices (modem & router) have DHCP turned on (you'll have to use the devices web pages to change it probably). DHCP is the service that gives your devices an IP address, if you have 2 devices handing out addresses it goes pear shaped.

Hows that, simple enough?




Location: Dunedin

2527 posts

Uber Geek
+1 received by user: 939

Subscriber

  Reply # 887539 31-Aug-2013 20:01
Send private message

As above, you only have one device doing DHCP, and you've tried 'forget'ing all the SSIDs on the phone? Presumably you don't have MAC filtering enabled, and are you using WPA2-Personal with AES?




Windows 7 x64 // i5-3570K // 16GB DDR3-1600 // GTX660Ti 2GB // Samsung 830 120GB SSD // OCZ Agility4 120GB SSD // Samsung U28D590D @ 3840x2160 & Asus PB278Q @ 2560x1440
Samsung Galaxy S5 SM-G900I w/Spark



56 posts

Master Geek


  Reply # 887596 31-Aug-2013 22:11
Send private message

Hi Andrewnz, and thanks for translating for me!
I've tried telling the phone to forget the network, but the problem persists.
As far as I can make out only the modem has DHCP enabled.
It seems strange to me that the setup worked perfectly before (in a different location and using a different phone line and ISP). I've reset both the router and the modem to their factory defaults, so I don't understand why it shouldn't work just as if I was starting from scratch. And, as I say, the modem works fine with a LAN cable connection, and the router setup wizard tells me on completion that everything is set up and configured correctly.
If I can't get it sorted by tomorrow afternoon I'll have to set everythin back up how it was, using the inferior Thompson router. Well, supposedly inferior - but at least it works!

87 posts

Master Geek
+1 received by user: 12


  Reply # 887624 31-Aug-2013 22:41
Send private message

Does the Belkin also have a Wifi transmitter? If so - Are you sure that you havent inadvertently set up the Belkin with the Wifi still on ( assuming you only want to get Wifi from the Link-Sys) and it and the Link-sys may be trying to transmit on the same channel which will cause massive interference?

2090 posts

Uber Geek
+1 received by user: 356

Lifetime subscriber

  Reply # 887625 31-Aug-2013 22:43
Send private message

Maybe you can make it clear as to whether the Belkin connects to the WAN or LAN interfaces on the Linksys.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




56 posts

Master Geek


  Reply # 887754 1-Sep-2013 13:20
Send private message

Thanks for all the responses. Problem solved - everything is now working, and I can confirm what I had been advised: the Belkin modem / Linksys router is a much better option than the Thompson modem/router it replaced (ie a stronger signal that doesn't drop out at the extreme edge of the wireless range, namely the other end of the apartment).
The solution? 100% human error - mine, of course - when setting up, I had confused the router password with the wireless security password, and entered it in the wrong place. I did warn everyone that I was only a geeklet and not a fully-formed Geek - now I've proved it! :-)

624 posts

Ultimate Geek
+1 received by user: 124


  Reply # 887977 1-Sep-2013 22:05
Send private message

Glad to hear it's all good.


Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.