Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


57 posts

Master Geek
+1 received by user: 1


Topic # 14012 11-Jun-2007 14:03
Send private message

I’ve been “geeking” about with computers since I bought my shiny new “Sinclair ZX81” way back in 1970 something. But never tried networking before and it’s got me totally stuffed.

 

I’m trying to network 2 desktops (wired) and a wireless connection all with access to the internet through a just installed TelstraClear modem

 

I bought a D-Link DI-524UP and having lots of trouble getting nowhere – is it me or the router - probably my patchy knowledge, but as it has only USB 1.1, I’m wondering if I’ve been conned into an old model? I’ve installed the latest flash update.

 

My main computer is running Vista and the 2nd one runs Win 98SE. Without the router connected and with the TCL IP address etc loaded in TCP/IPv4 I have a good internet connection.

 

With TCP/IPv4 set to “obtain address automatically” and the router connected I can access and complete the router set-up, but have no internet and can’t “see” the 2nd computer. All this done with software firewalls disabled. Computers show IP addresses 192.168.0.100 and 192.168.0.101 but haven’t been able to make them see each other through Windows Explorer, I must be missing something.

 

The WAN indicator light flashes continuously (but no internet) and the D-Link website says that this is due to “older cable modem speed negotiation problem” they say this will correct if modem powered-up first – but this makes no difference.

 

Sorry for the length of this post but trying to explain all – can anyone offer some help please – is the router rubbish? Am I missing some obvious steps (probably).

 

Any advice gratefully received.


Create new topic
BDFL - Memuneh
61303 posts

Uber Geek
+1 received by user: 12043

Administrator
Trusted
Geekzone
Lifetime subscriber

  Reply # 74297 11-Jun-2007 14:21
Send private message

The USB port in the router is for a printer. You will plug the PCs via Ethernet cables.

When you configure the router make sure you enter the IP address, gateway and DNS addresses in the router configuration, and change both your PCs to use DHCP ("Obtain adddress automatically").

Once you do that, can you access the Internet from your PCs?

If it works, then you need to sort out the connection between your PCs. Open a command prompt on each and run IPCONFIG. You will see its IP address. Now try running "ping [IP address]" and see if each can see reply to the other.

If all works ok, you would be able to map drives from one PC to another. You will use Windows Explorer to map. Click Tools | Map and enter the address as \\[IP address]\[shared drive].

Make sure both your PCs have File sharing enabled in the network adapter, and allowed in the firewall. Also check that the drives are actually shared (right-click the drive and select Properties). Most importantly, when mapping the drive click the option to enter a user name and password for correct authentication - or use the same name/password in both computers.







57 posts

Master Geek
+1 received by user: 1


  Reply # 74299 11-Jun-2007 14:47
Send private message

Thanks for the quick reply, I'll have to wait until I get home from work to try all this - here's hoping.
And yes I understand the USB is for the printer, just thought that as it's 1.1 not 2.0 it might indicate an older model router.

cheers



57 posts

Master Geek
+1 received by user: 1


  Reply # 74355 12-Jun-2007 10:43
Send private message

Thanks  freitasm. Getting there nicely thanks. I hadn’t configured the router with IP address etc, simply because the installation guide says “choose Dynamic IP Address for most cable modems” Just goes to show, set-up wizards don’t know everything J

 

Now have internet on both PCs, each can ping the other. On the Vista machine I can see and access the drives on the Win98 machine.

 

The Win98 PC shows the Vista PC drives in Windows Explorer but says “access denied” and clicking properties shows 2 empty drives of 2GB each, which is wrong, should be approx 1 at 40GB and 1 at 210GB and not empty.

 

Had a problem with Vista in setting-up file sharing also. The “share” tab in properties takes ages to display then after clicking “share this drive” it comes up with a not responding message and asks to close and restart itself. Clicking OK closes but doesn’t restart. Despite this the icon in Explorer shows as a shared drive so I guess it works??

 

Any comments or suggestions gratefully received.


BDFL - Memuneh
61303 posts

Uber Geek
+1 received by user: 12043

Administrator
Trusted
Geekzone
Lifetime subscriber

Reply # 74358 12-Jun-2007 10:57
Send private message

Good to know the networking part is solved...

As for Windows Vista. Restart the machine. After this, on your Windows XP machine you should be able to map the entire drive if using c$ (or any other drive letter). The $ sign indicates an "invisible" share, and c$ is there by default. You will need username and password to correctly connect, and that's why I recommended using the same in both PCs, since it will make it transparent...

You only need to create a share if you want to share a specific folder instead of the whole drive...







57 posts

Master Geek
+1 received by user: 1


  Reply # 74651 14-Jun-2007 12:18
Send private message

Now this is getting embarrassing, I’ve had no more success in getting this to work. It’s been mentioned the importance of entering a user name and password for authentication but I haven’t had an option to enter either when mapping drives. Where is the entry screen for this? (now feeling really stupid).

 

I’m talking Windows Vista and Windows 98SE and now wondering if in fact this can be done at all, there is some discussion at –

 

http://www.chicagotech.net/netforums/viewtopic.php?t=523

 

http://windowshelp.microsoft.com/communities/newsgroups/en-us/default.mspx?=&query=network+vista+98

 

And this post in particular sounds pretty negative –

 

In article <osbk23l49t77hct076u6uko5duqd535ia6@4ax.com>, Chuck
<none@example.net> wrote:
>On Sat, 21 Apr 2007 13:00:14 +0200, "Oivind" <oeivinr@online.no> wrote:
>
>>Does windowsxp home talk to win98 SE in a home network?
>>or
>
>One of the reasons why Windows Networking is so complicated is interoperability.
>All versions of Windows are interoperable with all other versions, by design.
>
>All of that said, there are known issues with combining Windows 9x (95, 98, ME)
>and Windows NT (NT 2000, XP, probably Vista). And probably some unknown issues
>too.
><
http://nitecruzr.blogspot.com/2006/05/older-operating-systems-windows-98.html>
>
http://nitecruzr.blogspot.com/2006/05/older-operating-systems-windows-98.html

Speaking of Windows Vista:

1. Networking Vista with Windows XP and 2000 works fine.

2. A computer running Windows Vista can access shared folders
belonging to a computer running Windows 9x.

3. Microsoft doesn't support accessing shared folders belonging to a
computer running Windows Vista from a computer running Windows 9x.

I've seen the following problems when trying to access Vista's shared
folders from 9x.

1. Incompatible default network authentication protocols. Windows
95/98/Me uses LM and NTLM authentication. Vista uses NTLMv2
authentication. This causes a prompt for the IPC$ password on
95/98/Me when password protected sharing is enabled on Vista. There
is no valid response to the IPC$ prompt.

2. Incomplete enumeration of shares. 9x only sees some of Vista's
shared folders. The names of some shared folders are truncated,
making them inaccessible.

3. Instability. Accessing Vista's shared folders makes 9x hang or
crash.

To the best of my knowledge, no one has found a solution to problems
#2 and #3. Microsoft is aware of these problems, but there's no
guarantee that they will ever fix them.

To solve problem #1, configure Vista to use LM and NTLM authentication
to allow access from 9x when password protected sharing is enabled.
I'd like to thank my fellow MVP Evan Pearce, who helped me understand
and test this:

1. Click the Start button, type "regedit" in the Start Search box, and
press Enter.

2. Click "Continue" in the User Account Control prompt.

3. Open this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

4. If they don't already exist, create DWORD values named
LmCompatibilityLevel and NoLmHash.

5. Set LmCompatibilityLevel to 1.

6. Set NoLmHash to 0.

7. Restart the Vista computer.

8. Go to Control Panel > User Accounts, click "Change your password",
enter your current password in the boxes for "Current password", "New
password", and "Confirm new password", and click "Change password".
--
Best Wishes,
Steve Winograd, MS-MVP (Windows Networking)

Please post any reply as a follow-up message in the news group
for everyone to see. I'm sorry, but I don't answer questions
addressed directly to me in E-mail or news groups.

Microsoft Most Valuable Professional Program
http://mvp.support.microsoft.com

 

So, any thoughts, confirmation or comments??

  

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.