Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


265 posts

Ultimate Geek
+1 received by user: 19


Topic # 147042 6-Jun-2014 21:08
Send private message

Hey guys,

have a home server running server 2003. Ended up with a spare pci Wireless N card so have put it in the server with the thought of having it as a failover (we rent and the server ended up at the other end of the house than the main router/vdsl so its on the end of a chain of Cat5e/switches to get lan from one end of the home to the other, Not ideal but best we could do without going crazy with holes.

So putting the wifi in, and suddenly the rest of the network is trying to access the home server over the wifi link :/ I have changed the priority order in advanced settings but still going via wifi link.

From googling, would I be correct in saying that you can't make one network connection a failover link?




If you have to run heating in winter, you don’t own enough computers.


Create new topic
3409 posts

Uber Geek
+1 received by user: 404

Trusted

  Reply # 1060556 6-Jun-2014 21:12
One person supports this post
Send private message

It's gonna be hard. I personally wouldn't bother.







265 posts

Ultimate Geek
+1 received by user: 19


  Reply # 1060557 6-Jun-2014 21:13
Send private message

Zeon: It's gonna be hard. I personally wouldn't bother.


Oh well lol was worth a thought ;)

Might leave it in and just disable it for now.




If you have to run heating in winter, you don’t own enough computers.


3583 posts

Uber Geek
+1 received by user: 1316

Subscriber

  Reply # 1060585 6-Jun-2014 21:54
Send private message

Is it not just a case of setting up static routes and give the route that goes out the WLAN a higher distance than the LAN. Then it will use the LAN until it goes down and then it will go over the WLAN.

- I have zero idea on Windows Server though.

2442 posts

Uber Geek
+1 received by user: 720

Trusted
Lifetime subscriber

  Reply # 1060624 6-Jun-2014 23:05
One person supports this post
Send private message

Internet Protocol Version 4, Properties, Advanced, untick Automatic Metric and set it to 20 or similar. This will make it a lower priority than the cable which will have an automatic metric of 1.

To check go to a command prompt and type ROUTE PRINT




"4 wheels move the body.  2 wheels move the soul."

“Don't believe anything you read on the net. Except this. Well, including this, I suppose.” Douglas Adams

450 posts

Ultimate Geek
+1 received by user: 125


  Reply # 1061619 9-Jun-2014 08:36
One person supports this post
Send private message

There is not a built in failover mechanism for what you seem to be trying.  I'm assuming the LAN and WLAN are the same subnet?  If so, your problem is probably more which interface services bind to, rather than routing.  If they are binding to both then you need some mechanism for the clients to favour one over the other.  AFAIK none of this is supported, and has others have suggested getting it working is probably more hassle than it is worth.

If you do want to persist, I'd suggest keeping the Wifi down, and running a script that brings it up if you can't ping the router from the LAN interface.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.