Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




88 posts

Master Geek
+1 received by user: 2


Topic # 185221 14-Nov-2015 15:17
Send private message

Hi all, Hope some of the expert or experience network Geekzone members can help with my questions.

My home network set up currently with main VDSL2 modem router downstairs and LAN powerline up to a router upstairs. It's currently working great but recently I purchased Seagate personal cloud NAS drive.

The way it set up now the main modem and router upstairs work in different domain/subnets and therefore for the NAS only visible in the main modem domain and none of the upstairs devices can't see the NAS drive.

Could anyone advise provide a great link for me on:

 

     

  1. How I can set up the router upstairs to be part of downstairs modem/router domain/subnet
  2. Whether this is the best way to set it up without degrading the current network performance as currently it's working great

 



Thank you in advance :)

Filter this topic showing only the reply marked as answer Create new topic
3626 posts

Uber Geek
+1 received by user: 1702

Subscriber

  Reply # 1428026 14-Nov-2015 16:04
Send private message

Why do you have two routers?

Why not have a switch (or WAP) upstairs and the modem downstairs?




Sideface


4380 posts

Uber Geek
+1 received by user: 1231


  Reply # 1428027 14-Nov-2015 16:08
Send private message

Can you configure your upstairs router to bridge mode or similar - essentially disabling the routing functions

 
 
 
 




88 posts

Master Geek
+1 received by user: 2


  Reply # 1428028 14-Nov-2015 16:13
Send private message

Sideface: Why do you have two routers?

Why not have a switch (or WAP) upstairs and the modem downstairs?



I only have one extra router the modem downstairs. Apology for the confusion as I mentioned above modem router = modem router combo in one.

and upstairs is wireless router which I currently use as switch/WAP unfortunately they're not in the same domain/subnet as the downstairs modem hence upstair can't see the NAS drive. 



88 posts

Master Geek
+1 received by user: 2


  Reply # 1428029 14-Nov-2015 16:16
Send private message

RunningMan: Can you configure your upstairs router to bridge mode or similar - essentially disabling the routing functions


Bridge mode not ideal due to the location and I don't think the performance would be as consistent as powerline.

4380 posts

Uber Geek
+1 received by user: 1231


  Reply # 1428030 14-Nov-2015 16:17
Send private message

Und3f:
Sideface: Why do you have two routers?

Why not have a switch (or WAP) upstairs and the modem downstairs?



I only have one extra router the modem downstairs. Apology for the confusion as I mentioned above modem router = modem router combo in one.

and upstairs is wireless router which I currently use as switch/WAP unfortunately they're not in the same domain/subnet as the downstairs modem hence upstair can't see the NAS drive. 


You (generally) only need one router for a domestic network - it routes between the local and wide (internet) networks. Adding another router in this case is basically splitting your network into two, leading to the issues you have.

You need to stop the routing between upstairs and downstairs, and bridge them instead. Some routers have this ability, some wont.

4380 posts

Uber Geek
+1 received by user: 1231


  Reply # 1428031 14-Nov-2015 16:20
Send private message

Und3f:
RunningMan: Can you configure your upstairs router to bridge mode or similar - essentially disabling the routing functions


Bridge mode not ideal due to the location and I don't think the performance would be as consistent as powerline.


Not sure how location affects a bridge's performance....

You'll still need the powerline adaptors or a physical cable between the two.

1742 posts

Uber Geek
+1 received by user: 240

Subscriber

  Reply # 1428032 14-Nov-2015 16:26
Send private message

Add a static route to router with NAS connected telling it how to get to devices on the other network.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test




88 posts

Master Geek
+1 received by user: 2


  Reply # 1428034 14-Nov-2015 16:29
Send private message

RunningMan:
Und3f:
RunningMan: Can you configure your upstairs router to bridge mode or similar - essentially disabling the routing functions


Bridge mode not ideal due to the location and I don't think the performance would be as consistent as powerline.


Not sure how location affects a bridge's performance....

You'll still need the powerline adaptors or a physical cable between the two.


I kinda get it now. I thought bridging only works with wireless as my router has WDS bridging mode hence I mention location.

So based on your recommendation I should LAN bridge. Cool! Can I check couple things with you

Do I leave upstairs(router) powerline end to WAN port still?
From what I understood from reading google sources, to bridge I need to below steps. Am I missing anything?

 

     

  1. Update router IP address to the same subnet e.g. if modem 192.168.1.1 make sure router 192.168.1.X
  2. Disable DHCP

 

Thank you kindly



1842 posts

Uber Geek
+1 received by user: 579

Subscriber

  Reply # 1428035 14-Nov-2015 16:37
Send private message

Yes do that. But you need to plug the network cable into a lan port on the 2nd router. Don't plug anything into the wan port.







88 posts

Master Geek
+1 received by user: 2


  Reply # 1428036 14-Nov-2015 16:38
Send private message

Aredwood: Yes do that. But you need to plug the network cable into a lan port on the 2nd router. Don't plug anything into the wan port.


Great will try now!

4380 posts

Uber Geek
+1 received by user: 1231


  Reply # 1428045 14-Nov-2015 16:41
Send private message

Und3f: [snip]

Do I leave upstairs(router) powerline end to WAN port still?
From what I understood from reading google sources, to bridge I need to below steps. Am I missing anything?

 

     

  1. Update router IP address to the same subnet e.g. if modem 192.168.1.1 make sure router 192.168.1.X
  2. Disable DHCP

 

Thank you kindly




Depends!

If you can disable the routing functions in the router, so it is acting as a bridge only, then leave the powerline plugged into the WAN port - this effectively makes you have one big network.

If you can't run the router as a bridge, then the workaround is to do as you've written above, and as @Aredwood says, connect the powerline to a LAN port instead - this is a bit of a hack, but will generally work OK.



88 posts

Master Geek
+1 received by user: 2


Reply # 1428053 14-Nov-2015 17:02
Send private message

Okay ALL - Thank you and thank you! 

Work like a charm... bridging was the answer and I can see my NAS drive and it's awesome.

Have a great day!

Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Intel unveils the 8th Gen Intel Core Processor family for desktop
Posted 25-Sep-2017 19:45


Chow brothers plan to invest NZ$100 million in technology
Posted 24-Sep-2017 16:24


Symantec protects data everywhere with Information Centric Security
Posted 21-Sep-2017 15:33


FUJIFILM introduces X-E3 mirrorless camera with wireless connectivity
Posted 18-Sep-2017 13:53


Vodafone announces new plans with bigger data bundles
Posted 15-Sep-2017 10:51


Skinny launches phone with support for te reo Maori
Posted 14-Sep-2017 08:39


If Vodafone dropping mail worries you, you’re doing online wrong
Posted 11-Sep-2017 13:54


Vodafone New Zealand deploy live 400 gigabit system
Posted 11-Sep-2017 11:07


OPPO camera phones now available at PB Tech
Posted 11-Sep-2017 09:56


Norton Wi-Fi Privacy — Easy, flawed VPN
Posted 11-Sep-2017 09:48


Lenovo reveals new ThinkPad A Series
Posted 8-Sep-2017 14:37


Huawei passes Apple for the first time to capture the second spot globally
Posted 8-Sep-2017 10:45


Vodafone initiative enhances te reo Maori pronunciation on Google Maps
Posted 8-Sep-2017 10:40


Voyager Internet expand local internet phone services company with Conversant acquisition
Posted 6-Sep-2017 18:27


NOW Expands in to Tauranga
Posted 5-Sep-2017 18:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.