Hey guys,

I have spent the past 3 days trawling the internet trying to work out what I cant get Airplay to work in a number of different configurations. Something's really wrong but I don't know where to start/continue.

I have Vodafone cable (don't get me started on the massive amount of issues I'm having with dropouts and extended outages, but that's another story) running off a Technicolor TC7210 – Cable modem/router. Attached to one LAN port via a LONG LAN cable to the other end of the house is a Netgear N600 DGND3700v2 in wireless AP mode. Below are the basic configuration changes from Default.

Technicolor TC7210:
- Modem Login User and Password changed - gotta keep things secure
- DHCP scope changed to X.X.X.21-199
- I use 2-20 for Static IPs and 200 onwards for additional network hardware (WAY overkill I know)
- I have 5 port forwards for various things - None are common ports used by anything

Netgear N600 DGND3700v2:
- Modem Login User and Password changed
- DHCP disabled
- IP set to X.X.X.200
- Wireless in AP mode

I have a Win7 PC connected to the Technicolour via a cable. IP static at X.X.X.2. Used for:
- Storage PC
- Plex server
- Plex Home Theatre
- Latest iTunes installed (fresh)
- Has 5K player installed for testing (an airplay server)
- Spotify PC
- Does have DNS settings for Unblock US

I also have a Win10 HTPC connected to the Technicolour via Cable. IP Dynamic with same Unblock US DNS addresses
- iTunes installed
- Plex HT
- Spotify PC
- Has 5K player installed for testing (an airplay server)

Everything else network related works perfectly including file sharing, network discovery, Spotify connect, MSTSC, printing, internet, plex media, Home automation, no matter how you are connected etc. 

I think that's all the relevant info.

So, whats happening with Airplay??

Well here are the scenarios:

*iTunes open on Win7 PC OR the HTPC, Plex and 5k closed. iPhone connected to Technicolor OR Netgear Wifi  = No airplay icon on either devices at all. Nada!
*Plex OR 5k player open on Win7 PC. iPhone on either WIFI = Airplay option pops up on iPhone, but no audio plays when selected. No sign of iPhone as an option on the PC 5K programme though.
*Interestingly, if iTunes is open on the PC at the same time as Plex OR 5k, iTunes shows the airplay icon and will play to Plex or 5k. Same goes for the HTPC. BUT neither will play to the others iTunes. So airplay works from anything (including iTunes) to Plex or 5k from wired PCs through the Technicolor modem, but not TO iTunes.
*Win8 Surface connected to Technicolor Wifi with iTunes open on Win7 PC OR HTCP = no airplay options anywhere. As soon as one or the other has Plex or 5k open, airplay will play to it. So airplay works from iTunes to plex or 5k from wifi to wired, via Technicolour from windows to windows...but not iTunes to iTunes
*Have tried the HTPC both wired and wireless to the Netgear switch and no change to the above.

So my summary is:
Windows iTunes wont airplay to any other windows iTunes no matter how its connected
Windows iTunes wont play or receive airplay to/from an iPhone no matter how its connected
iTunes WILL airplay to Plex or 5k no matter how its connected
iPhone will not register or stream airplay to iTunes at all
iPhone will register airplay to plex or 5k, but wont stream to it

So.......how on earth do I go about fault finding this mess?

Should mention I have tried all the basics - disable windows firewall, restart everything, check through all the router settings, reinstalled iTunes/Bonjour etc.

Your help would be much appreciated!