Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


2853 posts

Uber Geek
+1 received by user: 491


Topic # 196129 20-May-2016 11:20
Send private message

We have two access points in the house, one at each end of the house effectively. Both have the same SSID and password. We also have another access point with a separate SSID and password.

 

Some mobile devices switch seamlessly between either of the two access point with the same name but others refuse to swap over and in the case of my wifes S7 Edge will revert to Mobile Data rather than swap to the other access point. It also won't swap to the access point with the different SSID.

 

If you turn WiFi on the phone of and back on it will connect to the stronger signal.

 

Does anyone have any suggestions on how this might be fixed so that the device will switch automatically between access points?

 

 





Sony Xperia X running Sailfish OS. https://sailfishos.org The true independent open source mobile OS 
Samsung Galaxy Tab S3
Nokia N1
Dell Inspiron 14z i5


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
'That VDSL Cat'
8685 posts

Uber Geek
+1 received by user: 1879

Trusted
Spark
Subscriber

  Reply # 1556094 20-May-2016 11:23
Send private message

Try forgetting the network and reconnecting it.

 

 

 

when i was testing my roaming setup, i used the Fritzbox app to connect to a certain channel, that saved to my config to only connect to that AP.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


607 posts

Ultimate Geek
+1 received by user: 28


  Reply # 1556147 20-May-2016 11:43
Send private message

Also check the WPA settings, should be the same on both, Eg mandated to WPA2+AES preferably on both

536 posts

Ultimate Geek
+1 received by user: 154


  Reply # 1556151 20-May-2016 11:45
Send private message

I think I remember reading somewhere that this is (especially) an issue with Android devices?

 

 

 

Might be wrong but think I came across that when I was having the same problem.


Hmm, what to write...
996 posts

Ultimate Geek
+1 received by user: 506

Trusted
Subscriber

  Reply # 1556183 20-May-2016 12:28
Send private message

AFAIK the only surefire way is to tell your access points to disconnect devices under a certain signal threshold. Mine work well set to disconnect anything below -90dBm

 

IF you don't have that sort of control you may be out of luck





Matthew


1552 posts

Uber Geek
+1 received by user: 353


  Reply # 1556226 20-May-2016 13:04
Send private message

tangerz:

 

I think I remember reading somewhere that this is (especially) an issue with Android devices?

 

 

Ive seen this on a few i-things .

 

2 options:
-disconnect the devices wifi & reconnect each time they move about the house.
-give ALL access points a different SSID . They connect to the SSID closest to where they are. This is the most foolproof 'fix'

 

 

 

 


14141 posts

Uber Geek
+1 received by user: 2546

Trusted
Subscriber

  Reply # 1556228 20-May-2016 13:08
Send private message

Yep, this happens. You may be able to work around it, but that's how most Android devices work. Use Tasker or Llama to turn off mobile data when you're at home, but I'm not sure you can use either of those to select the strongest WAP. My solution was to put one WAP up high in the center of the house.





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


What does this tag do
972 posts

Ultimate Geek
+1 received by user: 203

Subscriber

  Reply # 1556229 20-May-2016 13:09
Send private message

Sometimes reducing the power of your APs slightly will help roam devices


215 posts

Master Geek
+1 received by user: 82


  Reply # 1556264 20-May-2016 13:44
2 people support this post
Send private message

For a wireless device to roam there has to be an area where the coverage cells of both access points overlap.  If this overlap area is too small, or non-existent, wireless devices will not be able to roam and if this overlap area is too large then the wireless clients can become "sticky" and not want to roam.

 

How large is your coverage overlap?

 

Another setting to look at is your data rates.  If you have the low data rates enabled then the wireless clients are more likely to become "sticky".  As a rule I always disable the 802.11b data rates (1, 2, 5.5 and 11 Mbps), unless you have a wireless device that needs 802.11b data rates, and by increasing the lowest supported data rate you will make your wireless devices want to roam quicker.


'That VDSL Cat'
8685 posts

Uber Geek
+1 received by user: 1879

Trusted
Spark
Subscriber

  Reply # 1556440 20-May-2016 17:35
Send private message

mdooher:

 

AFAIK the only surefire way is to tell your access points to disconnect devices under a certain signal threshold. Mine work well set to disconnect anything below -90dBm

 

IF you don't have that sort of control you may be out of luck

 

 

 

 

this. although i found this to also cause an issue of APs blocking clients that are were sitting on the threashold right when the last check was ran though.

 

 

 

atleast for andriod devices, i have actually gone as far as to setup another wireless for testing for me, this has roaming turned off and my M8x roams far more smoothly and without fault than any roaming protocol offered on the E400s.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.




2853 posts

Uber Geek
+1 received by user: 491


  Reply # 1556745 21-May-2016 11:48
One person supports this post
Send private message

Crowdie:

 

For a wireless device to roam there has to be an area where the coverage cells of both access points overlap.  If this overlap area is too small, or non-existent, wireless devices will not be able to roam and if this overlap area is too large then the wireless clients can become "sticky" and not want to roam.

 

How large is your coverage overlap?

 

The overlap is good but not too large, I've been using a WiFi analyser to check.





Sony Xperia X running Sailfish OS. https://sailfishos.org The true independent open source mobile OS 
Samsung Galaxy Tab S3
Nokia N1
Dell Inspiron 14z i5




2853 posts

Uber Geek
+1 received by user: 491


  Reply # 1556746 21-May-2016 11:50
One person supports this post
Send private message

mdooher:

 

AFAIK the only surefire way is to tell your access points to disconnect devices under a certain signal threshold. Mine work well set to disconnect anything below -90dBm

 

IF you don't have that sort of control you may be out of luck

 

 

I've downloaded an app call SWIFI which allows you to set signal threshold levels. So far it seems to work.





Sony Xperia X running Sailfish OS. https://sailfishos.org The true independent open source mobile OS 
Samsung Galaxy Tab S3
Nokia N1
Dell Inspiron 14z i5


1488 posts

Uber Geek
+1 received by user: 334


  Reply # 1556817 21-May-2016 14:29
Send private message

I have been trialling an app called WiFi roaming.

https://play.google.com/store/apps/details%3Fid%3Dcom.heleron.wifiroamingfix

21463 posts

Uber Geek
+1 received by user: 4362

Trusted
Subscriber

  Reply # 1557185 22-May-2016 10:58
One person supports this post
Send private message

I tried some app that claimed to help with wifi roaming - cant recall which one, and it hammered my battery life and actually made me end up on cellular way more often.





Richard rich.ms

403 posts

Ultimate Geek
+1 received by user: 208

Subscriber

  Reply # 1557221 22-May-2016 12:22
One person supports this post
Send private message

Not sure why people are saying Android won't do this, I have 3 android phones in my house and they all roam between my FritzBox, ASUS router and Airport fine. Verified with wifi analyzer.


21463 posts

Uber Geek
+1 received by user: 4362

Trusted
Subscriber

  Reply # 1557226 22-May-2016 12:33
Send private message

My note 4 will hang onto the outdoor AP pointing at where I park with a -85dB useless signal inside instead of roaming over to the nice strong AP right above my desk. Tried same SSID (which I dont really want since the outdoor one is 2.4GHz only) and that did not help. Wont roam till it totally loses it, since its a powerful AP then it is visible to the phone when the phone is not visible particually well to the AP.

 

Wifi is just a horrid thing without roaming that works.





Richard rich.ms

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.