Geekzone: technology news, blogs, forums
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.

26 posts


Topic # 198638 17-Jul-2016 14:06

Hi folks,


I help out my brother-in-law with his small business network needs as I am able - but have come up against something I can't diagnose. Would be very grateful if fellow geeks could provide suggestions.


Set up:


Windows 2008 domain - DHCP and DNS on the server.


3 computers - all DCHP clients


1 Sharp networked printer (MX-2319U) - fixed IP (, DNS pointing at server


Internet access is via Linksys WAG220G. This unit configured purely as modem - is forwarding to downstream router as DMZ.


Router WAS old SnapGear VPN server - but was becoming increasingly temperamental and replacement has been purchased.


Router IS new Draytek Vigor 2912. I have tried to configure this device so that it can simply be slotted in as a direct replacement for the SnapGear.


With the Draytek in place, all network functionality appears to work as expected - bar one thing. The printer is configured for 'scan to email' and this is broken. From the (web) configuration of the printer, when I run an SMTP connectivity test, I receive a 3332 Error (Connection to SMTP server test failed).


Tests performed:


From the server (DC), and from a workstation, I can ping and tracert to without issue.


Swap back in the older SnapGear unit and scan-to-email works without issue.


Thought perhaps new router settings upsetting printer's DNS 'view' - so have used as SMTP server setting in printer config. But still receiving 3332 error.


I thought that I wouldn't have to specifically open any outbound ports on the Draytek to allow the port 587 traffic out - but tried this to no avail.


Screenshot of printer config screen is here.





Would be very grateful for any ideas/suggestions on what I might be able to try to get this working.


Thanks in advance.

Filter this topic showing only the reply marked as answer Create new topic
3685 posts

Uber Geek
+1 received by user: 1392


  Reply # 1593952 17-Jul-2016 14:43
Send private message

So my first thought is have you tested the gmail with a normal mail client to see if they actually work? Gmail seem to change things all the time and especially when stuff like two-factor authentication is enabled on the gmail account things can get really screwed up.


Personally I avoid gmail at all costs for random mail clients and prefer a "normal" SMTP service - smtp2go is really great and much simpler to set up as it listens on a number of ports as well as doing SSL/TLS. You can even simply whitelist your public IP and it will let you use it as a open relay.


My other thought is you have a Windows server which presumably has some file shares configure on it - a much better option for scanning is to scan to a network drive, especially when the scans are a bit bigger.




Internet access is via Linksys WAG220G. This unit configured purely as modem - is forwarding to downstream router as DMZ.


would indicate to me that the Linksys is in fact still NAT'ing traffic as simply sending all traffic to a DMZ means it will still have to NAT those packets. Yes it will stop any firewall in place from blocking inbound traffic, but it most certainly won't be a "modem". On the linksys' they called it "half-bridge", im not certain the wag200 had half bridge though - the old am300 did though and was quite commonly seen as just a "modem". This won't be the reason your mail set up isn't working but just thought it would be worth pointing out.

26 posts


  Reply # 1593995 17-Jul-2016 15:32

Thanks chevrolux!


I have tested 'ordinary', web-based gmail connectivity and that is working fine.


Have signed up to smtp2go's free plan to test - but unfortunately the error 3332 persists using these new settings/credentials. Tried configuring the printer settings across all of their suggested SSL ports (465, 8465, 443).


Also tried disabling the "Enable SSL" option in the printer settings and specifying port 2525 as per the smtp2go instructions - but still no change in error condition.


Scanning to drive could be an option which could be investigated. I guess I had hoped to just implement a hardware change (router/firewall 'swap') and have the users just continue to work they way they always have.




And thanks for setting me straight on the terminology (modem, bridging etc). Guess shows that I'm certainly a networking novice. Know just enough to be dangerous.




Thanks again for your help - I'll keep throwing things at it.








21620 posts

Uber Geek
+1 received by user: 4432


  Reply # 1594052 17-Jul-2016 16:55
Send private message

Can the printer get other internet connectivity ok? Sometimes the IP stacks on those things are not the best. I have had embedded devices not do any arp aging so if you changed the router over it might still be trying for the mac address of the old router and failing. I would have expected that a power cycle would have cleared the arp table out so probably not the issue, but really you need to get something on there that you can dump the traffic and see if the printer is even trying to get to google or just doing nothing and then throwing up that error.


26 posts


  Reply # 1594194 17-Jul-2016 21:23

Thanks Richms - you put me on the right track fix.


But definitely was one of these moments:



Probably fixed the actual problem early on - and no doubt it was probably a simply mistake too....


But the main issue was me tinkering with the printer settings and I set (or reset in this case) the default gateway to the wrong IP address while troubleshooting. Then spent time chasing my tail looking elsewhere for the problem.


Such a rookie mistake and kicking myself for wasting not only a bunch of my time also your valuable time too. Still I very much appreciate your input because it did cause me to get back to basics.


Thanks to you both.

1934 posts

Uber Geek
+1 received by user: 383


  Reply # 1594496 18-Jul-2016 14:13
One person supports this post
Send private message

Don't worry, their bills are in the (e)mail!!


But, yes, who hasn't been in a similarly embarrassing position?

Filter this topic showing only the reply marked as answer Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:

Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:

Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:

Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.

Geekzone Live »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron

Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.