Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




30 posts

Geek
+1 received by user: 7


Topic # 220361 7-Aug-2017 21:37
Send private message quote this post

Hi all,

 

My in-laws recently changed over to Orcon's 100/20 fibre.
They weren't really impressed with the WiFi speeds, so I had a look.

 

A couple of weeks ago, I ran speed tests using WiFi on the Netcomm NF4V (stock Orcon modem) using a phone and laptop in the same room as the modem, which returned very varied results.
Downloads were anywhere from 1-40mbps down and uploads ranged from 1-20mbps.
Just to check it wasn't the connection, I hooked up a ethernet cable to the modem and ran a few other tests, resulting in fairly consistent speeds around 100/20.

 

I have the same plan, with the same modem. A few years ago I added a Netgear R7000 via ethernet to my modem and greatly improved the WiFi.
Thinking my in-laws' WiFi issue was similar, I bought them a Netgear R8000 and connected it to the modem via ethernet.
With the new router I get fairly good download speeds (60-90mbps) down, but only 1-3mbps upload! Weird!

 

I enabled the WiFi on the Netcomm NF4V and performed a few more tests resulting speeds around 40 down/20 up (the upload on the Netcomm seemed more stable).
Reconnecting the R8000, I connected to the 2.4G, and both 5G WiFi bands and couldn't get upload speeds past 10mbps.
I thought it might be the room, so I took my 10m ethernet cable and tried moving the R8000 to the living room.

 

To eliminate variables, I brought the R8000 home, replacing my R8000 and consistently get over 90mbps down and around 20mbps up with wireless and wired.

 

I have run out of ideas, and I can't pinpoint the issue from my tests.
The Netcomm NF4V seems to have good upload now, but delivers less than half the download bandwidth, whereas the Netgear R8000 delivers good download speed but unusually low upload speed.

 

Anyone else experienced this before?
Any ideas would be much appreciated, thanks!
 


Filter this topic showing only the reply marked as answer Create new topic
20262 posts

Uber Geek
+1 received by user: 3822

Trusted
Subscriber

  Reply # 1840821 7-Aug-2017 21:50
One person supports this post
Send private message quote this post

Often can be high noise where the computer is so it will hold off its tranmissions, while the router is in a lower noise area so less effected. My 2.4GHz upload drops to almost nothing on the phone when I am outside even tho perfect line of sight to the AP and great signal.





Richard rich.ms

519 posts

Ultimate Geek
+1 received by user: 16


  Reply # 1840823 7-Aug-2017 21:52
One person supports this post
Send private message quote this post

Seems like an issue of some serious channel interference to me.  Are you able to download and run this app and check. https://play.google.com/store/apps/details?id=com.pzolee.wifiinfo&hl=en

 

Have you tried changing channels though it shouldn't affect 5GHz, very strange that even on 5GHz you are having similar issue.


 
 
 
 




30 posts

Geek
+1 received by user: 7


  Reply # 1840837 7-Aug-2017 22:26
Send private message quote this post

Thanks for your prompt replies!

 

@richms, they have a cordless phone near the router which I thought could be causing interference on the 2.4G band. But the 5G band suffers the same issue. I tried moving the router out to the lounge away from the cordless phone and tested it while standing right next to the router. Didn't seem to make a difference.

 

@quebec, I thought that could be a channel conflict too and used  the inSSIDer app (which looks similar to the one you suggested), while 2.4G was pretty congested across the board, they were on channel 1, which had the least conflicts (1 other). I checked the 5G and theirs was the only 5G registering. The signals looked pretty strong on the graph, but I wonder if there is some other radio waves than other WiFi signals causing the interference?

 

I'm a bit out of my depth in this area, but maybe I could run some sort of test to check lost packets? Although not sure how I'd distinguish whether the errors are caused by the WiFi and not general packets loss.

 

I also forgot to mention that when I switched to the long cable it didn't seem to make a difference, so I don't think it is the cable.


1911 posts

Uber Geek
+1 received by user: 604

Subscriber

  Reply # 1840861 8-Aug-2017 02:23
One person supports this post
Send private message quote this post

Get a purpose designed AP such as the Xclaim Xi3. I have 2 of them because overkill. I got them mainly because I wanted really good range. But the Xclaim's also have good speeds as well.

 

Even when I was using the Fritzbox inbuilt Wifi, I was getting approx 20/30mbit. (older fritzbox that only supported N Wifi) Which was plenty for devices like phones. As for laptops, there was always Ethernet if you needed to do large downloads or backups.

 

 

 

Try switching the 2.4 band to channel 13. Not all devices support it, but if it works I found that I got better speeds using it. But in reality, you are unlikely to ever get 100mbit over N wifi in an urban area. (The claimed 300mbit speed is a Layer 1 speed, While speedtests measure layer 3 speeds).

 

Also there are firmware bugs in Netcomm routers that mean they don't work too well if you try to use them with separate Wifi APs. Unless you disable the Netcomm inbuilt Wifi.






872 posts

Ultimate Geek
+1 received by user: 265

Trusted

  Reply # 1840867 8-Aug-2017 07:12
Send private message quote this post

Yeh get a HQ AP.

 

What I think you would have found is they may have had lets say 4-5+ devices, maybe more connected to that AP. When you replaced it with a different AP, you probably only hooked up one or two devices then ran the test.

 

Every Device, neighbours or otherwise COMPOUNDS the problems with wi-fi.

 

Read this article.

 

https://arstechnica.com/information-technology/2017/03/802-eleventy-what-a-deep-dive-into-why-wi-fi-kind-of-sucks/

 

 








30 posts

Geek
+1 received by user: 7


  Reply # 1841071 8-Aug-2017 13:02
Send private message quote this post

Thanks for your suggestion @Aredwood.
At this stage I'm a little apprehensive about throwing more money at the issue until I can be sure of the cause, I don't end up with multiple APs without resolving the issue.
But I will see if I can switch the router to channel 13.

 

@darylblake, yeah... having so many WiFi devices in the area does make things difficult.
Although, I can't say I've ever run into a problem quite like this before.
You'd think if it was an issue with interfering WiFi signals, switching to 5G which with the inSSider app seemed free, would have showed better speeds.

 

The other weird thing I don't understand is why does it seem to only affect the upload speed and not the download?

 

 


25 posts

Geek
+1 received by user: 3


  Reply # 1841329 8-Aug-2017 17:45
Send private message quote this post

agent86:

 

Thanks for your suggestion @Aredwood.
At this stage I'm a little apprehensive about throwing more money at the issue until I can be sure of the cause, I don't end up with multiple APs without resolving the issue.
But I will see if I can switch the router to channel 13.

 

 

given performance is SO bad even on the 5ghz band I'm suspicious it's a router issue rather than a noise issue - from what you describe it sounds like you've got still got the orcon provided netcomm as the router and you've got the r8000 hung off it - have you set the r8000 to bridge/access point mode - if you haven't you've got a classic double nat setup (which shouldn't normally kill performance that badly but you never know).

 

also make sure any QOS on the r8000 is off

 

ideally you should get rid of the netcomm totally and let the r8000 do all the routing as well as wifi, it's a much more capable device and is fully compatible with ufb (does the required vlan tagging)

 

 




30 posts

Geek
+1 received by user: 7


  Reply # 1841946 9-Aug-2017 16:17
Send private message quote this post

I think you're right @bignose. If it were a noise issue, then it would probably affect both the download and upload.
I did have the R8000 set in access point mode and switched off the NF4V's WiFi.
Unfortunately, I don't think I can get rid of the NF4V completely because they have a landline bundle and their phone is attached.
But that is a good idea, I should try it without the NF4V and see if it is the Orcon modem causing it.
Although connecting the laptop wired directly to the NF4V didn't show any download or upload issues, but still worth a try.

 

Cheers!


6693 posts

Uber Geek
+1 received by user: 3065

Moderator
Trusted
Subscriber

  Reply # 1842963 9-Aug-2017 17:16
Send private message quote this post

Something to consider is potentially grabbing an Enterprise grade access point like an Ubiquiti UniFi AC-Lite - these access points are designed for noisy environments and are a better fit than having yet another router attached. I believe it was mentioned above too. From there you could also use my UniFi controller to ensure things are in check.




Michael Murphy | https://murfy.nz
Want to be with an epic ISP? Want $20 to join them too? Well, use this link to sign up to BigPipe!
The Router GuideCommunity UniFi Cloud Controller | Ubiquiti Edgerouter Tutorial




30 posts

Geek
+1 received by user: 7


  Reply # 1848465 18-Aug-2017 11:18
Send private message quote this post

So I finally had time to try this again, this issues seems to be resolved.

 

I reset the router back to factory settings and tried a different Gbe cable.
I'm not sure which did the trick, but both upload and download speeds are as they should be.

 

2.4G (around 60/20) and 5G (around 100/20).
Big thanks to @bignose for his help.


Filter this topic showing only the reply marked as answer Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Vodafone TV — television in the cloud
Posted 17-Oct-2017 19:29


Nokia 8 review: Classy midrange pure Android phone
Posted 16-Oct-2017 07:27


Why carriers might want to embrace Commerce Commission study, MVNOs
Posted 13-Oct-2017 09:42


Fitbit launches Ionic, its health and fitness smartwatch
Posted 12-Oct-2017 15:52


Xero launches machine learning automation to improve coding accuracy for small businesses
Posted 12-Oct-2017 15:45


Bank of New Zealand uses Intel AI to detect financial crime
Posted 12-Oct-2017 15:39


Sony launches Xperia XZ1, a smartphone with real-time 3D capture
Posted 11-Oct-2017 10:26


Notes on Nokia’s phone comeback
Posted 10-Oct-2017 10:06


Air New Zealand begins Inflight Wi-Fi rollout
Posted 9-Oct-2017 20:16


The latest mobile phones in perspective
Posted 9-Oct-2017 18:34


Review: Acronis True Image 2018 — serious backup
Posted 8-Oct-2017 11:22


Lenovo launches ThinkPad Anniversary Edition 25
Posted 7-Oct-2017 23:16


Less fone, more tech as Vodafone gets brand make-over
Posted 6-Oct-2017 08:16


API Talent Achieves AWS MSP Partner Status
Posted 5-Oct-2017 21:20


Stellar Consulting Group now a Domo Partner
Posted 5-Oct-2017 21:03



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.