Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




43 posts

Geek
+1 received by user: 9


Topic # 223683 12-Oct-2017 15:01
Send private message quote this post

At my new house have the option of ADSL2+ (10-12mbit) and Skinny Fixed Wireless (Likely 30-50mbit with external antenna)

 

 

 

If i were to get ADSL2+ and the fixed wireless, is it possible to link these two connections together and then prioritize traffic over a particular connection based on packets?

 

 

 

For example

 

ADSL2+ Connection

 

Youtube traffic

 

Steam Downloads

 

Game traffic (low ping)

 

 

 

Fixed Wireless

 

All other web traffic

 

All other downloads/uploads

 

 

 

This would allow most things to happen without speed being noticed (Except for steam downloads).

 

 

 

What could I put in place to do this? 

 

 

 

 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
'That VDSL Cat'
6773 posts

Uber Geek
+1 received by user: 1284

Trusted
Spark
Subscriber

  Reply # 1882500 12-Oct-2017 15:36
2 people support this post
Send private message quote this post

Yes this is possible.

 

 

 

few platforms out there, each with their pros and cons.

 

Realistically, you need to have a fair understanding of TCP/IP to correctly identify and tag the packets.

 

 

 

I'd go down the Edgerouter route to terminate connections where possible. Alternative would be a x86 based platform (pfsense, sonicwall etc)

 

 

 

My current setup is a VDSL and ADSL link, with occasional 3G extra support.

 

i route selected data out certain interfaces (with fallback on congestion/no data where wanted).

 

 

 

All other traffic is balanced between interfaces, netting me close on double bandwidth. (when using multiple TCP sessions spread across the interfaces)

 

 

 

 

 

 

 

 





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


180 posts

Master Geek
+1 received by user: 23


  Reply # 1882531 12-Oct-2017 16:02
Send private message quote this post

hio77:

 

I'd go down the Edgerouter route to terminate connections where possible. Alternative would be a x86 based platform (pfsense, sonicwall etc)

 

 

 

 

SonicWall is not x86 based - it uses Cavium Octeon Processors.


 
 
 
 


'That VDSL Cat'
6773 posts

Uber Geek
+1 received by user: 1284

Trusted
Spark
Subscriber

  Reply # 1882536 12-Oct-2017 16:16
Send private message quote this post

vulcannz:

 

hio77:

 

I'd go down the Edgerouter route to terminate connections where possible. Alternative would be a x86 based platform (pfsense, sonicwall etc)

 

 

 

 

SonicWall is not x86 based - it uses Cavium Octeon Processors.

 

 

Sorry was thinking of smoothwall, they both begin with S.....





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


1457 posts

Uber Geek
+1 received by user: 353


  Reply # 1882544 12-Oct-2017 16:28
Send private message quote this post

Any router that allows you to set the gateway address based on destination address. This is dead simple on a mikrotik.

180 posts

Master Geek
+1 received by user: 23


  Reply # 1882570 12-Oct-2017 17:51
Send private message quote this post

Shrapz:

 

At my new house have the option of ADSL2+ (10-12mbit) and Skinny Fixed Wireless (Likely 30-50mbit with external antenna)

 

 

 

If i were to get ADSL2+ and the fixed wireless, is it possible to link these two connections together and then prioritize traffic over a particular connection based on packets?

 

 

 

For example

 

ADSL2+ Connection

 

Youtube traffic

 

Steam Downloads

 

Game traffic (low ping)

 

 

 

Fixed Wireless

 

All other web traffic

 

All other downloads/uploads

 

 

 

This would allow most things to happen without speed being noticed (Except for steam downloads).

 

 

 

What could I put in place to do this? 

 

 

 

 

 

 

The problem is you need application based routing, the only box I know does this is the Palo Alto Networks gear. And even then it will be troublesome, you'd also need to decrypt SSL traffic.

 

 

 

 


'That VDSL Cat'
6773 posts

Uber Geek
+1 received by user: 1284

Trusted
Spark
Subscriber

  Reply # 1882573 12-Oct-2017 18:02
Send private message quote this post

vulcannz:

 

The problem is you need application based routing, the only box I know does this is the Palo Alto Networks gear. And even then it will be troublesome, you'd also need to decrypt SSL traffic.

 

 

 

 

The need to do DPI is absoutely the largest limiting factor.

 

 

 

you can rudimentaly do it via ports and IP's (where applicable) however.





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


180 posts

Master Geek
+1 received by user: 23


  Reply # 1882576 12-Oct-2017 18:31
One person supports this post
Send private message quote this post

Many applications use port 443 (web/steam/youtube etc). And IPs are irrelevant when CDNs are being used (steam/youtube especially).


1457 posts

Uber Geek
+1 received by user: 353


  Reply # 1882581 12-Oct-2017 18:37
Send private message quote this post

On a Mikrotik you can add a domain to an address list, then apply rules to that address list.  The router updates the rule with a dynamic entry:

 

 

 


'That VDSL Cat'
6773 posts

Uber Geek
+1 received by user: 1284

Trusted
Spark
Subscriber

  Reply # 1882585 12-Oct-2017 18:56
Send private message quote this post

MadEngineer:

 

On a Mikrotik you can add a domain to an address list, then apply rules to that address list.  The router updates the rule with a dynamic entry:

 

 

 

 

 

Interesting.

 

Does it do wildcard for all the video caches unique domains?





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.


1457 posts

Uber Geek
+1 received by user: 353


  Reply # 1882588 12-Oct-2017 19:09
Send private message quote this post

No, but in the case of www.youtube.com which has a CNAME of youtube-ui.l.google.com which then finally has an A record, a dynamic rule applied to www.youtube.com would apply to all of the above.

 

 

 

If you required wildcard filtering you could run a scheduled foreach in [/ip dns cache find] do={ find "videocache.com" ... script against the DNS cache and add the entries to an address-list, then run a single rule against that address-list

 

 

 

Mikrotik scripting is awesome :)


180 posts

Master Geek
+1 received by user: 23


  Reply # 1882592 12-Oct-2017 19:20
Send private message quote this post

DNS sniffing only goes so far. Plus you will add an overhead in processing...

 

 

 

Here's just 1 single PC doing some youtube today (about an hours worth), not even running SSL decrypt over the traffic:

 

 

 


1457 posts

Uber Geek
+1 received by user: 353


  Reply # 1882597 12-Oct-2017 19:30
Send private message quote this post

It's hard to tell from your image, but is that all youtube? What are the CNAMEs listed there? Looks like the dynamic address would cover that no problem and there's no overhead for it.  As for the script I've used similar before and it certainly didn't have any effect on performance.  Definitely nothing wrong using it as a solution to what's wanted here in a domestic situation.  For others you'd employ a dedicated appliance(/s)

 

 

 

Edit, actually it's been a while since I had to set up a youtube filter and you couldn't block one 'site' as listed earlier so yes on a Mikrotik a script against .googlevideo.com would be needed.

 

You could also connection-mark against a layer7 rule that included youtube's addresses with a suitable regexp.  The connection-mark process means the router isn't running every packet of data against a rule. (One should always run such a filter on *new* connections only, then mark the connections that apply, then finally mark the packets if needed)


1457 posts

Uber Geek
+1 received by user: 353


  Reply # 1898291 9-Nov-2017 13:08
Send private message quote this post

*bump*

 

Filter via layer7 but on dns queries only so your router isn't getting bogged down scanning other traffic:

 

 

 

/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube).*\$"
add name=videocache regexp="^.+(videocache).*\$"

 

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=youtube new-connection-mark=youtube_conn passthrough=yes

 

add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=videocache new-connection-mark=youtube_conn passthrough=yes

 

add action=mark-packet chain=prerouting connectionmark=youtube_conn new-packet-mark=youtube_packet

 

 

 

Then you can queue/filter/route those tagged as desired


13349 posts

Uber Geek
+1 received by user: 2247

Trusted
Subscriber

  Reply # 1898292 9-Nov-2017 13:12
Send private message quote this post

Before you get to a solution, exactly what problem are you trying to solve?





AWS Certified Solution Architect Professional, Sysop Administrator Associate, and Developer Associate
TOGAF certified enterprise architect
Professional photographer


701 posts

Ultimate Geek
+1 received by user: 97

Trusted

  Reply # 1898313 9-Nov-2017 13:59
Send private message quote this post

timmmay:

 

Before you get to a solution, exactly what problem are you trying to solve?

 

 

My take is that they want the ADSL for larger transfers & low latency but the fixed wireless for high speed.





 


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39


UAV Traffic Management Trial launching today in New Zealand
Posted 12-Dec-2017 16:06


UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23


New Fujifilm macro lens lands in New Zealand
Posted 5-Dec-2017 20:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.