Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


868 posts

Ultimate Geek
+1 received by user: 30


Topic # 240083 19-Aug-2018 21:51
Send private message quote this post

Ok, so I have my new grandstream router up and working, but I'm having a problem with my PLEX server. I think it is to do with DNS rebinding as per here, as I can no longer direct connect to it securely. I had the same issue with the fritzbox but it was easily fixed by adding plex.direct to a box and it fixed it. From what I can find the way to change it on the gwn7000 is to go here

 

Click to see full size

 

and add a line to the DHCP options - rebind-domain-ok=/plex.direct/

 

but that just breaks the internet. 

 

Anybody got any suggestions here? I don't even know what DNS rebinding is, so I'm  a little out of my depth.


Create new topic


868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 2081972 31-Aug-2018 16:42
Send private message quote this post

Anybody have any ideas about this? Anyone using Plex and the grandstream gwn7000 router?

 

The plex support page has info about using DNSMASQ, near the bottom of the page - https://support.plex.tv/articles/206225077-how-to-use-secure-server-connections/

 

I can't figure this one out. 


Meow
8004 posts

Uber Geek
+1 received by user: 4003

Moderator
Trusted
Lifetime subscriber

  Reply # 2081973 31-Aug-2018 16:48
Send private message quote this post

Plex should direct connect where possible without any configuration on your router.

 

I have not got plex.direct or any special rules set up on my network and yet my parents actually access the Plex server via their site-to-site VPN.

 

Unless if you're meaning the router is blocking DNS Rebinding Attacks as part of its firewall?







868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 2082092 31-Aug-2018 22:04
Send private message quote this post

Yes I believe that is what's happening. I had to do a similar thing on the fritzbox when I was using that, for plex to be able to direct connect.


dan

966 posts

Ultimate Geek
+1 received by user: 88


  Reply # 2082185 1-Sep-2018 07:51
Send private message quote this post

if your router has DNS rebinding protection, then no plex will not work 100% correctly, some clients will be connecting via the plex wan interface or even possibly the relay instead of lan,

 

that is not good.

 

 

 

 what is the actual plex problems your having tho

 

 


dan

966 posts

Ultimate Geek
+1 received by user: 88


  Reply # 2082187 1-Sep-2018 07:57
Send private message quote this post

a quick google search seems to indiate you are able to turn this off.

 

 

 

Aug 22, 2018 - GRANDSTREAM NETWORKS. GWN7000 ... If your GWN7000 has firmware version lower than 1.0.2.62 (1.0.2.62 not included), please refer to the beta forum ..... Added option to enable/disable DNS Rebind Attack Protection.




868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 2082737 2-Sep-2018 13:05
Send private message quote this post

I seem to be running on the most recent firmware - 1.0.4.23 but I can see no such option to disable DNS rebind anywhere. My problem is that plex won't direct connect (I think to any device), and I seem to be getting a lot of buffering via the xbox one which I wasn't getting before. I think what I'm looking for is to be able to add this "rebind-domain-ok=/plex.direct/" to DNSMASQ field in the router and have eveything work, but it just seems to disable the internet entirely (i have no idea what's technically doing). Alternatively yes I guess turning off the DNS rebind function would also work, but I can't find a way to do that either. 


dan

966 posts

Ultimate Geek
+1 received by user: 88


  Reply # 2082755 2-Sep-2018 14:04
Send private message quote this post

a quick google search shows that setting should be here to disable it

 

 

 

System Settings→Maintenance→Basic→Rebind Protection.




868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 2082873 2-Sep-2018 19:39
Send private message quote this post

They have obviously changed this in subsequent firmware as it no longer appears to be an option. Here's what I see.

 

Click to see full size

 

I haven't yet found the option anywhere else in the settings.

 

I'm puzzled why "rebind-domain-ok=/plex.direct/" in the DNSMASQ box doesn't work though. I don't think I'm doing it wrong.


dan

966 posts

Ultimate Geek
+1 received by user: 88


  Reply # 2082902 2-Sep-2018 21:19
Send private message quote this post

its looks like they have only added the option to disable it in the beta firmware for the next release

 

this one here

 

http://www.grandstream.com/support/firmware/gwn7000-beta-test-firmware

 

 

 

 




868 posts

Ultimate Geek
+1 received by user: 30


  Reply # 2082909 2-Sep-2018 21:40
Send private message quote this post

Ah ok. I'm not too keen to try out a beta, I guess I'll have to wait. 


Meow
8004 posts

Uber Geek
+1 received by user: 4003

Moderator
Trusted
Lifetime subscriber

  Reply # 2082917 2-Sep-2018 22:10
Send private message quote this post

CutCutCut:

 

Ah ok. I'm not too keen to try out a beta, I guess I'll have to wait. 

 

You can always go back if it isn't for you.





Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.