Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


18 posts

Geek


Topic # 25332 18-Aug-2008 20:55
Send private message

HI,

I just recently bought a usb tp-link wireless card to connect to my router. Before this, I connected to my router through a network cable and got broadband speeds of up to 5500 kb/s. With the wireless card I'm getting speeds up to 800 kb/s ! The signal strength is 100% though. Any ideas on how to troubleshoot this?

Create new topic
44 posts

Geek


  Reply # 157830 18-Aug-2008 21:31
Send private message

That sounds like something's very wrong.

54mb/s wireless should usually be able to outperform any ADSL connection no matter what's happening.  Even 802.11b at 11mb/s will be faster than your 5500kbps that you were getting.

Check your settings in the access point configuration - 800kbps sounds like your device is connecting to the AP at 1mbps instead of higher speeds.  This can be for several reasons;  (1)  the devices are negotiating the best quality link possible and the preferred connection/quality is picking up 1meg.  (2) you're getting tons of wifi/2.4ghz interference from around your environment.  (3) the connecting cable between your AP and your router is having ethernet issues.

If your AP and router are the same unit (eliminating 3 as a possibility), check & recheck your settings.  Download netstumbler (google for it) and run that on your PC/Laptop and it'll tell you how many other wifi access points it can see around you.

802.11b/g (Wifi) Channel's 1, 6 & 11 do not overlap and cause interferance between them - your access point is probably going to be set to channel 6 as a lot of AP's come with CH6 as default - if netstumbler shows lots of other wifi around you choose another channel as far away from the others as possible.

Lastly, power cables in the wall can & will affect your reception - try and keep your access point up as high as possible, and at least 1m away from any solid metal objects (filing cabinets etc) - don't have your AP under the desk sitting on a bundle of power and lan cables.

Good luck.

NZSM

75 posts

Master Geek


  Reply # 157901 19-Aug-2008 09:02
Send private message

Channel 13 is the best channel to use - although a lot of cheaper equipment does not let you use it.  USA regulations limit you to channels 1-11, however NZ follows the ETSI standards, permitting channels 1-13.  1, 7, 13 will actually give you the best seperation.  You do still get adjacent channel interference, you can just minimise it.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.