Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




1015 posts

Uber Geek

Trusted

#269854 11-Apr-2020 15:58
Send private message quote this post

Hey, I was wondering if I could get some help here.

 

I have a little bit of a more advanced network setup.

I have a edgerouter PoE connected to gig fibre.. I get great speeds > 900mbit, so no problems with the internet.

 

One of the ports powers a nanostation M5, and points to my sisters place next door, in her place i got a mikrotik as her router, so she gets just over 100meg internet for free (because i pay for it).

 

 

 

Anyway Port 1 on my PoE router plugs into a 16 port gig unmanaged switch (its a little bit old) but i got all my ethernet port jacks in the wall coming back to it and on any of these ports in the house if i plug a laptop or pc in and do a speed test I get a solid 900mbit which is fantastic. Wifi is 300mbit + so no wifi issues.

Here lies the problem. I only have 1 spare ethernet port in my office. And since I been working from home and have a few pc's I need multiple connections in there for the time being im using wifi but ideally I want to have a few devices in my office plugged in via ethernet. 

 

So i purchased a 5 port desktop (cheap and nasty) unmanaged switch from pbtech. On its own this switch is fine but if I hang it off a port on my 16port switch it does all sorts of funky stuff and drops out etc. 

 

So i tried creating another network and plugging into the switch directly. but that means the routers cpu has to process all the packets and the performance is a bit poo.

 

 

 

DO i need to replace this 16 port switch to get this setup working ideally? I dont think its the cheap 5 port office desktop switch i tend to think its the main one but I dont know why its a bit crappy..

 

 

 

Any advice?


Create new topic
4542 posts

Uber Geek

Trusted

  #2459432 11-Apr-2020 16:04
Send private message quote this post

Is it an auto-negotiation issue? Dodgy cable etc? Negotiating down to 10Mbps-half or soemthing?



1015 posts

Uber Geek

Trusted

  #2459433 11-Apr-2020 16:07
Send private message quote this post

I don't think so, its connecting at a full gig, the connection to the wall jack in the office is sound. 

 

Its just dropping connection and doing strange stuff when i daisy chain the two switches together and im pretty certain there is no loop.

 

 


 
 
 
 


7607 posts

Uber Geek

Trusted
Subscriber

  #2459446 11-Apr-2020 16:37
Send private message quote this post

Hi, so when you have the 5port plugged directly into the EdgeRouters port its all dandy? Which model Edge router is it, does it have a switch chip that is a real one or have you created a seperate network and the Edge router is routing between the 16port and 5 port lan segments.

 

Cyril




1015 posts

Uber Geek

Trusted

  #2459453 11-Apr-2020 16:51
Send private message quote this post

Its an edgerouter PoE.
If i plug it in it send the data over interface switch0. 

 

 

 

It runs ok.. the problem is its smashing the cpu.. for example if i start downloading in the office, i get about 150mbit max (i know its not the upstream provider) and the cpu on the edgerouter is at 100%.

 

 

 

 

 

eth0 is Internet uplink to ONT

 

eth0.10 is the internet virutal connection

 

eth1 is the uplink to my 16 port switch. 192.168.179.0/24

 

eth2 i have plugged the 5 port swtich into it. I made this network 192.168.2.0/24 (virtual interface is switch0)

 

eth3 - disconnected

 

eth4 PoE - Nanostation M5 -> M5. (no issues with this).

 

 


7607 posts

Uber Geek

Trusted
Subscriber

  #2459458 11-Apr-2020 17:02
Send private message quote this post

Hi to discount a cabling issue have you tried connecting the two switches side by side with a 2m patch lead?

Cyril

Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

National Institute for Health Innovation develops treatment app for gambling
Posted 6-Jul-2020 16:25


Nokia 2.3 to be available in New Zealand
Posted 6-Jul-2020 12:30


Menulog change colours as parent company merges with Dutch food delivery service
Posted 2-Jul-2020 07:53


Techweek2020 goes digital to make it easier for Kiwis to connect and learn
Posted 2-Jul-2020 07:48


Catalyst Cloud launches new Solutions Hub to support their kiwi Partners and Customers
Posted 2-Jul-2020 07:44


Microsoft to help New Zealand job seekers acquire new digital skills needed for the COVID-19 economy
Posted 2-Jul-2020 07:41


Hewlett Packard Enterprise introduces new HPE GreenLake cloud services
Posted 24-Jun-2020 08:07


New cloud data protection services from Hewlett Packard Enterprise
Posted 24-Jun-2020 07:58


Hewlett Packard Enterprise unveils HPE Ezmeral, new software portfolio and brand
Posted 24-Jun-2020 07:10


Apple reveals new developer technologies to foster the next generation of apps
Posted 23-Jun-2020 15:30


Poly introduces solutions for Microsoft Teams Rooms
Posted 23-Jun-2020 15:14


Lenovo launches new ThinkPad P Series mobile workstations
Posted 23-Jun-2020 09:17


Lenovo brings Linux certification to ThinkPad and ThinkStation Workstation portfolio
Posted 23-Jun-2020 08:56


Apple introduces new features for iPhone iOS14 and iPadOS 14
Posted 23-Jun-2020 08:28


Apple announces Mac transition to Apple silicon
Posted 23-Jun-2020 08:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.