Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


97 posts

Master Geek


Topic # 27134 15-Oct-2008 17:27
Send private message

Hey guys, I'm haing major trouble port forwarding behind two routers.

This is my current setup.

Internet -> Dynalink RTA1320 -> Linksys SPA2102 (for Xnet Fusion) -> 8 port switch -> Computers.

This is what I have configure so far. I have forwarded the port (65437) from the RTA1320 (192.168.1.1) to the SPA2102 (192.168.0.1).

I have created an internal static IP for my pc with the following settings. The internet lays a brick if I use "1" rather than "0" for IP or gateway.



From the Linksys SPA2102 I have forwarded the port to the pc (192.168.0.100) and yet I cannot get Utorrent to turn green. It's a problem with the SPA2102 because if I remove it from the network and forward directly from the RTA1320 to the PC it works fine.

Anyone know why I am having this issue?

Create new topic
2025 posts

Uber Geek
+1 received by user: 330

Lifetime subscriber

  Reply # 171334 15-Oct-2008 18:47
Send private message

The port forward rule from the RTA1320 should go to the SPA2102's WAN/Internet interface IP address. Your rule points at the SPA2102 LAN interface address, which is WRONG.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


Go Hawks!
877 posts

Ultimate Geek
+1 received by user: 49

Trusted
Subscriber

  Reply # 171385 15-Oct-2008 23:07
Send private message

You mention:

RTA1320 - LAN IP Address = 192.168.1.1 (I don't think this is right, I think you mean 192.168.0.1 here, based upon your screen grab below)

SPA2102 - LAN IP Address = 192.168.0.1

PC - LAN IP Address = 192.168.0.100

Of course, if you plug in your SPA into this configuration, you now have a duplicate IP on the network - ergo, your network won't be able to route out properly.

I think you may need to allocate a different IP address to the SPA, and modify your forwarding rules to that, and of course,  you will need this to come into your WAN port.




2025 posts

Uber Geek
+1 received by user: 330

Lifetime subscriber

  Reply # 171418 16-Oct-2008 08:42
Send private message

SPA2102 WAN interface is on RTA1320 LAN interface subnet, with RTA1320 as gateway, e.g., 192.168.1.50, 255.255.255.0, gw 192.168.1.1, and the DNS servers.




Ross

 

Spark FibreMAX using Mikrotik CCR1009-8G-1S-1S+

 


Speed Test


8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 171450 16-Oct-2008 10:32
Send private message

Use PPoA half bridge and UPnP imo

Example here:  http://www.ben.geek.nz/adsl-routing-solution-in-detail/

After that is all working you simply turn on UPnP in the SPA, turn on UPnP in utorrent.




97 posts

Master Geek


  Reply # 171602 16-Oct-2008 16:53
Send private message

OK I think I have done this right. I set it in half bridge mode as per the link and now I do not have the virtual server options in the RTA1320. Is that meant to happen? How can I turn on UPnP in the SPA2102?

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 171617 16-Oct-2008 18:21
Send private message

Yes that's supposed to happen the Dynalink is not doing NAT and just acting as a bridge to the SPA2102, so single NAT instead of double.

If the SPA2102 doesn't have a UPNP option just foward a single port (from the SPA2102) for utorrent to the pc running utorrent.



97 posts

Master Geek


  Reply # 171638 16-Oct-2008 19:46
Send private message

kk, I'll do this in the weekend. In the mean time, I remember I have a 4 port Dynalink RTA1335 and so I have this setup going.

Internet -> RTA1335 -> Switch -> PCs
                              -> SPA2102 (through second port)

I enabled UPnP in utorrent and now I have a green icon.

Go Hawks!
877 posts

Ultimate Geek
+1 received by user: 49

Trusted
Subscriber

  Reply # 171720 16-Oct-2008 23:02
Send private message

The other option I can see here is to turn off NAT into the SPA2102 (assuming this can be done, I've got an older DLink that refuses to not do NAT...) - then add a route into the RTA1320 for the 192.168.0.1/24, with the gateway as the IP address of the WAN port (192.168.1.50?)

You essentially subnet off your machines, which can be problematic if you're using Bonjour like services to advertise *across* the routers - but your initial diagrams didn't indicate that.

As to whether UPnP will work across that setup, I'm not entirely sure ...

HTH.

Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.