Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




566 posts

Ultimate Geek


#272745 13-Jul-2020 15:42
Send private message quote this post

I'm hoping that someone has some insight into a problem I'm having with connecting to Spark Fibre using a Linksys WRT1900ACS running OpenWRT.

 

 

As far as I can tell I'm tagging the WAN traffic properly but no matter what I try it seems to keep timing out during the PPPoE PADI Discovery step as per this log:

 

 

Sat May 16 19:39:00 2020 daemon.notice netifd: Interface 'wan' is now down

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.094493] IPv6: ADDRCONF(NETDEV_UP): eth1.10: link is not ready

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.155163] mvneta f1070000.ethernet eth1: Link is Down

 

Sat May 16 19:39:00 2020 daemon.notice netifd: Interface 'wan' is disabled

 

Sat May 16 19:39:00 2020 daemon.notice netifd: Interface 'wan' is enabled

 

Sat May 16 19:39:00 2020 daemon.notice netifd: Interface 'wan' is setting up now

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.166592] mvneta f1070000.ethernet eth1: configuring for fixed/rgmii-id link mode

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.174409] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.180349] mvneta f1070000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off

 

Sat May 16 19:39:00 2020 daemon.err insmod: module is already loaded - slhc

 

Sat May 16 19:39:00 2020 kern.info kernel: [ 4009.189421] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

 

Sat May 16 19:39:00 2020 daemon.err insmod: module is already loaded - ppp_generic

 

Sat May 16 19:39:00 2020 daemon.err insmod: module is already loaded - pppox

 

Sat May 16 19:39:00 2020 daemon.err insmod: module is already loaded - pppoe

 

Sat May 16 19:39:00 2020 daemon.info pppd[3791]: Plugin rp-pppoe.so loaded.

 

Sat May 16 19:39:00 2020 daemon.info pppd[3791]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7

 

Sat May 16 19:39:00 2020 daemon.notice pppd[3791]: pppd 2.4.7 started by root, uid 0

 

Sat May 16 19:39:01 2020 daemon.debug pppd[3791]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12

 

Sat May 16 19:39:01 2020 daemon.debug pppd[3791]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:0b:b9:0f

 

Sat May 16 19:39:01 2020 daemon.debug pppd[3791]: [service-name] [host-uniq cf 0e 00 00]

 

Sat May 16 19:39:06 2020 daemon.debug pppd[3791]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12

 

Sat May 16 19:39:06 2020 daemon.debug pppd[3791]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:0b:b9:0f

 

Sat May 16 19:39:06 2020 daemon.debug pppd[3791]: [service-name] [host-uniq cf 0e 00 00]

 

Sat May 16 19:39:11 2020 daemon.debug pppd[3791]: Send PPPOE Discovery V1T1 PADI session 0x0 length 12

 

Sat May 16 19:39:11 2020 daemon.debug pppd[3791]: dst ff:ff:ff:ff:ff:ff src 60:38:e0:0b:b9:0f

 

Sat May 16 19:39:11 2020 daemon.debug pppd[3791]: [service-name] [host-uniq cf 0e 00 00]

 

Sat May 16 19:39:16 2020 daemon.warn pppd[3791]: Timeout waiting for PADO packets

 

Sat May 16 19:39:16 2020 daemon.err pppd[3791]: Unable to complete PPPoE Discovery

 

Sat May 16 19:39:16 2020 daemon.info pppd[3791]: Exit.

 

 

 

This is the config I've tried (amongst others):

 

 

config interface 'wan'

 

option ifname 'eth1.10'

 

option proto 'pppoe'

 

option password 'password'

 

option ipv6 '0'

 

option username 'user@spark.co.nz'

 

option pppd_options 'debug'

 

 

config switch

 

option name 'switch0'

 

option reset '1'

 

option enable_vlan '1'

 

 

config switch_vlan

 

option device 'switch0'

 

option vlan '1'

 

option ports '0 1 2 3 5t'

 

 

config switch_vlan

 

option device 'switch0'

 

option vlan '10'

 

option ports '4t 6'

 

 

 

Stock firmware on the Linksys had no issues connecting and the Spark HG659b that I'm using as a backup is fine too.

 

 

To say I'm at a loss as to what I'm missing would be an understatement so any help would be most appreciated :)

Filter this topic showing only the reply marked as answer Create new topic
50 posts

Geek


  #2522240 13-Jul-2020 16:03
Send private message quote this post

You sure the VLAN port assignments are correct?

 

That config has:

 

  • Untagged VLAN 1 on ports 0, 1, 2, 3; tagged VLAN 1 on port 5
  • Untagged VLAN 10 on port 6; tagged VLAN 10 on port 4

 

 

Not an OpenWRT expert by any means but I would've expected untagged VLAN 1 on all ports, and tagged VLAN 10 only on whichever port is your WAN port

 

 

 

Any ideas which port numbers correspond to what physical ports on the unit? Weird that the config lists 7 ports (0 to 6) but the unit physically has only 5

 

 

 

Incorrect VLAN tagging would explain why the PADI message results in no PPPoE server advertisements coming back in

 

 




566 posts

Ultimate Geek


  #2522242 13-Jul-2020 16:11
Send private message quote this post

OzoneNZ:

You sure the VLAN port assignments are correct?

 

That config has:

 

  • Untagged VLAN 1 on ports 0, 1, 2, 3; tagged VLAN 1 on port 5
  • Untagged VLAN 10 on port 6; tagged VLAN 10 on port 4

 

 

 

I haven't touched VLAN 1 as when I tried to touch that it broke my ability to even connect to it on the LAN and I had to reset to factory settings :)

 

 

The port definitions are as per https://openwrt.org/toh/linksys/linksys_wrt1900acs#switch_ports_for_vlans so its tagging on the WAN port itself but not on the CPU port (I must admit I'm a little confused on how those two interact...)

 

 

For note I've also tried it with both of the ports tagged on VLAN 10 too but got the same thing.

 
 
 
 


'That VDSL Cat'
12453 posts

Uber Geek

Trusted
Spark
Subscriber

  #2522244 13-Jul-2020 16:12
Send private message quote this post

Can you DM me your account number, think i might know what this is..





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 


'That VDSL Cat'
12453 posts

Uber Geek

Trusted
Spark
Subscriber

  #2522323 13-Jul-2020 17:28
Send private message quote this post

Fixed, Switching cables quickly can make things cranky :)





#include <std_disclaimer>

 

Any comments made are personal opinion and do not reflect directly on the position my current or past employers may have.

 




566 posts

Ultimate Geek


  #2522324 13-Jul-2020 17:29
Send private message quote this post

Just to complete this thread, a huge thanks to hio77 who helped me solve the issue which wasn't exactly to do with the config but more to do with me trying too many different things in a short space of time which tripped some protection measures at Spark's end.

 

 

Lesson for the future : be more patient :D

568 posts

Ultimate Geek


  #2522524 14-Jul-2020 01:10
Send private message quote this post

The port definitions are as per https://openwrt.org/toh/linksys/linksys_wrt1900acs#switch_ports_for_vlans so its tagging on the WAN port itself but not on the CPU port (I must admit I'm a little confused on how those two interact...) For note I've also tried it with both of the ports tagged on VLAN 10 too but got the same thing.

 

To help with confusion about the CPU ports on the switch, I have a WRT1900AC.  The way it works is that the switch and CPU are distinct bits of hardware.  I am not sure if they are actually separate chips or combined in the same chip, but the CPU has two 1 gigabit Ethernet ports, eth0 and eth1.  Both of them physically connect to individual ports on the switch.  There is no direct connection from the CPU to the LAN or WAN ports on the outside of the router - the traffic all has to be sent via the switch.  The switch is a fully VLAN capable switch and works the same way as normal separate Ethernet switches do.

 

So what you really have is a two port router connected to a seven port switch, with two of the seven switch ports permanently connected to the router part's CPU eth ports and the other five ports connected to the sockets on the outside of the box.  How you connect them all together is entirely up to you and how you program the switch.  The names on the physical ports (WLAN, LAN x) are for your convenience, but actually meaningless - you can disregard them and use the ports however you like.  All the physical ports are equally capable identical switch ports.

 

So if you want the CPU eth0 port to be connected to the physical WAN port and nothing else, you would create a VLAN to do this, say VLAN 2.  The CPU eth0 port would be set to "untagged" on VLAN 2 and the WAN port would also be set to "untagged" on VLAN 2, with all other ports set to "off" on VLAN 2.

 

If you want to connect the CPU eth0 port to the WLAN port but have the traffic on WLAN tagged as VLAN 10, then you would create a VLAN 10, set CPU eth0 to "untagged" on VLAN 10 and WLAN to "tagged" on VLAN 10, with all other ports set to "off" on VLAN 10.

 

Typically, you would want the above setup for your WAN port and have the CPU eth1 port connected to the LAN ports via the switch.  That way the LAN and WAN sides both have a 1 gigabit CPU port, so they can both do full gigabit traffic.  But you could, if you had a good reason, run both the LAN and WAN traffic to the switch via the same CPU eth port, just using either two different VLAN numbers, or having say the WLAN traffic untagged on the CPU port and the LAN traffic tagged with a VLAN number.  That would leave you with a spare CPU eth port for whatever high bandwidth job you want it for.

 

In the CPU, the eth ports are full Linux Ethernet ports with the usual full set of capabilities, not all of which are able to be used by the OpenWRT GUI, or even at the UCI config file level.  I think it is possible to fiddle with the ports at the Linux level if you want to do really specialised things.  For some capabilities, you do need to load extra kernel modules, which are often available as opkg packages.


Filter this topic showing only the reply marked as answer Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.