Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


jm3

jm3

6 posts

Wannabe Geek


#277298 6-Oct-2020 20:19
Send private message quote this post

Hi,

 

I had a Edgerouter Lite die and I'm trying to configure a Mikrotik in it's place but I'm having trouble with the static IP block that was provided from the ISP.

 

I need to allow two of the public IP addresses to accept port 8000 based on an allowed list of IP's, each public IP routes to a different internal server. I've tried 1 to 1 NAT configurations but think I must be missing something subtle.

 

The connection is UFB PPPOE, no VLAN tagging and the static block is routed to our main IP.

 

Should I be explicitly adding the static IP info somewhere in the Mikrotik?

 

Any help appreciated.

 

 

 

Cheers

 

 

 

 

 

 


Create new topic
nztim
968 posts

Ultimate Geek

Subscriber

  #2580314 6-Oct-2020 20:35
Send private message quote this post

No need to add the (I am assuming) /30 to an interfaces if its routed to your PPPoE you can just pick this up with nat rules to/from your server

For the mikrotik make sure MAC server and discovery is disabled on your WAN interface and also ensure Winbox and DNS and other ports are firewalled on your WAN interface.

jm3

jm3

6 posts

Wannabe Geek


  #2580343 6-Oct-2020 21:29
Send private message quote this post

Thanks. I'll have another look at my rules again.
It's a 0.0.0.0/29 range but we currently only use two of them.

 
 
 
 


nztim
968 posts

Ultimate Geek

Subscriber

  #2580371 6-Oct-2020 22:19
Send private message quote this post

jm3: Thanks. I'll have another look at my rules again.
It's a 0.0.0.0/29 range but we currently only use two of them.

 

Here is an example for you

 

Assuming that:

 

* You want to port forward TCP 8000

 

* Your internal subnet is "192.168.5.0/24"

 

* Your PPPoE interface to your ISP is "pppoe-isp"

 

* Your internal server is 192.168.5.10

 

* Your first IP of your /29 is 202.0.0.1 

 

The following syntax will port forward tcp 8000 from 202.0.0.1 to 192.168.5.10

 

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.5.10 to-ports=8000  protocol=tcp src-address=0.0.0.0/0 dst-address=202.0.0.1  in-interface=pppoe-isp dst-port=8000

 

The following syntax will NAT all traffic to from 192.168.5.0/24 out to the internet using 202.0.0.1 instead of your PPPoE ip address

 

/ip firewall nat add chain=srcnat action=src-nat to-addresses=202.0.0.1 src-address=192.168.5.0/24 out-interface=pppoe-isp

 

 

 

I will also repeat my above message secure your Mikrotik WAN interface so it doesn't get hacked (as per previous post)

 

 


Create new topic





News »

Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS1621+ 
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13


Teletrac Navman launches integrated multi-camera solution for transport and logistics industry
Posted 8-Oct-2020 10:57


Farmside hits 10,000 RBI customers
Posted 7-Oct-2020 15:32


NordVPN starts deploying colocated servers
Posted 7-Oct-2020 09:00


Google introduces Nest Wifi routers in New Zealand
Posted 7-Oct-2020 05:00


Orcon to bundle Google Nest Wifi router with new accounts
Posted 7-Oct-2020 05:00


Epay and Centrapay partner to create digital gift cards
Posted 2-Oct-2020 17:34


Inseego launches 5G MiFi M2000 mobile hotspot
Posted 2-Oct-2020 14:53









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.