Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




21 posts

Geek
+1 received by user: 1


Topic # 49089 17-Nov-2009 19:32
Send private message

Hi
Currently i have an speedtouch st536v6 modem, and a wireless belkin f5d8236 router. For the life of me i cannot get my Xbox too work correctly with this setup (seems to be a double nat problem). After countless hours on the phone to telelcom and belkin and xbox forums, i am close too giving up.

Now here's the catch, if i plug the xbox DIRECTLY into the modem (bypassing the router) then it works very well. If i ditch the router and put a network switch in place, it works flawlessy also and i can get port forwarding too work well and also hook up all my pc's too it. So... my questions:

1. Will this work:
Phone Line to Modem -> Modem to Switch -> Switch to 2 wired pcs, the xbox, and also to the wireless router
And then my laptop and other wireless devices to that wireless router.

2. If so, what port does the modem plug into on the switch? And what port does the router plug into on the switch. Im ASSUMING that the modem would go into port 1 as normal, and then 2 3 & 4 would be the 3 wired devices.
Then use the uplink port for the router? Or just a standard port(port5?)?

Remembering that the st536 modem is also a router, and will accept multiple devices via a switch.

Thanks :)

Create new topic
6041 posts

Uber Geek
+1 received by user: 159

Trusted

  Reply # 274017 17-Nov-2009 19:50
Send private message

Hi you need to operate the Belkin as simply a layer 2 device, in other words connect it to the modem not via its WAN port but one of its LAN ports. Before you do this you must turn the DHCP server in the Belkin off, and ideally change the LAN admin address of the Belkin to an address within the address space of the modem but out of the way of the modems DHCP server such that you dont get address conflicts.

Hope this makes sense but if you can get the DHCP server of the Belkin off, change its address (can be messy) and connect them together via the LAN ports not WAN then you should be all good to go.

Cyril



21 posts

Geek
+1 received by user: 1


  Reply # 274605 19-Nov-2009 22:41
Send private message

I get what your saying but am still not 100%.
-Connect modem to port on belkin (1). NOT the wan/modem port.
-Turn of DHCP in belkin so that modem will handle that for the wired pcs/xbox.
-Set new address in router.

1. That would basically make the router operate as switch correct? By sharing the connection from ports 1 through to 2, 3 and 4 and not using the WAN/modem port.
2. I see this having a bad impact on wireless capabilites?
3. When you say change address of router, do you mean the current address i use to connect to it (192.168.2.1) or the address it is assigned from the modem (192.168.1.64)


 
 
 
 


8020 posts

Uber Geek
+1 received by user: 386

Trusted
Subscriber

  Reply # 274615 19-Nov-2009 23:54
Send private message

Yes routing, NAT, DHCP is handled by the Speedtouch and the Belkin is just acting as a switch and wireless access point.

Wireless will still work perfectly normally, just the Belkin won't be doing DHCP, NAT, Firewall you don't want to do that stuff twice because the Speedtouch is already doing it.

If your speedtouch is using 192.168.1.1 you should set the Belkin to use something like 192.168.1.2

Also change the DHCP range in the Speedtouch to start from 192.168.1.3 so it doesn't not try to give out .2 to any clients

Similar situation to this recent post:
http://www.geekzone.co.nz/forums.asp?forumid=49&topicid=49267





21 posts

Geek
+1 received by user: 1


  Reply # 274874 21-Nov-2009 00:31
Send private message

Thanks mate, will give this a go tomorow. Hopefully solves my problem. Fingers crossed....



21 posts

Geek
+1 received by user: 1


  Reply # 274972 21-Nov-2009 15:29
Send private message

Success! Thanks for all your help guys, works flawlessly now and wireless is up and running also. All pc's and xbox running static ip's and no more nat issues.

Heres what i did:
1. Go into router, turn off dhcp and set ip address to 192.168.1.253 (right at the end of the modem's range)
2. Unplug cable from modem port on router and put into port 1.
3. Set static ip on pcs (gateway of 192.168.1.254, the modems address) and ip's starting at about 10 higher than the lowest in the range. (lowest possible was 64, so i started my pcs at 74 too avoid any conflict.
4. Port forward ports from modem to required devices.
5. Reboot modem and router
6. PLAY XBOX LIVE!! And all my networking was still working flawlessly and could still browse between other pc's shared folders and music.

Thanks again guys! Huge help!

Create new topic



Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

New Zealand government to create digital advisory group
Posted 16-Dec-2017 08:47


Australia datum changes means whole country moving 1.8 metres north-east
Posted 16-Dec-2017 08:39


UAV Traffic Management Trial launching today in New Zealand
Posted 12-Dec-2017 16:06


UFB connections pass 460,000
Posted 11-Dec-2017 11:26


The Warehouse Group to adopt IBM Cloud to support digital transformation
Posted 11-Dec-2017 11:22


Dimension Data peeks into digital business 2018
Posted 11-Dec-2017 10:55


2018 Cyber Security Predictions
Posted 7-Dec-2017 14:55


Global Govtech Accelerator to drive public sector innovation in Wellington
Posted 7-Dec-2017 11:21


Stuff Pix media strategy a new direction
Posted 7-Dec-2017 09:37


Digital transformation is dead
Posted 7-Dec-2017 09:31


Fake news and cyber security
Posted 7-Dec-2017 09:27


Dimension Data New Zealand strengthens cybersecurity practice
Posted 5-Dec-2017 20:27


Epson NZ launches new Expression Premium Photo range
Posted 5-Dec-2017 20:26


Eventbrite and Twickets launch integration partnership in Australia and New Zealand
Posted 5-Dec-2017 20:23


New Fujifilm macro lens lands in New Zealand
Posted 5-Dec-2017 20:16



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.