Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


12 posts

Geek


Topic # 61094 8-May-2010 21:27
Send private message

Hi

 

After reading around and becoming more and more confused I've found myself here needing the same help as others.

 

Up until not long ago I was using utorrent without any issues and then I started getting the dredded red dot. After looking around I surmised my issue was due to my 'old' dlink 524 router, so I went out and purchased a linksys wrt54g router. After playing around with things today I now find myself here asking for help.

I have set-up in my pc a static address and I know my router works fine. I've set up to port forward on both the router and my modem but somewhere along the line all is not well.

I'm certain the issue is with my modem , the address I use to get to this is 10.1.1.1 (I'm with AAPT) , the address I use to get to my router is 192.168.1.1. By entering my modem settings I've gone advanced>virtual server and used LAN IP as 10.1.1.2 to open a port. My PC static IP is 192.168.1.50 and I've opened a port with the WRT54G using this address.


Can someone guide a lost , helpless fool?

 

spyware posted this in another thread but I haven't a clue what it means
The WAN interface on Linksys needs a static IP (on same subnet as 502T LAN interface). The LAN interface of the 502T connects to WAN interface of Linksys. Port forward rule on 502T points to this WAN interface IP address.

To summarise. Port forward rule on 502T points to WAN interface IP address on Linksys and port forward rule on Linksys points to PC IP address (running uTorrent). So both the PC and Linksys WAN interface need static addresses.

P.S. All above assumes that you have connected the 502T to WAN interface of the linksys, and hence your port forward rule in the Linksys, but maybe you connected the 502T to the Linksys LAN interface in which case you don't need any port forward rule in the Linksys as it is not doing any routing. Also the above port forward would have to be modified.


 

View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 328186 9-May-2010 15:23
Send private message

You have two routers in a double NAT setup, rather than having to port forward twice (once in each device) it's better to setup the devices in WAN Bypass mode or in bridged mode.

Given you're in Australia your ISP probably supports connecting via PPPoE which means you can use bridging:

http://forums.whirlpool.net.au/forum-replies.cfm?t=814956

Alternatively if you can only connect via PPPoA (like here in NZ for most ISP's) you should use a wan bypass setup

http://forums.whirlpool.net.au/forum-replies.cfm?t=933517



12 posts

Geek


  Reply # 328287 9-May-2010 21:03
Send private message

Thank you for some direction on the subject, Ragnor. I did find this too if it helps anyone.

http://whirlpool.net.au/wiki/?tag=adsl_modem_router_bridge_mode

I'm still scratching my head a bit but will give things a try.

1984 posts

Uber Geek
+1 received by user: 133

Trusted

  Reply # 328686 10-May-2010 20:02
Send private message

10.1.1.1 is not the internet address, its the local address of your modem (on your side of the LAN) as is your 10.1.1.2 address for your other ethernet router.

Why not try to bypass the WAN link on your linksys and plug the modem to it via a normal LAN port? If you do it you would need to turn off the DHCP (automatic IP addressing) on the linksys so that all addresses get allocated by the modem. That will create a single LAN (so only the modem doing NAT routing), and you can then forward the port directly to your computer's new 10.1.1.x address, since it becomes all one range of IP addresses.

Dont forget to turn off the DHCP or you will get other computers being allocated wrong IP addresses.

EDIT: This solution would also allow your computers to plug into both routers, whichever is convenient, being all on the same LAN. It might also need a crossover cable to connect both routers together if they dont detect that automatically.




Qualified in business, certified in fibre, stuck in copper, have to keep going  ^_^



12 posts

Geek


  Reply # 329190 12-May-2010 00:00
Send private message

Thanks for that webwat - I sort of get what you mean. I'm off work Thursday so will give it a try. Cheers.



12 posts

Geek


  Reply # 329733 13-May-2010 12:17
Send private message

Currently my PC connects via ethernet cable to the WRT54G and then I have a cable running from LAN 1 into the 502T.

The back of the modem/router D-link 502T has a usb plug and one ethernet plug
The back of the WRT54G has the ethernet plug and the four LAN plugs.

From what I'm reading in the guide for WAN bypass, I have to connect my PC to the 502T then connect to the WRT54G. 

PC>502T>WRT54G ?


From this guide (WAN bypass) http://forums.whirlpool.net.au/forum-replies.cfm?t=933517 Ragnor posted, it tells me to do it the way listed above - how do I it the other way around.

Sorry for sounding like a vague idiot. From this screen (not actually my settings) what do I select/deselect  


 

 

 



12 posts

Geek


  Reply # 329826 13-May-2010 15:24
Send private message

Update - I tried connecting my 502T directly to my PC so I could WAN bypassing and could not connect to the modem or the internet at all. I changed my settings via network connection to obtain an IP automatically. I have no idea why I couldn't even connect to the modem at all.

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 329873 13-May-2010 17:18
Send private message

Your PC should be able to plug into LAN ports on either device, either way it should get it's ip address from the 502T, the WRT54 just acts as a "dumb" extension of the network switch (plus wireless access point).

So it sounds odd that plugging into the 502T wouldn't give you an ip address and let you connect to it. Settings must be wrong in the 502T. You can always reset it to default via the pinhole button if need be and re-set it up.

I would definitely get the 502T going properly before you add the WRT back into the mix.

Make sure you're using Internet Explorer when accessing the Dlink, I heard they have problems saving settings when using other browsers.



12 posts

Geek


  Reply # 329895 13-May-2010 18:33
Send private message

Thanks for hanging in there with me :)

I did try the reset button in the back to no avail :(

I'll stick with trying to sort out the dlink first and go from there.



12 posts

Geek


  Reply # 330086 14-May-2010 12:59
Send private message

Had another go at connecting the 502T directly to the ethernet connection with the WRT out of the way and couldn't connect again. I've googled around and found others with similar issues without finding a result or without finding as to why this happens - I'm sure it's something simple but now I'm stuck.

Forget it guys, thanks for your help.

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 330157 14-May-2010 15:22
Send private message

Can you clarify what you mean..

Is the 502T connected to the internet and internet is working normally, just you can't access the routers admin ui from your pc?

Or you pc doesn't get an ip address from the 502T at all?

When your PC is connected to the 502T by ethernet cable, what does running ipconfig on your machine show?

eg: Start Menu > Run > cmd > ipconfig /all



12 posts

Geek


  Reply # 330206 14-May-2010 18:45
Send private message

When I 'direct' connect the 502T I get a 169.x.x.x IP address and the limited or no connectivity error message. The lights all show that I am connected but I can't even go to the 502T page 10.1.1.1

When I unplug the 502T and plug the WRT54G back in and as soon as I change the TCP/IP settings back to using 'use the following IP address' 192.168.1.50, subnet 255.255.255.0, default gateway 192.168.1.1
and prefferred DNS as 10.1.1.1 and 10.1.1.2 I can reconnect immediately.

I've tried shutting down the PC and rebooting without anything plugged in and selected obtain IP address automatically before I've shutdown and left the 502T off for at least 5 mins and pushed the reset button and still got nothing.

I have a broadcom netXtreme 57xx card Gigabit controller and the cables aren't cross over, btw.

ipconfig results -

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Ash>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : computer
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont
roller
Physical Address. . . . . . . . . : 00-11-43-9F-3D-69
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.23.181
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 10.1.1.1
10.1.1.2

C:\Documents and Settings\Ash>

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 330662 16-May-2010 17:04
Send private message

169.x is the default address windows uses when it can't get an address automatically from the device via dhcp.

I suspect you might have disabled DHCP in the 502T instead of the WRT54G when following the WAN bypass guide.

Plug in to the 502T and give your PC a manual ip address (for now) eg: 10.1.1.5, this should allow you to connect to the admin ui on the 502T on 10.1.1.1 and make changes.



12 posts

Geek


  Reply # 330714 16-May-2010 18:37
Send private message

Sorry Ragnor, I didn't even get to start on WAN bypass as I got stuck at the first hurdle. I have been trying to show a screen print of my 502T settings but I can assure you that DHCP is not disabled :(

8027 posts

Uber Geek
+1 received by user: 387

Trusted
Subscriber

  Reply # 330777 17-May-2010 02:00
Send private message

Is it a Generation II?



And which revision?



or




12 posts

Geek


  Reply # 331563 18-May-2010 20:14
Send private message

It's a generation 1 and revision A

BTW, thanks for hanging in here with helping me

 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic

Twitter »

Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.