My 2nd gen 4GB iPod nano, of which I haven't used for a while has stopped working - I've tried resetting, restoring, the whole lot - doesn't seem to make a different. You put a song (or a podcast) on it and you can play it, but nothing happens - it goes into the song and says it's playing but it isn't - there's not any sound and the seconds seem to lag - for instance I started the broken iPod and computer playing the same song at the same time and the computer was at 11 seconds by the time the iPod had made it to 3. I also tried switching the 'clicker' to headphones and suprisingly it didn't work. I also went into the diagnostics menu (through reset) and did multiple audio tests. Nothing happened and the iPod consequently froze. I have a feeling that it could be more than one problem, but both of them occuring at the same time is a bit strange.

I'm pretty sure the iPod's seen better days, but I thought I should ask around here before I go through the annoying formalities of a funeral and its cremation. xD