Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




4267 posts

Uber Geek
+1 received by user: 1466


# 210558 2-Apr-2017 08:40
One person supports this post
Send private message

I've been trying to use two factor auth for my apple devices and account. 

 

But, it doesn't work as apple say... eg, apple says  once you have authenticated a device it never asks you again. 

 

This is wrong, i always get asked for the stupid pin code no matter how many times i've entered it. 

 

And, there is no email authenticate option, so I'd be stuffed when overseas on a local sim card or when the phone is not nearby. 

 

It has been too much trouble for me, so I'll switch it off I think.   I like the idea of it, but in practice it is way too annoying and the implementation is poor. 


View this topic in a long page with up to 500 replies per page Create new topic
 1 | 2
6638 posts

Uber Geek
+1 received by user: 1325

Trusted
Lifetime subscriber

  # 1753032 2-Apr-2017 09:06
Send private message

I ended up switching it off after getting frustrated with being asked every single time. Also, what's the point of having a map of where the login happened if it's completely wrong? Apple thinks I'm in Auckland...


defiant
899 posts

Ultimate Geek
+1 received by user: 491

Lifetime subscriber

  # 1753033 2-Apr-2017 09:10
One person supports this post
Send private message

Are you still using two step verification which was via SMS or find my iphone? https://support.apple.com/en-nz/HT204152

 

There's two factor auth which uses trusted devices https://support.apple.com/en-nz/HT204915

 

I never get prompted again after allowing a device


 
 
 
 




4267 posts

Uber Geek
+1 received by user: 1466


  # 1753047 2-Apr-2017 09:18
Send private message

nas:

 

Are you still using two step verification which was via SMS or find my iphone? https://support.apple.com/en-nz/HT204152

 

There's two factor auth which uses trusted devices https://support.apple.com/en-nz/HT204915

 

I never get prompted again after allowing a device

 

 

On windows I always seem to be prompted. 

 

I think i am using trusted devices. 

 

 


defiant
899 posts

Ultimate Geek
+1 received by user: 491

Lifetime subscriber

  # 1753053 2-Apr-2017 09:33
Send private message

Ah ok, I don't use any apple/icloud services on my windows boxes


3183 posts

Uber Geek
+1 received by user: 1643


  # 1753236 2-Apr-2017 16:15
One person supports this post
Send private message

Just came up on our account today.  Had been previously turned off after similar experiences as the OP, but out of the blue we got an email saying that we had enabled it (ahhh nope!)

 

Logged in and turned it off again but the badge on the settings icon and the prompt at the top of the settings windows remains. I can't figure out how to turn the notification off.

 

Is Apple forcing 2FA now?  I note it's only on our iPhone's not on iPads (not yet anyway)

 

I don't want 2FA if everything we do on any device needs a damn code, which by the way only gets sent to 1 of our 7 authorised devices!    

 

 





Always be yourself, unless you can be Batman, then always be the Batman



3183 posts

Uber Geek
+1 received by user: 1643


  # 1753243 2-Apr-2017 16:37
Send private message

...and it's now just popped up on our iPad's.  Now on all devices that have 10.3

 

Thought I would try enabling it then turn it off again.  Can't even do that as I get an error saying the it can't get a response from the apple security servers (or something like that) so either they are overloaded with everyone joining up or there's a problem, which doesn't give me any faith the service has been implemented well at all.

 

 

 

Meanwhile have this horrible red "1" of the settings icon...grrrrr  OCD triggered.  

 

 

 

 

 

 





Always be yourself, unless you can be Batman, then always be the Batman



417 posts

Ultimate Geek
+1 received by user: 315


  # 1753251 2-Apr-2017 16:42
Send private message

I use it, my phone is my trusted device, never get prompts other than if I sign out, which I don't do.

It works as expected.




BlinkyBill

 
 
 
 


6638 posts

Uber Geek
+1 received by user: 1325

Trusted
Lifetime subscriber

  # 1753253 2-Apr-2017 16:44
Send private message

It definitely shouldn't turn itself on! I was invited to enable it when I installed 10.3 but I chose not to, and it's still off for my account.


3183 posts

Uber Geek
+1 received by user: 1643


  # 1753321 2-Apr-2017 18:24
Send private message

Turned off via on-line account login (again) and have managed after several attempts, to go through the settings on each device to enable it again (in the hope that I could disable it again and get rid of the notification), and it worked.  Although even accepting the option to turn on 2FA on each device it did, well, nothing.  The notifications have gone and 2FA still remains off (well that's what the website says anyway).

 

The latest shambles confirms my answer to the OP's question.  No I am not using it and until it works properly across multiple devices on a single account will remain that way.

 

 

 

  





Always be yourself, unless you can be Batman, then always be the Batman



14963 posts

Uber Geek
+1 received by user: 2046


  # 1753328 2-Apr-2017 18:28
One person supports this post
Send private message

I had all sorts of problems as it seems to have enabled itself after the IOS10.3 update. It needed me to authenticate my iphone and it said it had sent me a SMS. But the number it had sent it to was the device I was upgrading, and it wouldn't then let me read that message, as I couldn't get past that screen to fill it in.


14963 posts

Uber Geek
+1 received by user: 2046


  # 1753329 2-Apr-2017 18:30
Send private message

Behodar:

 

It definitely shouldn't turn itself on! I was invited to enable it when I installed 10.3 but I chose not to, and it's still off for my account.

 

 

 

 

I am not sure I was 'invited' to enable it, as I can't recall it asking me when I upgraded. Perhpas it did that trick where you need to select the small text link, rather than the big next button, if you don't want to enable it.


6638 posts

Uber Geek
+1 received by user: 1325

Trusted
Lifetime subscriber

  # 1753330 2-Apr-2017 18:32
Send private message

I'm pretty sure that that was indeed the case.


1908 posts

Uber Geek
+1 received by user: 460

Trusted
Subscriber

  # 1753332 2-Apr-2017 18:33
Send private message

I found it was round robining to the most previously updated device. It used to be you could send a TEXT to a nominated mobile, but Apple has depracated using SMS as a channel and just uses its onboard app connected to the internet.

 

not useful if you have more than 2 devices :-)





________

 

Antonios K

 

Click to see full size


2539 posts

Uber Geek
+1 received by user: 716


  # 1753345 2-Apr-2017 18:56
One person supports this post
Send private message

Yes, I stupidly ennabled it and am now being prompted ALL THE TIME 😡 even on my primary device (cellphone) and never seem to get the authentication request either.

Even more stupidly is the way they handle my multiple (regional) Apple ids... aka they no longer seem to let me switch regions for region-specific apps!

Totally peeved and am trying to turn it off on all the accounts and devices... 3 days later and still trying to get it to 'stick' off 😡

150 posts

Master Geek
+1 received by user: 80


  # 1753729 3-Apr-2017 13:07
Send private message

Aarrgghh!  that explains whats happening to me too.  Ok, going to try and turn it off, but not expecting much success yell


 1 | 2
View this topic in a long page with up to 500 replies per page Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Dunedin selects Telensa to deliver smart street lighting for 15,000 LEDs
Posted 18-Jul-2019 10:21


Sprint announces a connected wallet card with built-in IoT support
Posted 18-Jul-2019 08:36


Educational tool developed at Otago makes international launch
Posted 17-Jul-2019 21:57


Symantec introduces cloud access security solution
Posted 17-Jul-2019 21:48


New Zealand government unveils new digital service to make business easier
Posted 16-Jul-2019 17:35


Scientists unveil image of quantum entanglement
Posted 13-Jul-2019 06:00


Hackers to be challenged at University of Waikato
Posted 12-Jul-2019 21:34


OPPO Reno Z now available in New Zealand
Posted 12-Jul-2019 21:28


Sony introduces WF-1000XM3 wireless headphones with noise cancellation
Posted 8-Jul-2019 16:56


Xero announces new smarter tools, push into the North American market
Posted 19-Jun-2019 17:20


New report by Unisys shows New Zealanders want action by social platform companies and police to monitor social media sites
Posted 19-Jun-2019 17:09


ASB adds Google Pay option to contactless payments
Posted 19-Jun-2019 17:05


New Zealand PC Market declines on the back of high channel inventory, IDC reports
Posted 18-Jun-2019 17:35


Air New Zealand uses drones to inspect aircraft
Posted 17-Jun-2019 15:39


TCL Electronics launches its first-ever 8K TV
Posted 17-Jun-2019 15:18



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.