Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




Human
2982 posts

Uber Geek

Subscriber

#59857 13-Apr-2010 17:52
Send private message

I tried my XT SIM in my iphone then put my Vodafone one back in. "Telecom NZ" was stuck there, instead of having VodaNZ there.

So, I restored the iPhone (3gs) and installed the carrier bundle from iPhoneNewZealand.co.nz - still the same problem.


Has anyone worked out a solution for this? (Other than restoring the iPhone).

I realize its just a little thing, but it bugs the hell out of me, I don't really want to have to restore my iPhone each time I use my XT SIM.





Create new topic
178 posts

Master Geek


  #317961 13-Apr-2010 18:15
Send private message

One of my customers just had this happen to her today. I'm searching for a fix now. I'll let you know if I find one. I asked her to put her XT sim back in temporarily, go to network settings and change the carrier to Vodafone. It should display "no service". Put the Voda sim back in. I haven't heard a response back yet, so let me know if it works. I've sent a message to John asking if he knows anything about it.

2431 posts

Uber Geek

Trusted

  #317963 13-Apr-2010 18:21
Send private message

Try this...

http://bugreport.apple.com/


 
 
 
 




Human
2982 posts

Uber Geek

Subscriber

  #317965 13-Apr-2010 18:21
Send private message

LennonNZ: Try this...

http://bugreport.apple.com/



I'll take a look, but I think it would be unlikely Apple would do much since Telecom is actually an unsupported Carrier in the first place.





2431 posts

Uber Geek

Trusted

  #317969 13-Apr-2010 18:32
Send private message

Its a bug.. maybe its already been fixed in 4.0. I personally have reported about 20 3.1.3 bugs and 20 4.0 bugs and most of the 3.1.3 bugs have been fixed and the 4.0 bugs are being looked into.

Thanks

89 posts

Master Geek


  #317974 13-Apr-2010 18:45
Send private message

Try this:

To fix it, I would first suggest trying putting the XT sim back in, (while the phone is off) boot up, and see if you can manually change the network to Vodafone, if you can, let it connect to Vodafone, shut down the phone, swap the Vodafone sim back in and boot up and all should be good.

This is from the vodafone forum.



Human
2982 posts

Uber Geek

Subscriber

  #317980 13-Apr-2010 19:01
Send private message

firewire: Try this:

To fix it, I would first suggest trying putting the XT sim back in, (while the phone is off) boot up, and see if you can manually change the network to Vodafone, if you can, let it connect to Vodafone, shut down the phone, swap the Vodafone sim back in and boot up and all should be good.

This is from the vodafone forum.


Nope, doesn't work.





558 posts

Ultimate Geek

Subscriber

  #317985 13-Apr-2010 19:11
Send private message

Have You Tried Entering Airplane Mode for some reason this works for me

Geoff 




Geoff E


 
 
 
 




Human
2982 posts

Uber Geek

Subscriber

  #317987 13-Apr-2010 19:12
Send private message

geocom: Have You Tried Entering Airplane Mode for some reason this works for me

Geoff 


damnm I just finished restoring my iPhone.


I will try it again in a second and let you know..

I think I ahve tried it and it didn't work, but will do it again to confirm.





178 posts

Master Geek


  #318032 13-Apr-2010 20:29
Send private message

My customer tried inserting her XT sim, choosing Vodafone under settings, then reinserting the Voda sim. No luck. I've asked her to do a restore, as per John R's instructions.

2210 posts

Uber Geek

Trusted
Subscriber

  #318038 13-Apr-2010 20:41
Send private message

Nice haircut mate!



Human
2982 posts

Uber Geek

Subscriber

  #318046 13-Apr-2010 21:09
Send private message

corksta: Nice haircut mate!


Thanks :P

Raised almost $1,000 - about 4 times my original target. =D





232 posts

Master Geek


  #318049 13-Apr-2010 21:14
Send private message

i think you need to plug your iphone into the itunes application and do a reset i think it is to fix the issue



Human
2982 posts

Uber Geek

Subscriber

  #318051 13-Apr-2010 21:15
Send private message

guyz: i think you need to plug your iphone into the itunes application and do a reset i think it is to fix the issue


We're aware of that, but this shouldn't need to be the case.





2210 posts

Uber Geek

Trusted
Subscriber

  #318067 13-Apr-2010 21:26
Send private message

Aaroona:
corksta: Nice haircut mate!


Thanks :P

Raised almost $1,000 - about 4 times my original target. =D


Good stuff, that's awesome!!

I'll stop hijacking the thread now... 

178 posts

Master Geek


  #319466 16-Apr-2010 17:29
Send private message

Just an update. "Restore" in iTunes didn't work. We had to replace the customer's iPhone and send the phone away for repair/replacement.

Create new topic




News »

Freeview On Demand app launches on Sony Android TVs
Posted 6-Aug-2020 13:35


UFB hits more than one million connections
Posted 6-Aug-2020 09:42


D-Link A/NZ extends COVR Wi-Fi EasyMesh System series with new three-pack
Posted 4-Aug-2020 15:01


New Zealand software Rfider tracks coffee from Colombia all the way to New Zealand businesses
Posted 3-Aug-2020 10:35


Logitech G launches Pro X Wireless gaming headset
Posted 3-Aug-2020 10:21


Sony Alpha 7S III provides supreme imaging performance
Posted 3-Aug-2020 10:11


Sony introduces first CFexpress Type A memory card
Posted 3-Aug-2020 10:05


Marsello acquires Goody consolidating online and in-store marketing position
Posted 30-Jul-2020 16:26


Fonterra first major customer for Microsoft's New Zealand datacentre
Posted 30-Jul-2020 08:07


Everything we learnt at the IBM Cloud Forum 2020
Posted 29-Jul-2020 14:45


Dropbox launches native HelloSign workflow and data residency in Australia
Posted 29-Jul-2020 12:48


Spark launches 5G in Palmerston North
Posted 29-Jul-2020 09:50


Lenovo brings speed and smarter features to new 5G mobile gaming phone
Posted 28-Jul-2020 22:00


Withings raises $60 million to enable bridge between patients and healthcare
Posted 28-Jul-2020 21:51


QNAP integrates Catalyst Cloud Object Storage into Hybrid Backup solution
Posted 28-Jul-2020 21:40



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.