Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.


anandpatel18

54 posts

Master Geek


#63179 22-Jun-2010 10:08
Send private message

Hey,

Every time I add a contact and add their birthday the date of the birthday automatically moves by one day.

For example, I will select someones birthday as the 23rd of march and click done but the contact birthday shows 24th. Even if I select a random date say 1st June, it will say 2nd. 

When I go into the calendar app and display the birthday calendar the birthdays are right though, it will have a notification as a birthday on the 23rd.

I have done a fresh restore from a backup and as a new iphone, still I have the error.

I'm thinking that the contact list in iOS4 is set to a specific timezone different from my phones timezone as it adjusts it for a day. Since I live in New Zealand, my timezone settings are set to Auckland, New Zealand, even in the calendar time zone. When I change my timezone settings to somewhere in the USA it  automatically changes the contacts birthdays to the correct date. When I change it back it adjusts the birthdays by a day again. This would be correct as the 23rd in USA would be the 24th here but my contacts are not in a different timezone so why does my iphone think they are? Even if a add a new contact it still changes the birthday date.

Just wondering if anyone else has noticed this or had the same problem?

I do have a couple of email accounts sync to exchange but I have deselected syncing with these. Its a Iphone 3GS btw.

Any help would be great.

Create new topic
clicknz
426 posts

Ultimate Geek

Trusted

  #344087 22-Jun-2010 11:17
Send private message

Hi,
I'm sorry I can't give any insights on this behaviour, other than to say that it's been a fairly persistent bug in iOS's going back to the earliest days. I think you have identified the problem (a timezone issue), but as far as I know there isn't an elegant solution to this. But at least I know it's still present in iOS4....sigh.... 




Cheers,
Mike

Photographer/Videographer clickmedia.nz


anandpatel18

54 posts

Master Geek


  #344106 22-Jun-2010 11:52
Send private message
 
 
 
 


corksta
2218 posts

Uber Geek

Trusted
Subscriber

  #344143 22-Jun-2010 13:31
Send private message

Yes I've experienced this before, it's not a 4.0 issue.

I'm trying to remember how I fixed it though - all the birthdays I have entered are now correct.

Try a Google search in the meantime.




2018 iPad Pro 12.9 Wi-Fi 64GB (Space Grey) | 2018 iPad mini Wi-Fi 64GB (Space Grey) | iPhone 11 Pro Max 64GB (Midnight Green) | 2x HomePod (Space Grey) | 3x Apple TV 4K | Apple Watch Series 4 44mm (Space Grey)

 

Sony 65" A8F OLED TV | Sony 65" X850F LED TV | Sony 55" X900F LED TV


bcourtney
652 posts

Ultimate Geek

Trusted

  #344153 22-Jun-2010 13:54
Send private message

corksta: Yes I've experienced this before, it's not a 4.0 issue.

I'm trying to remember how I fixed it though - all the birthdays I have entered are now correct.

Try a Google search in the meantime.


It used to be an issue in one of the previous OS refreshes due to our daylight savings time changes that occurred. It was eventually fixed by a further OS update that occurred (but took a LONG time to get fixed).

Although I've not noticed this issue since upgrading to iOS4 so perhaps the OP has a different problem

raydenl
97 posts

Master Geek


  #344763 24-Jun-2010 09:15
Send private message

This appears to be a new problem with ios4, or maybe an existing problem highlighted with the introduction of the new Birthday calendar in ios4.

Others are also experiencing this problem:

http://discussions.info.apple.com/thread.jspa?messageID=11734996

edit: ah, I see that's your post also...

SGgal
1 post

Wannabe Geek


  #345617 26-Jun-2010 22:09
Send private message

I'm using the iOS 4.0 on my 3G and experienced the same problems. I was quite annoyed by it, so tried tweaking around and found a solution (at least worked for me). This may not be the best way, can be tedious for people with many birth dates stored in their contact list but it's worth a try.

1) Go to your Calendar > tap on the "Calendars" button on top left corner of the screen. This will bring you to the Calendars settings page.

2) Uncheck the selection for "Birthdays" (indicated by the red dot) under the "Others" category, then select "Done".

3) Then go into each and every contact detail on your Contacts list, and edit or re-insert the Birthday date as though you are doing it all over again, even if the date reflected is already correct. (Yes, this can be frustrating if your list is long).

4) When all birthdays are re-input, return to the Calendar and repeat Step 1, only this time, you check to put a tick next to the "Birthdays" option > Click "Done".

This should set the birthday dates right in your calendar again. New dates added after that should be reflected correctly too.


anandpatel18

54 posts

Master Geek


  #345673 27-Jun-2010 08:53
Send private message

Hey thanks, yeah I noticed that when I delete a contacts birthday and add it back the correct date would show in my calendar but not my contacts. Mine worked without having to disable the calendar so yours might as well.

I use a program called myphone+ which syncs my facebook friends to my contacts so I didn't have to add them all bk manually but this was a bit more complex to get it to work. If someone wants me to write the process then just reply.

 
 
 
 


phillw
60 posts

Master Geek


  #345764 27-Jun-2010 13:57
Send private message

Interesting to hear that deleting contacts and adding them again seems to fix this. I would like to see if it holds the fix after a few days as I remember doing this about 6 months ago but the problem came back for me :-(

Just another ongoing issue like the DST problem we had with MobileMe calendars a long time ago.

anandpatel18

54 posts

Master Geek


  #345770 27-Jun-2010 14:27
Send private message

Yeah I think it will only last till I update or do a restore from a backup. There must a problem when it adds the contacts from a backup or something.

phillw
60 posts

Master Geek


  #345773 27-Jun-2010 14:42
Send private message

Bummer :-(
Well hopefully it will be fixed on day. Might be a good idea for as many of us to submit feedback here - http://www.apple.com/feedback/

You never know it might help if enough of us in New Zealand let them know it's a problem.

Behodar
7171 posts

Uber Geek

Trusted
Lifetime subscriber

  #345774 27-Jun-2010 14:50
Send private message

I'm running iOS 3 but I used to have this issue too. I think it went away with OS X 10.6 though. What OS are you running on your computer?

The same problem used to affect my Sony Ericsson phone too (using iSync) but like my iPod it's no longer an issue.

phillw
60 posts

Master Geek


  #345775 27-Jun-2010 14:51
Send private message

I'm running Mac OS 10.6.4 - how many of you are syncing using MobileMe?

Behodar
7171 posts

Uber Geek

Trusted
Lifetime subscriber

  #345776 27-Jun-2010 14:53
Send private message

I'm running 10.6.3 and am not using MM.

anandpatel18

54 posts

Master Geek


  #345777 27-Jun-2010 14:57
Send private message

I'm running windows 7. I submitted a feedback form explaining the bug and putting a link to this forum. Let's hope they actually look lol.

Create new topic





News »

Vodafone enables 5G roaming - for when international travel comes
Posted 30-Oct-2020 15:03


Spark awards funding to Kiwi businesses in 5G funding initiative
Posted 30-Oct-2020 14:58


Huawei launches IdeaHub Pro in New Zealand
Posted 27-Oct-2020 16:41


Southland-based IT specialist providing virtual services worldwide
Posted 27-Oct-2020 15:55


NASA discovers water on sunlit surface of Moon
Posted 27-Oct-2020 08:30


Huawei introduces new features to Petal Search, Maps and Docs
Posted 26-Oct-2020 18:05


Nokia selected by NASA to build first ever cellular network on the Moon
Posted 21-Oct-2020 08:34


Nanoleaf enhances lighting line with launch of Triangles and Mini Triangles
Posted 17-Oct-2020 20:18


Synology unveils DS16211+
Posted 17-Oct-2020 20:12


Ingram Micro introduces FootfallCam to New Zealand channel
Posted 17-Oct-2020 20:06


Dropbox adopts Virtual First working policy
Posted 17-Oct-2020 19:47


OPPO announces Reno4 Series 5G line-up in NZ
Posted 16-Oct-2020 08:52


Microsoft Highway to a Hundred expands to Asia Pacific
Posted 14-Oct-2020 09:34


Spark turns on 5G in Auckland
Posted 14-Oct-2020 09:29


AMD Launches AMD Ryzen 5000 Series Desktop Processors
Posted 9-Oct-2020 10:13









Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.