Geekzone: technology news, blogs, forums
Guest
Welcome Guest.
You haven't logged in yet. If you don't have an account you can register now.




45 posts

Geek


# 70171 19-Oct-2010 20:59
Send private message

My micro-sim finally arrived yesterday and my iPhone 4 is now up and running!  Well mostly.

Internet works fine at work over wifi, and it works fine over 3G.  However at home the internet mostly doesn't work, except occasionally it works very briefly and then stops again.  But it's not a wifi problem, the wifi icon is stable and doesn't disappear when the internet cuts out. 

The laptops and games consoles in the house are all connecting to the internet without problem.  And I had an iPhone 3G before this one, and it worked fine with the home wifi. My network hasn't changed.

Is there a setting in the iPhone I'm missing?  Remember it works fine with wifi at work.  At home I have a WAG310G wireless gateway.

Any help much appreciated!

Create new topic
3 posts

Wannabe Geek


  # 393810 19-Oct-2010 22:17
Send private message

Sorry I can't help Rhinosaur but I'm having exactly the same issue. I too have an iphone 4 and a WAG310G. My old 3GS and ipod 2G worked fine also?

Will not stab you
237 posts

Master Geek

Subscriber

  # 393893 20-Oct-2010 10:16
Send private message

Yep, I have the same thing. iPhone 4,




Recursion: See recursion.
--
“It is important not to let the perfect become the enemy of the good, even when you can agree on what perfect is. Doubly so when you can't. As unpleasant as it is to be trapped by past mistakes, you can't make any progress by being afraid of your own shadow during design.”

     --Greg Hudson, Subversion developer

 
 
 
 


116 posts

Master Geek


  # 393896 20-Oct-2010 10:27
Send private message

I have the same issue with my iPhone 4. No problems with 3GS or computers however.

I just have to use SBS Settings to easily turn wifi on and off 



45 posts

Geek


  # 393902 20-Oct-2010 10:41
Send private message

Well at least I'm not the only one, I guess...

Are you all using the WAG310G?  Xnet Fusion per chance?

And just to confirm:  your wifi is perfectly stable (the ))) icon on the screen doesn't disappear), but your internet isn't working, or is barely working?


862 posts

Ultimate Geek


  # 393905 20-Oct-2010 10:43
Send private message

I had this problem. I stopped using my TomTom so turned off bluetooth and now my wifi works perfectly everywhere...

Will not stab you
237 posts

Master Geek

Subscriber

  # 393911 20-Oct-2010 11:04
Send private message

I am using a WAG160N with Snap.. Laptops all seem okay, just Wifi on the iphone. I also get it a little at the wifi at work, but I do not use it much there.




Recursion: See recursion.
--
“It is important not to let the perfect become the enemy of the good, even when you can agree on what perfect is. Doubly so when you can't. As unpleasant as it is to be trapped by past mistakes, you can't make any progress by being afraid of your own shadow during design.”

     --Greg Hudson, Subversion developer



45 posts

Geek


  # 393932 20-Oct-2010 12:15
Send private message

Thanks for the bluetooth suggestion, but I have bluetooth turned off already so unfortunately that's not the solution for me.

There must be a router setting to adjust? I'm not too network-savvy...
Has anyone tried giving it a static IP?

 
 
 
 


862 posts

Ultimate Geek


  # 393940 20-Oct-2010 12:40
Send private message

Have you tried upgrading to the latest firmware on the router? This will often fix connection issues that were only occuring with one device and not others.



45 posts

Geek


  # 394055 20-Oct-2010 16:44
Send private message

No I haven't, I'll try that tonight.

Actually I just checked their website and version 1.0 is all that's available...

1 post

Wannabe Geek


  # 419210 19-Dec-2010 21:58
Send private message

I'm also having trouble getting wireless access with my iPhone 4 via my WAG310G. Have you found any solutions? Cheers.

402 posts

Ultimate Geek

Trusted

  # 419245 19-Dec-2010 23:20
Send private message

Hi - I can't offer any solutions, sorry, but I have noticed that there were some threads covering this on the Apple discussions site. I seem to recall something about poor performance with certain routers due to the up-specced nature of the iPhones radio chip... and maybe changing the password/encryption type to help. Good luck.

http://discussions.apple.com/forum.jspa?forumID=1141




Cheers,
Mike

Photographer/Videographer clickmedia.nz


BDFL - Memuneh
64690 posts

Uber Geek

Administrator
Trusted
Geekzone
Lifetime subscriber

  # 419251 19-Dec-2010 23:38
Send private message

From what I read in some of those discussions it seems the workaround is to change the router from 11g to 11b... This doesn't seems like "up specs" but more like a faulty implementation - also b is slower than g.






45 posts

Geek


  # 419324 20-Dec-2010 09:53
Send private message

Hi Smithers,

No, no solution unfortunately.  Basically just what ClickNZ said - it seems to be a widely reported problem.  There was speculation (hope) that it would be fixed with the ios 4.2 update, but unfortunately it wasn't.  If I turn off wifi, then turn it back on, I'll sometimes get half a minute of use, but my 'solution' is to leave wifi off and use 3G.  2degrees will be thanking me!

I hadn't heard of the 11b wifi solution, maybe I should give that a try.  For the less savvy among us Embarassed is there a real world disadvantage using the slower protocol, or are broadband speeds still slower than 11b (and still the bottle neck)?  I don't do any file transfers over wifi or anything like that, it's just internet (and printer).



Create new topic



Twitter and LinkedIn »



Follow us to receive Twitter updates when new discussions are posted in our forums:



Follow us to receive Twitter updates when news items and blogs are posted in our frontpage:



Follow us to receive Twitter updates when tech item prices are listed in our price comparison site:





News »

Arlo unveils its first video doorbell
Posted 21-Oct-2019 08:27


New Zealand students shortlisted for James Dyson Award
Posted 21-Oct-2019 08:18


Norton LifeLock Launches Norton 360
Posted 21-Oct-2019 08:11


Microsoft New Zealand Partner Awards results
Posted 18-Oct-2019 10:18


Logitech introduces new Made for Google keyboard and mouse devices
Posted 16-Oct-2019 13:36


MATTR launches to accelerate decentralised identity
Posted 16-Oct-2019 10:28


Vodafone X-Squad powers up for customers
Posted 16-Oct-2019 08:15


D Link ANZ launches EXO Smart Mesh Wi Fi Routers with McAfee protection
Posted 15-Oct-2019 11:31


Major Japanese retailer partners with smart New Zealand technology IMAGR
Posted 14-Oct-2019 10:29


Ola pioneers one-time passcode feature to fight rideshare fraud
Posted 14-Oct-2019 10:24


Spark Sport new home of NZC matches from 2020
Posted 10-Oct-2019 09:59


Meet Nola, Noel Leeming's new digital employee
Posted 4-Oct-2019 08:07


Registrations for Sprout Accelerator open for 2020 season
Posted 4-Oct-2019 08:02


Teletrac Navman welcomes AI tech leader Jens Meggers as new President
Posted 4-Oct-2019 07:41


Vodafone makes voice of 4G (VoLTE) official
Posted 4-Oct-2019 07:36



Geekzone Live »

Try automatic live updates from Geekzone directly in your browser, without refreshing the page, with Geekzone Live now.


Support Geekzone »

Our community of supporters help make Geekzone possible. Click the button below to join them.

Support Geezone on PressPatron



Are you subscribed to our RSS feed? You can download the latest headlines and summaries from our stories directly to your computer or smartphone by using a feed reader.

Alternatively, you can receive a daily email with Geekzone updates.